Electrical Problem - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Join Mustang Evolution Today

Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-16-2015, 10:49 AM   #1
Registered User
Join Date: Mar 2015
Posts: 1
Electrical Problem

Ok well idk if this is the right thread to post but anyways I'll explain. For starters I own a 2001 mustang 3.8 v6. Last thurs it was snowing, my rear tires caught a snow patch and unfortunately lost control of my car. Luckily I manage not to hit anybody as I cut through 3 lanes of empty traffic and had my car spun around. May that point my car was at a complete stop. Next thing I know I see a car behind me (it could've been avoided 100%) the car decides to take the off ramp and hit me. Well now I got myself into an accident as my car is at a complete stop on an off ramp. Blah blah blah cops called and all that. Car was running at the time (it still runs) but I turn the key off as your suppose to. About 30 min I try to start my car but gets no power what's so ever. Cops were telling me to hurry up and all that. So I tell them my car won't start now and now cops called to get my car towed which I did. Once we got off the highway I asked them to see if they can use a jump box to see if I can any type of power to my car. Which I connect it and I get power and low and behold my car even starts! So I was able to drive away with no front bumper which was due to an accident prior. That was my whole ****ty day.

But my questions are to you guys that I'm completely baffled is once the guy behind me hits me my car is still running but I turned it off but minutes later I tried to start it but got no power whats so ever? Once I attached a jump box to my car I got power and my vehicle has started? Also now I have another issue. This happened the day of the accident but it started at night time. Now my dash won't illuminate nor will taillights (parking lamp). Yes I know my fuse is/was blown. I have a ground wiring touching somewhere and have no clue where to look. I recently had my turn signal socket and pigtail replaced bc it was destroyed in the accident. I'm also 100% confident I spliced the wires properly.

Sent from my iPhone using Mustang Evolution
leberj123 is offline   Reply With Quote

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical problem - 2005 2005Aaron 2005-2010 Mustang GT 5 07-27-2009 07:28 AM
electrical problem with my 65 Mustang convertible joeyemma Classic Mustangs 3 04-27-2009 09:42 PM
electrical problem? dave1170 1979-1995 Mustang GT 1 03-11-2008 12:51 PM
Problem with electrical system kitslik Pre-2005 V6 Mustang 4 11-29-2007 10:56 PM

» Like Us On Facebook

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

10:49 AM

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.