WTF is wrong with my taillight? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-10-2016, 10:47 PM   #1
Registered Member
Regular
 
JudenInduven's Avatar
 
Join Date: Nov 2015
Location: Fort Collins
Region: Colorado
Posts: 317
WTF is wrong with my taillight?

I got my smoked Raxiom taillights today (yay) and installed them just fine, but getting some of those clips out was a huge PITA, as was moving all the sandbags out.

Anyways, now my left turn signal is f****d. (All that follows will regard the left taillight.) The signal blinks really fast and only blinks the middle bulb, not the leftmost two. The left amber turn signal up front blinks the same speed. Hazards blink normal speed, but again, only the middle bulb. With the headlights on, it lights up all three bulbs normally. I really need help, since I can't drive the car like this (well, more like I don't want to). But I need to know how to fix it, because my back can't take another round of moving sandbags in and out. I'll post some short videos in a second
__________________
Quote:
Originally Posted by natestang07 View Post
The chargers are slugs lol
2001 3.8L - Cheap SR CAI, SF4/X4 w/ 91 Octane Bama Tuning, Pacesetter H-pipe and Borla Stingers, Auburn HP Limited-Slip Diff, FRPP 4.10 gears

Coming EVENTUALLY: BBK headers, Eibach Springs, FRPP Aluminum Driveshaft, Maximum Motorsports Caster Camber Plates
JudenInduven is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-10-2016, 10:50 PM   #2
Registered Member
Regular
 
JudenInduven's Avatar
 
Join Date: Nov 2015
Location: Fort Collins
Region: Colorado
Posts: 317
This is the turn signal on with the headlights on as well.
Attached Files
__________________
Quote:
Originally Posted by natestang07 View Post
The chargers are slugs lol
2001 3.8L - Cheap SR CAI, SF4/X4 w/ 91 Octane Bama Tuning, Pacesetter H-pipe and Borla Stingers, Auburn HP Limited-Slip Diff, FRPP 4.10 gears

Coming EVENTUALLY: BBK headers, Eibach Springs, FRPP Aluminum Driveshaft, Maximum Motorsports Caster Camber Plates
JudenInduven is offline   Reply With Quote
Old 02-10-2016, 11:21 PM   #3
Registered Member
Regular
 
JudenInduven's Avatar
 
Join Date: Nov 2015
Location: Fort Collins
Region: Colorado
Posts: 317
Pulled the taillight out, took the far left bulb out of its housing and after separating its wires from the middle bulb, it seems to work fine. What went wrong?
__________________
Quote:
Originally Posted by natestang07 View Post
The chargers are slugs lol
2001 3.8L - Cheap SR CAI, SF4/X4 w/ 91 Octane Bama Tuning, Pacesetter H-pipe and Borla Stingers, Auburn HP Limited-Slip Diff, FRPP 4.10 gears

Coming EVENTUALLY: BBK headers, Eibach Springs, FRPP Aluminum Driveshaft, Maximum Motorsports Caster Camber Plates
JudenInduven is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-10-2016, 11:28 PM   #4
Registered Member
Regular
 
JudenInduven's Avatar
 
Join Date: Nov 2015
Location: Fort Collins
Region: Colorado
Posts: 317
Now it's stuck blinking really fast again with the far left bulb not working. It occasionally sparks a bit, but I can't get it to work

With the middle bulb removed, the front turn signal still flashes really fast
__________________
Quote:
Originally Posted by natestang07 View Post
The chargers are slugs lol
2001 3.8L - Cheap SR CAI, SF4/X4 w/ 91 Octane Bama Tuning, Pacesetter H-pipe and Borla Stingers, Auburn HP Limited-Slip Diff, FRPP 4.10 gears

Coming EVENTUALLY: BBK headers, Eibach Springs, FRPP Aluminum Driveshaft, Maximum Motorsports Caster Camber Plates
JudenInduven is offline   Reply With Quote
Old 02-10-2016, 11:51 PM   #5
Registered Member
Regular
 
JudenInduven's Avatar
 
Join Date: Nov 2015
Location: Fort Collins
Region: Colorado
Posts: 317
I think the ****ing idiot that owned my car before me (he removed the right taillight, ****ed up the bumper, spliced in some wires to repair something, I guess, god knows why he didn't leave the factory everything for the right taillight as is) my turn signals already had some bugs, like if they were on for too long sometimes, they'd freeze up and stop blinking, even after repeated cycles of turning them on and off. I'm guessing this is just the straw that broke the camel's back. I have no idea why or how. But, ****, I'm out of ideas and this is extremely frustrating
__________________
Quote:
Originally Posted by natestang07 View Post
The chargers are slugs lol
2001 3.8L - Cheap SR CAI, SF4/X4 w/ 91 Octane Bama Tuning, Pacesetter H-pipe and Borla Stingers, Auburn HP Limited-Slip Diff, FRPP 4.10 gears

Coming EVENTUALLY: BBK headers, Eibach Springs, FRPP Aluminum Driveshaft, Maximum Motorsports Caster Camber Plates
JudenInduven is offline   Reply With Quote
Old 02-11-2016, 12:19 AM   #6
Registered Member
Regular
 
JudenInduven's Avatar
 
Join Date: Nov 2015
Location: Fort Collins
Region: Colorado
Posts: 317
Had a eureka moment. The dual filament in the far left bulb was broken. Must've just slightly aligned sometimes and worked fine. That was causing the middle bulb to blink fast, and since the filament was broken, the far left bulb did not blink with the signal, but worked with the headlights being on. One new taillight later (thank God I still had one from changing my brother's taillight), and everything works perfectly. Still don't know about the turn signals occasionally freezing though, lol I'm just extremely relieved I don't have to go through this process of moving everything again.

BTW, thanks for nothing guys. Just kidding
__________________
Quote:
Originally Posted by natestang07 View Post
The chargers are slugs lol
2001 3.8L - Cheap SR CAI, SF4/X4 w/ 91 Octane Bama Tuning, Pacesetter H-pipe and Borla Stingers, Auburn HP Limited-Slip Diff, FRPP 4.10 gears

Coming EVENTUALLY: BBK headers, Eibach Springs, FRPP Aluminum Driveshaft, Maximum Motorsports Caster Camber Plates
JudenInduven is offline   Reply With Quote
Old 02-11-2016, 12:51 AM   #7
Registered Member
Regular
 
JudenInduven's Avatar
 
Join Date: Nov 2015
Location: Fort Collins
Region: Colorado
Posts: 317
I had my key at START for a while, without starting the car, for the hour that I was trying to fix my taillights, and upon start up, all my gauges went as far right as they could, it said I was revving 7K, doing 120mph, etc. Is this just from the car being at accessories for an hour without the engine being on. The voltmeter said the battery was just fine.

(And sorry to keep posting on this thread, I didn't want to start a new one, since it's related)
__________________
Quote:
Originally Posted by natestang07 View Post
The chargers are slugs lol
2001 3.8L - Cheap SR CAI, SF4/X4 w/ 91 Octane Bama Tuning, Pacesetter H-pipe and Borla Stingers, Auburn HP Limited-Slip Diff, FRPP 4.10 gears

Coming EVENTUALLY: BBK headers, Eibach Springs, FRPP Aluminum Driveshaft, Maximum Motorsports Caster Camber Plates
JudenInduven is offline   Reply With Quote
Old 02-11-2016, 07:33 AM   #8
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,989
When the ecm loses enough power (i.e. leaving your key on) it goes through and does a gauge check. I'm assuming they swept right and then returned to the left position?
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Old 02-11-2016, 11:09 AM   #9
Registered Member
Regular
 
JudenInduven's Avatar
 
Join Date: Nov 2015
Location: Fort Collins
Region: Colorado
Posts: 317
Quote:
Originally Posted by Mile high JDF View Post
When the ecm loses enough power (i.e. leaving your key on) it goes through and does a gauge check. I'm assuming they swept right and then returned to the left position?
Yessir, just for a brief moment, then it returned to where it should've been. But after a bit of driving, it should be fine, right? Unless my alternator is on its way out (which I highly doubt)
__________________
Quote:
Originally Posted by natestang07 View Post
The chargers are slugs lol
2001 3.8L - Cheap SR CAI, SF4/X4 w/ 91 Octane Bama Tuning, Pacesetter H-pipe and Borla Stingers, Auburn HP Limited-Slip Diff, FRPP 4.10 gears

Coming EVENTUALLY: BBK headers, Eibach Springs, FRPP Aluminum Driveshaft, Maximum Motorsports Caster Camber Plates
JudenInduven is offline   Reply With Quote
Old 02-11-2016, 04:05 PM   #10
Registered Member
Regular
 
yogibooboorange's Avatar
 
Join Date: Jun 2015
Location: LaPorte
Region: Indiana
Posts: 65
Try replacing the flasher unit to stop the intermittent freezing. Flasher units get old and worn out. Hope that helps that problem.
yogibooboorange is offline   Reply With Quote
Old 02-11-2016, 06:45 PM   #11
Registered Member
Regular
 
JudenInduven's Avatar
 
Join Date: Nov 2015
Location: Fort Collins
Region: Colorado
Posts: 317
Quote:
Originally Posted by yogibooboorange View Post
Try replacing the flasher unit to stop the intermittent freezing. Flasher units get old and worn out. Hope that helps that problem.
Hmm, I'll look into it, thanks
__________________
Quote:
Originally Posted by natestang07 View Post
The chargers are slugs lol
2001 3.8L - Cheap SR CAI, SF4/X4 w/ 91 Octane Bama Tuning, Pacesetter H-pipe and Borla Stingers, Auburn HP Limited-Slip Diff, FRPP 4.10 gears

Coming EVENTUALLY: BBK headers, Eibach Springs, FRPP Aluminum Driveshaft, Maximum Motorsports Caster Camber Plates
JudenInduven is offline   Reply With Quote
Old 02-11-2016, 06:49 PM   #12
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,989
Quote:
Originally Posted by JudenInduven View Post
Yessir, just for a brief moment, then it returned to where it should've been. But after a bit of driving, it should be fine, right? Unless my alternator is on its way out (which I highly doubt)
Yeah it'll be fine after some driving.
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Old 02-11-2016, 09:00 PM   #13
Road Trip!
Regular
 
Join Date: Jun 2014
Location: Saskatoon, Saskatchewan
Region: Canada
Posts: 1,502
Send a message via Skype™ to Gravydog316
WTF is wrong with my taillight?

yeah, if it blinks really fast, it's usually a bad bulb.
You can notice it on other vehicles, when they are signalling
Gravydog316 is offline   Reply With Quote
Old 02-12-2016, 07:25 AM   #14
Site Sponsor
 
Join Date: May 2014
Location: Malvern, PA
Region: Pennsylvania
Posts: 2,510
Quote:
Originally Posted by yogibooboorange View Post
Try replacing the flasher unit to stop the intermittent freezing. Flasher units get old and worn out. Hope that helps that problem.
Quote:
Originally Posted by JudenInduven View Post
Hmm, I'll look into it, thanks
Quote:
Originally Posted by Gravydog View Post
yeah, if it blinks really fast, it's usually a bad bulb.
You can notice it on other vehicles, when they are signalling
OP - I'd start with the flasher and then the bulb. If it persists let us know and we'll get the taillights replaced for you no questions asked.

Alex
__________________
Alex Lazarus | AmericanMuscle.com
Toll Free: 1-866-363-4591
Bama Hotline: 888.226.9764 | M-F 9AM-5:30PM EST
WIN A SUPERCHARGED MUSTANG & 2017 RAPTOR!
Free Same-Day Shipping!
AMAlexLazarus is offline   Reply With Quote
Old 02-12-2016, 10:58 AM   #15
Registered Member
Regular
 
JudenInduven's Avatar
 
Join Date: Nov 2015
Location: Fort Collins
Region: Colorado
Posts: 317
Quote:
Originally Posted by AMAlexLazarus View Post
OP - I'd start with the flasher and then the bulb. If it persists let us know and we'll get the taillights replaced for you no questions asked.

Alex
That's very kind, Alex, but the new taillights are perfectly fine lol the flasher has been a bit wonky since I got the car. I must've just damaged the bulb changing them from the old housing to the new one
__________________
Quote:
Originally Posted by natestang07 View Post
The chargers are slugs lol
2001 3.8L - Cheap SR CAI, SF4/X4 w/ 91 Octane Bama Tuning, Pacesetter H-pipe and Borla Stingers, Auburn HP Limited-Slip Diff, FRPP 4.10 gears

Coming EVENTUALLY: BBK headers, Eibach Springs, FRPP Aluminum Driveshaft, Maximum Motorsports Caster Camber Plates
JudenInduven is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I was wrong - Really Wrong- Yep I was ronnie948 AmericanMuscle 4 03-09-2013 03:51 PM
I quit... everything, seriously wtf is wrong with people? jimmy_beaner Pictures and Videos 57 07-27-2010 12:08 PM
WTF is wrong with my tuner? Kyle Pre-2005 V6 Mustang 36 11-10-2005 05:03 PM
Crazy Vid, wrong place wrong time Black95GT The Bar 19 06-26-2004 04:38 PM

» Like Us On Facebook



04:06 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.