Dash HVAC illumination - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-11-2016, 06:21 PM   #1
Registered Member
Regular
 
MattMacFarlane's Avatar
 
Join Date: Oct 2014
Location: Moose Jaw
Region: Canada
Posts: 58
Dash HVAC illumination

Ok guys,
It's been a while since I posted about my dash, trac control switch and HVAC lights being dead in my 99. I've done some testing and I can say for certain this the problem seems isolated to the #5 fuse circuit:
1) the cluster is not U/S pictures above
2) I have power at the fuse block
3) I have power at the headlight switch
4) I do not have power at the pigtail that plugs into the back of the cluster in the car.
5) the headlight switch is new

Has anyone had this issue before? Where is this circuit grounded? Is there a place I should start my search effectively? Thanks in advance. RMR5685. Click image for larger version

Name:	ImageUploadedByMustang Evolution1473639597.697417.jpg
Views:	44
Size:	62.2 KB
ID:	205014


Sent from my iPhone using Mustang Evolution
__________________
Live Strong-Drive Hard
MattMacFarlane is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-11-2016, 11:22 PM   #2
Registered Member
Regular
 
Revvv's Avatar
 
Join Date: Apr 2016
Location: Augusta
Region: Georgia
Posts: 2,847
Bumping the thread so it gets noticed. Sorry about your electrical gremlin. I personally would have to chase each side and search for worn insulation, broken wires, or a loose ground. Also make sure all of the wires are firmly in their plugs.
Revvv is offline   Reply With Quote
Old 09-12-2016, 06:19 AM   #3
Registered Member
Regular
 
MattMacFarlane's Avatar
 
Join Date: Oct 2014
Location: Moose Jaw
Region: Canada
Posts: 58
After an of testing and striking out and bring very confused I went back to the fuse block under the dash and pulled every fuse that was associated with the interior illumination and discovered that fuse #37 was defective, I had already replaced it once because it was blown. It wasn't blown it just wasn't carrying any current. Replaced the fuse and now life is good.
Now I just need to figure out why my constant 12v source (Lt Green and purple wire) for the radio isn't working. Already did the fuse block under the dash I'll check the under good ones in the morning.


Sent from my iPhone using Mustang Evolution
__________________
Live Strong-Drive Hard
MattMacFarlane is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-12-2016, 10:34 AM   #4
Registered Member
Regular
 
Revvv's Avatar
 
Join Date: Apr 2016
Location: Augusta
Region: Georgia
Posts: 2,847
Glad to hear about the forward progress on the electrical nightmare.
Revvv is offline   Reply With Quote
Old 09-12-2016, 11:46 AM   #5
Registered Member
Regular
 
MattMacFarlane's Avatar
 
Join Date: Oct 2014
Location: Moose Jaw
Region: Canada
Posts: 58
Now I just need to have the mystery auto starter/security system removed and the associated wires repaired.
As for the stereo situation, in the 99 mustang w Mach 460 the light green and purple wire is hot all the time correct? I do not have power at this wire only at the switched 12v black and pink. I suspect the fuse under the hood is to blame. Thoughts??


Sent from my iPhone using Mustang Evolution
__________________
Live Strong-Drive Hard
MattMacFarlane is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: 11-14 Laser Engraved Wind Deflector w/ Blue Illumination - Running Pony Mean14 Mustang Parts for Sale and Wanted 3 12-07-2015 07:20 PM
Gauge illumination when headlights come on Untamed5.0 2011-2014 Mustang GT 0 02-14-2013 06:25 PM
No trunk illumination? the_stig 2011-2014 V6 Mustang 6 06-25-2012 01:12 PM
1986 mustang guage cluster illumination ? columbanus 1979-1995 Mustang GT 1 12-15-2011 09:19 PM
Mustang Guage Cluster illumination.........? Clifton 1979-1995 Mustang GT 2 12-13-2011 01:01 AM

» Like Us On Facebook



09:56 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.