Speedo Problem??? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-29-2004, 04:38 PM   #1
Registered Member
Regular
 
Join Date: Jan 2004
Posts: 34
Send a message via AIM to v6mustangguy Send a message via Yahoo to v6mustangguy
Speedo Problem???

I was driving my car today, and it was slick (its snowing) so I spun and then like a bit later I looked down and my speedo was stuck at 25 miles per hour...and it just stayed there, then it finally moved down...and I stoped and it went down, then tried to drive again, and it just stayed down on 0. Is that a broken speedo cable? or what?
v6mustangguy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-29-2004, 04:51 PM   #2
Registered Member
Regular
 
Shahrum's Avatar
 
Join Date: Jul 2003
Posts: 614
Send a message via MSN to Shahrum
Do you have gauge overlays?
Shahrum is offline   Reply With Quote
Old 01-29-2004, 07:41 PM   #3
Registered Member
Regular
 
Join Date: Jan 2004
Posts: 34
Send a message via AIM to v6mustangguy Send a message via Yahoo to v6mustangguy
yes...and I tried to drive it since then, and it works fine now? *shrugs*
v6mustangguy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-11-2004, 07:47 PM   #4
Registered Member
Regular
 
Join Date: Jan 2004
Posts: 113
it happens. same thing happens to me when i'm having fun in the snow, then the speedo works fine.
__________________
All pigs are useless!
widowvirgin is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
speedo off k28gt 1996-2004 Mustang GT 19 11-27-2009 02:42 PM
Speedo is off... redbird2289 1996-2004 Mustang GT 14 09-10-2009 08:51 AM
Speedo Problem Justin 1979-1995 Mustang GT 16 02-21-2007 08:37 AM
Car problems continue,Speedo' problem Dark02Pony Pre-2005 V6 Mustang 4 09-22-2005 01:19 PM
I need a speedo jimmy_beaner Mustang Parts for Sale and Wanted 4 05-13-2005 07:21 PM

» Like Us On Facebook



01:19 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.