Help...Temp - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-17-2004, 11:11 PM   #1
Legacy Member
Legacy
 
Black95GT's Avatar
 
Join Date: Jul 2003
Region: New Jersey
Posts: 897
Send a message via AIM to Black95GT
Help...Temp

Two days ago, I was driving, my antifreeze came out the overflow valve, because my car almost overheated, the temp went to normal to hot in 30 seconds and i pulled over and turned it off. I got my thermostat changed and fluid changed. It runs ok, but my temp is going all the way to the L in normal, and before it stayed under the C the whole time, until i pushed it over 3k. I get no heat in my car, nothing is leaking, and the heads and everthing look ok. Please Help.
__________________
-Jason
2003 DSG Cobra -2.2L KB, 60lbs Injectors, Single Blade TB, SCT2400 MAF, Kook's LT's, Kook's High-Flow Catted X-Pipe, Magnaflow CB, JLT RAI, MGW Short-Throw, H&R Race Springs, MM CC Plates, MM Bumpsteer, BF IRS Brace, BF Idlers, and AFS 18 Chrome Reps w/ R888s
Black95GT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-18-2004, 07:32 AM   #2
Ken
Legacy Member
Legacy
 
Ken's Avatar
 
Join Date: May 2003
Region: New Hampshire
Posts: 1,350
Could one of your hoses have become clogged?
__________________
Can't afford Mods? Go To College!
Ken is offline   Reply With Quote
Old 02-18-2004, 08:31 AM   #3
Registered Member
Regular
 
Join Date: Aug 2003
Posts: 567
do a compression test, could be a head gasket and the exhaust is pushing into your coolant lines.
__________________
1998 Subaru Legacy L Sedan
New Hottness

1999 V6 5-speed
14.6 @ 95 w/ 2.22 60'
Wrecked
stangin99 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-18-2004, 08:42 AM   #4
Legacy Member
Legacy
 
Danger Dude's Avatar
 
Join Date: May 2003
Region: South Carolina
Posts: 5,187
Send a message via AIM to Danger Dude
Here are some possibilities. Thermostat is bad, your radiator was not completely full (you have a small leak somewhere) your head gasket is toast (you have a 95 and if it has not been changed well now its time) or your radiator is clogged or deteriorated.

The fact is our cars have a closed coolant system and will overheat if the system is not completely full or has air in it.
__________________
Danger Dude is offline   Reply With Quote
Old 02-18-2004, 11:12 AM   #5
Legacy Member
Legacy
 
Black95GT's Avatar
 
Join Date: Jul 2003
Region: New Jersey
Posts: 897
Send a message via AIM to Black95GT
The top hose gets warm, however the bottom one stays cooled, alot of air came out the lines today, but i am bringing it back to a mechanic, to take a look.
__________________
-Jason
2003 DSG Cobra -2.2L KB, 60lbs Injectors, Single Blade TB, SCT2400 MAF, Kook's LT's, Kook's High-Flow Catted X-Pipe, Magnaflow CB, JLT RAI, MGW Short-Throw, H&R Race Springs, MM CC Plates, MM Bumpsteer, BF IRS Brace, BF Idlers, and AFS 18 Chrome Reps w/ R888s
Black95GT is offline   Reply With Quote
Old 02-18-2004, 11:13 AM   #6
Legacy Member
Legacy
 
Black95GT's Avatar
 
Join Date: Jul 2003
Region: New Jersey
Posts: 897
Send a message via AIM to Black95GT
I don t think its the gasket because my oil is fine and the exhaust isnt smoking.
__________________
-Jason
2003 DSG Cobra -2.2L KB, 60lbs Injectors, Single Blade TB, SCT2400 MAF, Kook's LT's, Kook's High-Flow Catted X-Pipe, Magnaflow CB, JLT RAI, MGW Short-Throw, H&R Race Springs, MM CC Plates, MM Bumpsteer, BF IRS Brace, BF Idlers, and AFS 18 Chrome Reps w/ R888s
Black95GT is offline   Reply With Quote
Old 02-18-2004, 11:21 AM   #7
Legacy Member
Legacy
 
Join Date: May 2003
Posts: 1,895
Send a message via AIM to Rellik Send a message via Yahoo to Rellik
get your cooling system checked by ford. There was a recall in the control module for 94-95's.

Like soemtimes it wouldnt turn the fan on at all, or at the right temp or ect.
Rellik is offline   Reply With Quote
Old 02-18-2004, 11:26 AM   #8
Legacy Member
Legacy
 
Black95GT's Avatar
 
Join Date: Jul 2003
Region: New Jersey
Posts: 897
Send a message via AIM to Black95GT
i got that replaced when i bought the car
__________________
-Jason
2003 DSG Cobra -2.2L KB, 60lbs Injectors, Single Blade TB, SCT2400 MAF, Kook's LT's, Kook's High-Flow Catted X-Pipe, Magnaflow CB, JLT RAI, MGW Short-Throw, H&R Race Springs, MM CC Plates, MM Bumpsteer, BF IRS Brace, BF Idlers, and AFS 18 Chrome Reps w/ R888s
Black95GT is offline   Reply With Quote
Old 02-18-2004, 11:35 AM   #9
Legacy Member
Legacy
 
Black95GT's Avatar
 
Join Date: Jul 2003
Region: New Jersey
Posts: 897
Send a message via AIM to Black95GT
Quote:
Originally Posted by Danger Dude
Here are some possibilities. Thermostat is bad, your radiator was not completely full (you have a small leak somewhere) your head gasket is toast (you have a 95 and if it has not been changed well now its time) or your radiator is clogged or deteriorated.

The fact is our cars have a closed coolant system and will overheat if the system is not completely full or has air in it.
Thermostat was replaced
No sign of Headgasket Failure
I think the Radiator is clogged, because the top hose to the radiator from the engine is hot, the bottom stays cooled. I am having it checked out.
__________________
-Jason
2003 DSG Cobra -2.2L KB, 60lbs Injectors, Single Blade TB, SCT2400 MAF, Kook's LT's, Kook's High-Flow Catted X-Pipe, Magnaflow CB, JLT RAI, MGW Short-Throw, H&R Race Springs, MM CC Plates, MM Bumpsteer, BF IRS Brace, BF Idlers, and AFS 18 Chrome Reps w/ R888s
Black95GT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Temp Gauge not working? BILLFORD01 1996-2004 Mustang GT 5 08-06-2009 12:04 PM
Can a mechanical water temp guege be installed. rob4292 1996-2004 Mustang GT 3 05-17-2007 03:16 PM
Decided to keep Water Temp Guage Ibanezplayer272 1979-1995 Mustang GT 2 02-04-2006 05:52 PM
Autometer Lunar Water Temp Gauge FS stangin99 Mustang Parts for Sale and Wanted 0 05-16-2005 05:11 PM
temp. guage question red pony V6 Pre-2005 V6 Mustang 4 03-28-2005 07:56 PM

» Like Us On Facebook



02:35 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.