Mustang V6 Problem. - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-04-2008, 01:45 PM   #1
Registered User
Newbie
 
Join Date: Oct 2008
Region: Florida
Posts: 1
Exclamation Mustang V6 Problem.

I have a '99 Mustang V6
Ok so this is how the problem started. And pardon my non-technical terms for im new to this.

First my AC compresor fried.
- Had it replaced for a new one.

Now the car is "fine" when the AC is not on. But when I turn it on. Even though the AC is is blowing cold air. The car idles and RPMs drop below normal including a bit of shaking and a ticking sound just like old chevy trucks.
This causes the AC compresor to turn off and on as the RPM goes up and down. When I accelerate everything is just fine. The only thing is when im above 60mph I hear the ticking sound again as if there was a gasket loose in the pipe or something.


My car has a dual exhaust adaptation with Flowmasters but they removed the catalytics, so it has a straight pipe installation. Also the Check Engine light is always on. (im guessing because of the missing catalytics)

I don't know if this is a vacuum leak or a gasket being worn out. Any one that has come across this issue please help.

Thanks in advance.
nexuslair is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-04-2008, 04:29 PM   #2
Legacy Member
Legacy
 
Herbstang's Avatar
 
Join Date: Jan 2005
Region: Florida
Posts: 2,932
Re: Mustang V6 Problem.

Yeah no cats will throw a light .Clean your MAF and check for leaks Who did the A/C install ?? If a shop did it have them check for vacuum leak If you did it re check your install
__________________

Mods-K&N CAI , True Dual Flowmaster 40, BBK Ceramic Shorties, 3.73 , 25% UDP, 3/8 Phenolic Intake Spacer ,Steeda Tri-ax, SCT Chip/Dyno Tune

Quote:
"Some people are like Slinkies; useless, but fun to push down the stairs."
Herbstang is offline   Reply With Quote
Old 10-04-2008, 04:38 PM   #3
Legacy Member
Legacy
 
Herbstang's Avatar
 
Join Date: Jan 2005
Region: Florida
Posts: 2,932
Re: Mustang V6 Problem.

Yeah no cats will throw a light .Clean your MAF and check for leaks Who did the A/C install ?? If a shop did it have them check for vacuum leak If you did it re check your install

check the ac belt tension. adjust the ac idle speed there's a idle adjustment when ac is on (rpm goes up).Check your freon level if it's low the idle will go up and down
__________________

Mods-K&N CAI , True Dual Flowmaster 40, BBK Ceramic Shorties, 3.73 , 25% UDP, 3/8 Phenolic Intake Spacer ,Steeda Tri-ax, SCT Chip/Dyno Tune

Quote:
"Some people are like Slinkies; useless, but fun to push down the stairs."
Herbstang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-11-2008, 01:50 PM   #4
Registered User
Newbie
 
1RNKPNY's Avatar
 
Join Date: Oct 2008
Region: Canada
Posts: 5
Re: Mustang V6 Problem.

Without the Cats in place, (A) the exhaust passes by the sensors so fast that they don't have time to properly get a true reading, and (B) with the OBDII system you will have pre and post O2 sensors. They will read the same thus probably throwing a TWC (3way cat) inefficiency or below threshold codes. The only way to turn the light off is to install high flow cats.
1RNKPNY is offline   Reply With Quote
Old 10-13-2008, 12:40 PM   #5
Registered Member
Regular
 
1234's Avatar
 
Join Date: Feb 2007
Region: Missouri
Posts: 1,292
Re: Mustang V6 Problem.

Or get MIL elimantors. Or a tuner and turn the back sensors off.
__________________
03 GT Charcoal Silver Metallic - Stolen
1234 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
66 Mustang taillight wiring problem mustangmatt_66 Classic Mustangs 3 08-18-2009 06:01 PM
Air Conditioning problem - 96 Mustang V6 WVKarenC 1996-2004 Mustang GT 8 06-15-2009 01:42 AM
Need Help with Rear End Problem on my 70 Mustang blk66stang Classic Mustangs 3 12-03-2008 03:51 PM
06 mustang rearend problem chino mustang 2005-2010 Mustang GT 5 07-11-2007 10:12 PM
05 Mustang GT draw problem mustanggtgirl05 2005-2010 Mustang GT 5 09-24-2006 10:21 PM

» Like Us On Facebook



10:18 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.