Car isnt running good: - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-12-2004, 11:25 PM   #1
Registered User
Newbie
 
Join Date: Mar 2004
Posts: 9
Car isnt running good:

Hey all.

my car hasnt been running very good.
Its been idling a little rough, making some weird noises.
Running a little ****ty, accelerating slow.

I was hopeing there could be something i could do to bring back the life, and acceleration.

I changed the spark plugs, and the spark plug wires, the fuel pump.
I changed the oil, the fuel filter was changed a little while ago, but iam going to change that again.

But what can I do?
Iam willing to go into the engine slighly.
I was thinking about changnign the upper and lower intake to some ported one just for them to flow a little better, and put on some newer/or ne fuel injectors.

I really dont know what to do?

What do u guys do to cars with alot of miles to get them to live again?
__________________
Trying to learn!
MustangNewB is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-12-2004, 11:31 PM   #2
Registered User
 
01mineralgrey6's Avatar
 
Join Date: Jun 2003
Region: Florida
Posts: 1,715
Send a message via AIM to 01mineralgrey6
what year? how many miles? Fuel injector cleaner??? not sure what to say, sounds almost fuel related
__________________
-Tony
'99 cobra 'vert
01mineralgrey6 is offline   Reply With Quote
Old 05-12-2004, 11:32 PM   #3
Registered Member
Regular
 
03redfire cobra's Avatar
 
Join Date: May 2004
Region: Maryland
Posts: 166
Send a message via AIM to 03redfire cobra
you are using the wrong kind of blinker fluid! You need to change it asap or something might break!
__________________
~Evan~ This smiley was named after me-->:evan:

2008 Cadillac Escalade ESV
2006 Chrysler 300c SRT8
03redfire cobra is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-13-2004, 12:06 AM   #4
Zim
You want to **** me?
Legacy
 
Zim's Avatar
 
Join Date: Jun 2003
Location: Kansas City
Region: Missouri
Posts: 4,043
Quote:
Originally Posted by 03redfire cobra
you are using the wrong kind of blinker fluid! You need to change it asap or something might break!
lol..

yeah id try injector cleaner... if it still runs the same after that take it somewhere to have the injectors cleaned professionally. If that still doesnt work, I dont know what to tell ya.
__________________

I like toys
Zim is offline   Reply With Quote
Old 05-13-2004, 12:18 AM   #5
Registered Member
Regular
 
Join Date: May 2003
Region: New Hampshire
Posts: 386
Send a message via AIM to Smokedya95stang
Do you have any leaks?
Exhaust leak? Vacumm leak?
How/where is it idling?

Fuel injectors could be an issue? Whats the mileage on the car?
Whats mods do u have?
__________________
-Charles
Smokedya95stang is offline   Reply With Quote
Old 05-13-2004, 01:10 PM   #6
Road Trip!
 
Tbird232ci's Avatar
 
Join Date: Jun 2003
Region: Maryland
Posts: 1,170
Send a message via AIM to Tbird232ci
clogged cat?
Tbird232ci is offline   Reply With Quote
Old 05-13-2004, 02:11 PM   #7
Registered Member
Regular
 
Shahrum's Avatar
 
Join Date: Jul 2003
Posts: 614
Send a message via MSN to Shahrum
Guys... I know what our good friend is suffering from... because, well... I've been suffering from it too lately... He lost 2 cylinders that he was supposed to have... as soon as he adds those 2 replacement ones to the 6 he currently has, he'll be set!!!
Shahrum is offline   Reply With Quote
Old 05-17-2004, 11:34 AM   #8
Legacy Member
Legacy
 
Rick0636's Avatar
 
Join Date: Jun 2003
Region: North Carolina
Posts: 1,552
Send a message via AIM to Rick0636 Send a message via Yahoo to Rick0636
See Matt at Crossroadzdirect, he now has 99 Cobra Crate engines available, fix you right up .
__________________
Rick Kilpatrick, AAS Automotive Systems Tech, Alamance Community College, Class of 99. 06 5 speed manual Mustang with Pony pkg : GT Mac Mufflers, true duals with one custom pipe. 2.5" system. GT bumper cover, all installed March 7&8 2006. AFE Stage 1 CAI, Motoblue Underdrive pulley, GT aluminum shifter knob, honeycomb rear blackout panel,and dash kit installed. Roush hood scoop and side window louvers installed. SS taillight trim has been installed, new alum. GT steering wheel installed.
Rick0636 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Car wont stay running Mustang1804 1996-2004 Mustang GT 5 06-17-2010 11:59 AM
Vortech supercharger problems car quits running sporter 2005-2010 Mustang GT 15 11-28-2008 06:55 PM
this car isnt a parts car Rellik The Bar 11 10-09-2003 10:04 PM
It sucks not having a running car. : ( slow232 The Bar 0 07-15-2003 11:53 AM

» Like Us On Facebook



08:47 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.