need help really bad !! - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-18-2009, 09:17 PM   #1
Registered User
Newbie
 
Join Date: Aug 2008
Region: Florida
Posts: 12
need help really bad !!

ok i gotta 94 3.8 and at a dead idle the car has a little shake to it and from 800 to 900 rpms it shakes really bad but after that it doesnt.... driver motor mount is cracked but i was told that it wouldnt do that bc of the mount. there are 3 codes that come up as well the first one is for evap valve purge second is cam shaft sensor which i replaced today and it still does it and the third is manufacture controlled air fuel some of the sort..... it runs like crap and i still dont know how to fix it car sucked a half a tank of gas in only 70 miles , all hw driving as well. any and all comments or opinions are greatly appriciated

please help!!!
Mikemx250 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-18-2009, 09:33 PM   #2
Registered User
Regular
 
Brent's Avatar
 
Join Date: May 2003
Region: Tennessee
Posts: 11,873
Re: need help really bad !!

Do you have the exact error codes?
__________________

Reddit
Brent is offline   Reply With Quote
Old 01-18-2009, 09:39 PM   #3
Registered User
Newbie
 
Join Date: Aug 2008
Region: Florida
Posts: 12
Re: need help really bad !!

i didnt write them down but i can get them tomorrow definatly
Mikemx250 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-19-2009, 12:16 AM   #4
Registered User
Newbie
 
longalan2's Avatar
 
Join Date: Jan 2009
Region: Texas
Posts: 14
Re: need help really bad !!

if your purge canister is bad, you have to replace it. for that year it is very important as far as emmissions and engine management. infact if the purge canister is bad, it can build up unfiltered gasses and cause other censors to act up. i hope this helped.
longalan2 is offline   Reply With Quote
Old 01-19-2009, 07:53 AM   #5
Registered User
Newbie
 
Join Date: Aug 2008
Region: Florida
Posts: 12
Re: need help really bad !!

the e vap code has been on in the car for almost a year and no problems with it but the codes that came up brent are
*p0443- e vap valve purge
*p1151 -manufacturer specific dtc

thanks for the info longalan 2.....do you know where that is located the purge canaster?
Mikemx250 is offline   Reply With Quote
Old 01-19-2009, 08:55 AM   #6
Legacy Member
Legacy
 
jimmy_beaner's Avatar
 
Join Date: May 2004
Region: Iowa
Posts: 2,037
Send a message via AIM to jimmy_beaner Send a message via MSN to jimmy_beaner Send a message via Yahoo to jimmy_beaner
Re: need help really bad !!

well... I know p1151 my car has been popping that one with the p1131 for a couple weeks. It's the upstream o2 sensor indicating lean. The most common problem are the precat o2 sensors being bad. I'd try to replace those if I were you, and I hear Motorcraft o2's are the "best" (whatever that means).

P0443 is Evaporative Emission control system purge valve circuit malfunction.
Check all the hoses on your throttle body to make sure they aren't loose or cracked. After fixing those issues, disconnect the battery for about 20 minutes to reset the codes and see if they come back.
__________________

SOLD! 2002 Sonic Blue GT, 5 Speed
Mods: MGW Short Throw Shifter, Mach 1 Brakes
Hypercoated Saleens, Eibach Pro-Kit, Bilstein shocks/struts, Borla Exhaust, Steeda Wing, 03 Cobra hood, Cobra mirrors, 03 Cobra Front Bumper, smoked fogs/headlights, 03 Cobra side skirts, Grill Delete, Mach C-pillars
jimmy_beaner is offline   Reply With Quote
Old 01-19-2009, 10:12 AM   #7
Moderator Emeritus
Legacy
Regular
 
SpectorV's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 26,049
Send a message via AIM to SpectorV
Re: need help really bad !!

also clean your MAF sensor and replace the air filter if needed. The MAF is a very finicky thing so keep it cleaned up.
__________________
2003 Cobra Vert (Redfire) #3938 of 5082 @ 05/27/2003
472rwhp/493rwtq -Modification List - Dyno Sheet
2012 Mustang 3.7L M6 (Kona Blue)
2011 Ford Edge Sport (Red Metallic)
SpectorV is offline   Reply With Quote
Old 01-19-2009, 03:33 PM   #8
Registered User
Newbie
 
Join Date: Aug 2008
Region: Florida
Posts: 12
Re: need help really bad !!

I cleaned the mass air sensor. And the filter is alittle dirty but not too bad.
What would cause it to be so lean? I can also hear a rattle coming from the cats when I rev up the car. Would that have something to do with it ?

n
Mikemx250 is offline   Reply With Quote
Old 01-19-2009, 06:37 PM   #9
Legacy Member
Legacy
 
jimmy_beaner's Avatar
 
Join Date: May 2004
Region: Iowa
Posts: 2,037
Send a message via AIM to jimmy_beaner Send a message via MSN to jimmy_beaner Send a message via Yahoo to jimmy_beaner
Re: need help really bad !!

Quote:
Originally Posted by Mikemx250 View Post
I cleaned the mass air sensor. And the filter is alittle dirty but not too bad.
What would cause it to be so lean? I can also hear a rattle coming from the cats when I rev up the car. Would that have something to do with it ?

n
check for exhaust leaks... and perhaps think of replacing the front o2's
__________________

SOLD! 2002 Sonic Blue GT, 5 Speed
Mods: MGW Short Throw Shifter, Mach 1 Brakes
Hypercoated Saleens, Eibach Pro-Kit, Bilstein shocks/struts, Borla Exhaust, Steeda Wing, 03 Cobra hood, Cobra mirrors, 03 Cobra Front Bumper, smoked fogs/headlights, 03 Cobra side skirts, Grill Delete, Mach C-pillars
jimmy_beaner is offline   Reply With Quote
Old 01-20-2009, 08:55 AM   #10
Registered User
Newbie
 
Join Date: Aug 2008
Region: Florida
Posts: 12
Re: need help really bad !!

Ok , as of yesterday I replaced the motor mounts and have a trans mount on the way.At a dead idle the car doesnt shake, but then from 800 to a grand, it has the death shake and driving its from just under 1 grand and to 1200. Wednesday im replacing the trans mount and ill see what happens...And i checked for exhaust leaks ,the only on i found is the muffler in the bottom and i think the cats are going bad as well guessing from the rattle. Probably from the rich air mixture and it frying everything in there. Last night i left the battery unplugged for the night and reconnected it this morning and the check engine light stayed off for quite a while, but the car still ran the same and later came back on. Jimmy, has your car had a rough idle as well bc of that same code the p 1151? if not, then it might be the evap canister or even the trans mount but ill find out if its the trans mount late wednesday night and post the results...
Mikemx250 is offline   Reply With Quote
Old 01-20-2009, 11:18 AM   #11
Legacy Member
Legacy
 
Herbstang's Avatar
 
Join Date: Jan 2005
Region: Florida
Posts: 2,932
Re: need help really bad !!

The P1151 Code according to this source should not effect drivability

OBD Trouble Code: P1151 Lack of HO2S-21 Switch, Sensor Indicates Lean

The PO443 will cause a rough running engine if the purge valve is stuck open

OBD-II Trouble Code: P0443 Evaporative Emission Control System Purge Control Valve Circuit
__________________

Mods-K&N CAI , True Dual Flowmaster 40, BBK Ceramic Shorties, 3.73 , 25% UDP, 3/8 Phenolic Intake Spacer ,Steeda Tri-ax, SCT Chip/Dyno Tune

Quote:
"Some people are like Slinkies; useless, but fun to push down the stairs."
Herbstang is offline   Reply With Quote
Old 01-20-2009, 12:31 PM   #12
Legacy Member
Legacy
 
MonteCitan's Avatar
 
Join Date: Aug 2004
Region: California
Posts: 2,506
Send a message via AIM to MonteCitan
Re: need help really bad !!

As per above, while the lack of switching in itself may not affect the performance of the car, a massive intake leak will

What did you clean your Mass Airflow with?

Also, spray some fuel injection/carb cleaner around the engine bay, specifically the gaskets at the throttle body/ around the upper and lower intake manifolds.. you'll know right away if you've got a leak at any of those spots, car's idle will change completely...
__________________
2012 IS F Blue IS F Sport
2006 Mustang V6 wannabe
MonteCitan is offline   Reply With Quote
Old 01-20-2009, 08:06 PM   #13
Registered User
Newbie
 
Join Date: Aug 2008
Region: Florida
Posts: 12
Re: need help really bad !!

i cleaned the MAF with MAF cleaner from auto zone... after the death shake car runs smooth and there has been no noticible performance loss


now the purge valve that idk if its stuck open....anyone know how to check if it is?
Mikemx250 is offline   Reply With Quote
Old 01-21-2009, 07:24 AM   #14
Legacy Member
Legacy
 
Herbstang's Avatar
 
Join Date: Jan 2005
Region: Florida
Posts: 2,932
Re: need help really bad !!

Quote:
Originally Posted by Mikemx250 View Post
i cleaned the MAF with MAF cleaner from auto zone... after the death shake car runs smooth and there has been no noticible performance loss


now the purge valve that idk if its stuck open....anyone know how to check if it is?
To locate and check this valve, first find the charcoal canister, it will be a round or rectangular black plastic "box" with several different size hoses attached to it. If in doubt that you've found it, look at the bottom, there will be a plastic foam filter there---make sure it is not plugged up---. Once you've located the canister, start following the hoses attached to it. One will go towards the engine, follow that one along until you find the control valve that it attaches to, that's the valve that's not operating. Several things you can do now, just buy a new one and hope it is not the wiring or computer that's at fault. If you want to check it and the wiring, first, with key off, disconnect the two wire connector from it. Use a 12 volt test lamp, turn the key to "run" and check for current at both wires in the connector, one sould have current. Next, connect the test lamp between the two wires in the connector, start the engine and let it warm up, then run the engine up to around 1500 RPM or so, the test light should come on, if it doesn't, then it is the wire that was "cold" when you checked for power at the connector. or the computer. If the light comes on, then it is the valve. Remove it from the vehicle and clean it with an aerosol can of carburetor cleaner,use the "straw" that comes with the can and spray the cleaner into both hose nipples on the valve, alternatly spraying and shaking the valve. When you no longer get brown "gunk" coming out of the valve, reinstall it in the vehicle, but leave, if possible, the hose from the cannister disconnected. Start the car and let it warm up, (if need be), now raise the RPMs to 1500 or so. valve should now open and a vacuum should be present at the open nipple.
__________________

Mods-K&N CAI , True Dual Flowmaster 40, BBK Ceramic Shorties, 3.73 , 25% UDP, 3/8 Phenolic Intake Spacer ,Steeda Tri-ax, SCT Chip/Dyno Tune

Quote:
"Some people are like Slinkies; useless, but fun to push down the stairs."
Herbstang is offline   Reply With Quote
Old 01-21-2009, 06:05 PM   #15
Registered User
Newbie
 
Join Date: Aug 2008
Region: Florida
Posts: 12
Re: need help really bad !!

Ok now I hate my car. Now I don't have 2nd or 4th gear. Just another thing going bad to make my day worse
Mikemx250 is offline   Reply With Quote
Old 01-22-2009, 04:12 PM   #16
Registered User
Newbie
 
Join Date: Aug 2008
Region: Florida
Posts: 12
Re: need help really bad !!

ok today i hooked up a diagnostic computer and found out cylinders 2 5 and 6 miss fireing... replaced the coil and still had the same results...the plugs arent fawled and the wires are good.... also trans wont go into 2nd or forth gear..and reverse occasionally. Considering just buying a whole new motor and trans anyone know of where i can get a good deal on one?
Mikemx250 is offline   Reply With Quote
Old 01-22-2009, 04:14 PM   #17
Registered User
Regular
 
Brent's Avatar
 
Join Date: May 2003
Region: Tennessee
Posts: 11,873
Re: need help really bad !!

What is your budget?
__________________

Reddit
Brent is offline   Reply With Quote
Old 01-23-2009, 07:47 AM   #18
Registered User
Newbie
 
longalan2's Avatar
 
Join Date: Jan 2009
Region: Texas
Posts: 14
Re: need help really bad !!

ebay. i picked up an 06 4.0 with automatic tranny with 12,000 miles on them for 350 plus s&h. the shipping was another 300, but i got the eng and tran for a total of $650. i would say that ebay would be your best bet.
longalan2 is offline   Reply With Quote
Old 01-23-2009, 10:41 AM   #19
Legacy Member
Legacy
 
Scut95's Avatar
 
Join Date: May 2005
Region: California
Posts: 501
Re: need help really bad !!

Quote:
ebay. i picked up an 06 4.0 with automatic tranny with 12,000 miles on them for 350 plus s&h. the shipping was another 300, but i got the eng and tran for a total of $650. i would say that ebay would be your best bet.
That's a really good find assuming everything is sound mechanically.
__________________

95 GT- Sold
09 Hyundai Elantra Touring-new ride.
Looking for the next project car now
Scut95 is offline   Reply With Quote
Old 01-23-2009, 10:50 AM   #20
Legacy Member
Legacy
 
jimmy_beaner's Avatar
 
Join Date: May 2004
Region: Iowa
Posts: 2,037
Send a message via AIM to jimmy_beaner Send a message via MSN to jimmy_beaner Send a message via Yahoo to jimmy_beaner
Re: need help really bad !!

Quote:
Originally Posted by Mikemx250 View Post
ok today i hooked up a diagnostic computer and found out cylinders 2 5 and 6 miss fireing... replaced the coil and still had the same results...the plugs arent fawled and the wires are good.... also trans wont go into 2nd or forth gear..and reverse occasionally. Considering just buying a whole new motor and trans anyone know of where i can get a good deal on one?
push that ****er into a lake
__________________

SOLD! 2002 Sonic Blue GT, 5 Speed
Mods: MGW Short Throw Shifter, Mach 1 Brakes
Hypercoated Saleens, Eibach Pro-Kit, Bilstein shocks/struts, Borla Exhaust, Steeda Wing, 03 Cobra hood, Cobra mirrors, 03 Cobra Front Bumper, smoked fogs/headlights, 03 Cobra side skirts, Grill Delete, Mach C-pillars
jimmy_beaner is offline   Reply With Quote
Old 01-23-2009, 10:52 AM   #21
15.3 Second V8 Killer Yo
Legacy
Regular
 
PureVenom's Avatar
 
Join Date: Aug 2004
Region: Louisiana
Posts: 7,212
Send a message via AIM to PureVenom Send a message via MSN to PureVenom Send a message via Yahoo to PureVenom
Re: need help really bad !!

Better yet...take it out to the swamps...they'll never find it.
__________________
"When I know more, I'll be forthcoming. Or I won't be forthcoming, and I'll be honestly deceptive." - Les Miles
PureVenom is offline   Reply With Quote
Old 01-23-2009, 10:53 AM   #22
Legacy Member
Legacy
 
jimmy_beaner's Avatar
 
Join Date: May 2004
Region: Iowa
Posts: 2,037
Send a message via AIM to jimmy_beaner Send a message via MSN to jimmy_beaner Send a message via Yahoo to jimmy_beaner
Re: need help really bad !!

Quote:
Originally Posted by PureVenom View Post
Better yet...take it out to the swamps...they'll never find it.
at least my car is mostly functional when it throws codes. That thing is just getting ready to take a **** on life.
__________________

SOLD! 2002 Sonic Blue GT, 5 Speed
Mods: MGW Short Throw Shifter, Mach 1 Brakes
Hypercoated Saleens, Eibach Pro-Kit, Bilstein shocks/struts, Borla Exhaust, Steeda Wing, 03 Cobra hood, Cobra mirrors, 03 Cobra Front Bumper, smoked fogs/headlights, 03 Cobra side skirts, Grill Delete, Mach C-pillars
jimmy_beaner is offline   Reply With Quote
Old 01-23-2009, 11:18 AM   #23
Registered Member
Regular
 
hottcobra's Avatar
 
Join Date: May 2007
Region: Louisiana
Posts: 2,638
Re: need help really bad !!

the common fix for those codes are a match and 5 gals. of gas
__________________

2006 Mustang GT lots of mods ex wife has it
1979 corvette stingray #'s matching 47K org. miles
1970Chevelle SS 454 big block Old School 500hp Sold
hottcobra is offline   Reply With Quote
Old 01-23-2009, 11:22 AM   #24
Legacy Member
Legacy
 
jimmy_beaner's Avatar
 
Join Date: May 2004
Region: Iowa
Posts: 2,037
Send a message via AIM to jimmy_beaner Send a message via MSN to jimmy_beaner Send a message via Yahoo to jimmy_beaner
Re: need help really bad !!

Quote:
Originally Posted by hottcobra View Post
the common fix for those codes are a match and 5 gals. of gas
__________________

SOLD! 2002 Sonic Blue GT, 5 Speed
Mods: MGW Short Throw Shifter, Mach 1 Brakes
Hypercoated Saleens, Eibach Pro-Kit, Bilstein shocks/struts, Borla Exhaust, Steeda Wing, 03 Cobra hood, Cobra mirrors, 03 Cobra Front Bumper, smoked fogs/headlights, 03 Cobra side skirts, Grill Delete, Mach C-pillars
jimmy_beaner is offline   Reply With Quote
Old 02-16-2009, 08:24 PM   #25
Registered User
Newbie
 
Join Date: Feb 2009
Posts: 12
Re: need help really bad !!

ok hey everyone i am mikemx250's buddy who now is the owner of the mustang i replaced the o2's the throtle body 2 injectors werent firing replaced them when mike said he had no exhaust leak he was mistaken the headers were barely held on by about 3 bolts on each side of the block the evap purge i will test tommorow i replaced the plug wired cause they were still dated from 1995 so i figured they were old the plugs replaced i got a crank sensor and still a death shake the trans tho i fixed he put a short throw shifter on and didnt tighten all the bolts so yea still need help with this thing tho i work at the local mazda and dodge dealerships and we cant figure this damn thing out for the life of us well hope for help
thanks yall
bobby
bmxrr1990 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
This guy is having a bad day... A really, really bad day JROC The Bar 15 08-16-2007 11:52 PM
When things go bad... they really go bad for some people Brent The Bar 8 12-13-2006 10:31 PM
I want it so bad. Dom Mustang Audio & Video 22 04-26-2006 08:54 AM
Bad Fox, Bad Thomas91169 The Bar 17 11-23-2005 07:24 AM
Hillarys such a bad bad girl.... Brent The Bar 24 03-31-2005 05:41 PM

» Like Us On Facebook



05:42 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.