NEED HELP NOW!!!!! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-30-2006, 07:40 PM   #1
Registered Member
Regular
 
Join Date: Feb 2005
Region: Kansas
Posts: 36
NEED HELP NOW!!!!!

Ok, I still cant figure out what is wrong with my stang. It is a 94 GT vert. I have replaced the fuel filter, Cap, Rotor, Coil, plugs, Wires,K&N filter, put seafoam in it, Fuel system cleaner, heet, replaced upper and lower intake gaskets, cleaned the egr, new coolent temp sensor, reset the computer, and the fuel pressure at idel is between 32 and 34. The car has no torque or hp. Im getting the code that both banks are running lean and the egr is staying closed. I try replacing the egr sensor and still got the code so i took it back. I cant figure it out the car is timed perfectly at 10 degrees. that car kind of has a rough idel like it has a cam in it. the owner before me had the tranny and a cobra short block put in it. cam is a cobra cam if that matters. I need help, im getting ready to go just light the ***** on fire.
95 DrOpToP is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-30-2006, 07:42 PM   #2
Registered User
Regular
 
Brent's Avatar
 
Join Date: May 2003
Region: Tennessee
Posts: 11,873
Re: NEED HELP NOW!!!!!

Quote:
I need help, im getting ready to go just light the ***** on fire.


Quote of the day

Does it have a tune to take into account the Cobra Cam?
__________________

Reddit
Brent is offline   Reply With Quote
Old 10-30-2006, 07:44 PM   #3
Registered Member
Regular
 
Join Date: Feb 2005
Region: Kansas
Posts: 36
Re: NEED HELP NOW!!!!!

no i wasnt sure how much different the cam was from a normal gt.
95 DrOpToP is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-30-2006, 07:47 PM   #4
Registered Member
Regular
 
Join Date: Jul 2006
Region: South Carolina
Posts: 996
Re: NEED HELP NOW!!!!!

The best thing I can tell you is to take it to a shop with a good reputation, but thats probably not what you wanted to hear. :dunno:
JROC is offline   Reply With Quote
Old 10-30-2006, 07:48 PM   #5
Legacy Member
Legacy
 
bbunt302's Avatar
 
Join Date: Jun 2004
Region: Texas
Posts: 2,459
Send a message via AIM to bbunt302
Re: NEED HELP NOW!!!!!

The main thing you need look at is the MAF and injectors. Make sure that the MAF is correctly calibrated for whatever size injectors it has. To do so, first look at the injectors. Stock 19# injectors are a tan color. 24# injectors are green or blue (not sure which). 30# injectors are red. I seriously doubt it has any bigger than that (or even that big).

Next, get the part number off the MAF and post it up. I'll see if I can look it up and see what it is calibrated for. Also, is that fuel pressure with the vacuum line on the fuel pressure regulator on or off? If it is with it off... that is kinda low. I would turn it up to around 45 psi. If you don't already have an adjustable fuel pressure regulator, get one. They are cheap and very handy.

The cam should not be an issue. The Cobra cam is actually milder than the stock 5.0L cam.
__________________

Scary stuff.
bbunt302 is offline   Reply With Quote
Old 10-30-2006, 07:49 PM   #6
Registered Member
Regular
 
Join Date: Feb 2005
Region: Kansas
Posts: 36
Re: NEED HELP NOW!!!!!

i had it into rusty eck ford, but i guess you said a good shop. im going to take it somewhere if i cant get it running right this next paycheck.
95 DrOpToP is offline   Reply With Quote
Old 10-30-2006, 07:52 PM   #7
Registered Member
Regular
 
Join Date: Feb 2005
Region: Kansas
Posts: 36
the MAF is fine, i even switched it out with my v6 stang to see if it was the prob but it still ran the same. i also have notice the engine seems to be running colder than it should(why i changed the coolent sensor) but even after the change its running a little lower than my v6 with a 180 in it.
95 DrOpToP is offline   Reply With Quote
Old 10-30-2006, 07:54 PM   #8
Registered User
Regular
 
Brent's Avatar
 
Join Date: May 2003
Region: Tennessee
Posts: 11,873
Re: NEED HELP NOW!!!!!

Is it just me or should the MAF off a GT not work with a V6? The GT has larger injectors no? If it runs fine in a V6 could that not be your problem then?

Or did you recalibrate it for the V6?
__________________

Reddit
Brent is offline   Reply With Quote
Old 10-30-2006, 07:59 PM   #9
Registered Member
Regular
 
Join Date: Feb 2005
Region: Kansas
Posts: 36
Re: NEED HELP NOW!!!!!

i beleve that they were the same size and both had 19 injectors.
95 DrOpToP is offline   Reply With Quote
Old 10-30-2006, 08:11 PM   #10
Legacy Member
Legacy
 
bbunt302's Avatar
 
Join Date: Jun 2004
Region: Texas
Posts: 2,459
Send a message via AIM to bbunt302
Re: NEED HELP NOW!!!!!

Uh yeah... you really shouldn't just swap a GT and V6 MAF. I would imagine the fuel mappings are entirely different. Also, how cold is cold? If it's running more than 180* I wouldn't worry about it.
__________________

Scary stuff.
bbunt302 is offline   Reply With Quote
Old 10-30-2006, 08:21 PM   #11
Registered User
Regular
 
Brent's Avatar
 
Join Date: May 2003
Region: Tennessee
Posts: 11,873
Re: NEED HELP NOW!!!!!

Quote:
Originally Posted by 95 DrOpToP View Post
i beleve that they were the same size and both had 19 injectors.
94-98 V6 Mustangs have 14# injectors
99-2004 Mustangs have 21# injectors

So the MAF shouldn't work just based on that bit of information.
__________________

Reddit
Brent is offline   Reply With Quote
Old 10-30-2006, 08:26 PM   #12
Registered Member
Regular
 
Join Date: Feb 2005
Region: Kansas
Posts: 36
Re: NEED HELP NOW!!!!!

i still have my v6 on on the gt cuz they ran the same. maybe thats my problem. i already sold the 6 but i didnt it to someone in town and they have to bring the car over so i can put the new side mirror and finder badges on. oops.
95 DrOpToP is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:39 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.