302 tick - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-15-2011, 11:41 PM   #1
Registered Member
Regular
 
Join Date: Jan 2011
Region: Canada
Posts: 55
302 tick

I have a 302 4bbl in my 79 mustang, I just replaced the camshaft and now I have a tick that increases with rpm that wasnt there before. When I installed the cam I torqued the rocker bolts with valves closed. I did use different pushrods is it possible that oil isnt passing through them and us causing a tick? Thanks for you help guys. Kevin.
Dexter is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-15-2011, 11:56 PM   #2
Registered User
Newbie
 
Join Date: Apr 2011
Region: Canada
Posts: 3
Did you check if your header bolts are tight? I had the same sound and it was loose header bolts! Hope it ain't a bottom end problem
BackhalvedLX is offline   Reply With Quote
Old 04-16-2011, 03:09 AM   #3
Road Trip!
 
Join Date: Dec 2010
Region: Other
Posts: 2,268
Re: 302 tick

Probably not a bottom end problem. Did you reuse the lifters? Probably just a sticky lifter.
93CobraGuy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-16-2011, 07:49 AM   #4
Registered Member
Regular
 
stampde's Avatar
 
Join Date: Oct 2010
Location: Manalapan
Region: New Jersey
Posts: 1,880
Re: 302 tick

I'd go back and re torque the rockers , and also check for a header leak like backhalved said ..... also run it a little bit could be a sticky lifter ??
__________________
2011 GT Auto
stampde is offline   Reply With Quote
Old 04-16-2011, 11:01 AM   #5
Registered Member
Regular
 
wereKEV's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 1,863
Re: 302 tick

If you run it for a while ,if it is a lifter it might loosen itself up .
wereKEV is offline   Reply With Quote
Old 04-16-2011, 12:17 PM   #6
Titus Wadicus
Regular
 
svtlx's Avatar
 
Join Date: Jan 2007
Region: Ohio
Posts: 2,103
Send a message via Yahoo to svtlx
Re: 302 tick

sounds like a bad lifter if it isnt an exhaust leak.
__________________

bbk ssi, 70ml t.b., bbk adj.reg., bd11-a 11psi, e-cam,
racing aod, 2700 stall, 3.42 gears, ported e7, 308ci, 1.7rr, comp .560valve springs, gear drive, high dwell module, msd 6a & coil, bbk off road xpipe, mac cat back, 30lbs inj, pro-m 90mm, welded subframe connectors, boxed upper & lower trailing arms, spherical axle bushings, 255/50/16 tires, 255lph pump, 456hp
svtlx is offline   Reply With Quote
Old 04-16-2011, 12:21 PM   #7
Registered Member
Regular
 
wereKEV's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 1,863
Re: 302 tick

If it's clicking it could also be a bad plug wire arcing also.
wereKEV is offline   Reply With Quote
Old 04-16-2011, 08:16 PM   #8
Registered Member
Regular
 
Join Date: Jan 2011
Region: Canada
Posts: 55
Wow listen to this, I took the intake and valve covers off to discover that I had bent 6 pushrods!! The weird thing is that they went bent when they went in. I guess I'm gonna have to get some stronger rods. Thanks for all the replys guys I like posting here.
Dexter is offline   Reply With Quote
Old 04-16-2011, 08:57 PM   #9
Titus Wadicus
Regular
 
svtlx's Avatar
 
Join Date: Jan 2007
Region: Ohio
Posts: 2,103
Send a message via Yahoo to svtlx
Re: 302 tick

how big is the cam? did u clay the pistons before u put it together all the way? i wonder if your valves are hitting the pistons causing the the pushrods to bend. just a thought sense u said u did a cam swap.
__________________

bbk ssi, 70ml t.b., bbk adj.reg., bd11-a 11psi, e-cam,
racing aod, 2700 stall, 3.42 gears, ported e7, 308ci, 1.7rr, comp .560valve springs, gear drive, high dwell module, msd 6a & coil, bbk off road xpipe, mac cat back, 30lbs inj, pro-m 90mm, welded subframe connectors, boxed upper & lower trailing arms, spherical axle bushings, 255/50/16 tires, 255lph pump, 456hp
svtlx is offline   Reply With Quote
Old 04-17-2011, 10:17 AM   #10
Registered Member
Regular
 
wereKEV's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 1,863
Re: 302 tick

that's true iy must be a piston hitting something to bend a push rod .
wereKEV is offline   Reply With Quote
Old 04-17-2011, 10:42 AM   #11
Legacy Member
Legacy
 
bbunt302's Avatar
 
Join Date: Jun 2004
Region: Texas
Posts: 2,459
Send a message via AIM to bbunt302
You also need to measure to ensure you have the correct length pushrods.
__________________

Scary stuff.
bbunt302 is offline   Reply With Quote
Old 04-17-2011, 11:21 AM   #12
Registered Member
Regular
 
wereKEV's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 1,863
Re: 302 tick

Thats for sure otherwise you will be pulling it apart again to fix the f ups.
wereKEV is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
302 Blackpony Classic Mustangs 6 12-21-2010 10:05 PM
i have a 66 302 need help guitarsav276 Classic Mustangs 5 03-30-2010 08:52 AM
Got the 302 SC_STEEDA Classic Mustangs 1 03-09-2010 07:59 PM
68 302 V8.. Fishers Stang Classic Mustangs 13 04-27-2006 06:57 PM
tick in new motor? hoof Pre-2005 V6 Mustang 6 04-27-2005 07:09 AM

» Like Us On Facebook



11:10 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.