Runs and dies - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-21-2011, 06:46 PM   #1
Registered Member
Regular
 
SportySpice's Avatar
 
Join Date: Jan 2011
Region: New York
Posts: 56
Runs and dies

88 5.0
So it was almost 100 degrees today and i drove the car about 30 miles, shut it off for half hr and when i started it again it started hard and idled weird till i revved it. Driving for 5 mins it starts running rough and dies and did this about 5 times till i towed it home. Was it just too hot today? Ideas? Thanks
SportySpice is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-21-2011, 07:00 PM   #2
Registered Member
Regular
 
90blue5.0gt's Avatar
 
Join Date: Dec 2010
Region: Alabama
Posts: 62
Probably the ignition module it may be doing it
90blue5.0gt is offline   Reply With Quote
Old 07-21-2011, 07:02 PM   #3
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: Runs and dies

May be the pickup coil in the distributor.
Did you check your coolant level, oil?
Trojan Horse is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-21-2011, 07:41 PM   #4
Registered Member
Regular
 
SportySpice's Avatar
 
Join Date: Jan 2011
Region: New York
Posts: 56
The was no coolant in the jug but the fluid that was in the radiator was a rust color? And i had just put some oil into it bc it burns it up, and sometimes oil pressure drops when i come to a stop but goes back to normal when i take off?
SportySpice is offline   Reply With Quote
Old 07-21-2011, 08:43 PM   #5
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: Runs and dies

Quote:
Originally Posted by SportySpice View Post
The was no coolant in the jug but the fluid that was in the radiator was a rust color? And i had just put some oil into it bc it burns it up, and sometimes oil pressure drops when i come to a stop but goes back to normal when i take off?
The oil pressure drop is a sign of worn out main, rod & cam bearings and oil pump.
Burning oil is a sign of worn out rings and pistons.
The rust shows that the cooling system hasn't been flushed for quite some time. The coolant in the overflow tank should be up to the level indicated on the outside of the tank.

I'd say you are very close to needing a rebuild or new engine.
Trojan Horse is offline   Reply With Quote
Old 07-23-2011, 09:52 AM   #6
Registered Member
Regular
 
stampde's Avatar
 
Join Date: Oct 2010
Location: Manalapan
Region: New Jersey
Posts: 1,880
Re: Runs and dies

Quote:
Originally Posted by Trojan Horse View Post
The oil pressure drop is a sign of worn out main, rod & cam bearings and oil pump.
Burning oil is a sign of worn out rings and pistons.
The rust shows that the cooling system hasn't been flushed for quite some time. The coolant in the overflow tank should be up to the level indicated on the outside of the tank.

I'd say you are very close to needing a rebuild or new engine.
+1
but back to your problem , Ignition module or possibly fuel vapor lock
__________________
2011 GT Auto
stampde is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:02 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.