turn signals - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-08-2011, 08:49 PM   #1
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
turn signals

i dont have any turn signals.if i turn on the hazards all 4 corners flash.when i bought the car it came with a new lever mechanism,so i thought that maybe the previous owner thought that that was the problem so i changed it.i also checked the fuse.any other ideas what could be wrong?
dreamstang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-08-2011, 09:46 PM   #2
Registered Member
Regular
 
00STANG00's Avatar
 
Join Date: Oct 2009
Location: Gonzales
Region: Louisiana
Posts: 801
Send a message via AIM to 00STANG00 Send a message via Yahoo to 00STANG00
a switch
__________________
SUCK MY DUST
00STANG00 is offline   Reply With Quote
Old 09-09-2011, 04:11 AM   #3
Registered Member
Regular
 
robb15033's Avatar
 
Join Date: Oct 2010
Location: Northern Virginia
Region: Virginia
Posts: 2,109
Re: turn signals

Its called the "multifunction switch"
Its the turn signal handle you use to turn on turn signals, control wiper speed ect...
__________________
'97 3.8L V6
Pacific Green
1996 SVT Cobra White
robb15033 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-09-2011, 05:03 AM   #4
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Quote:
Originally Posted by robb15033
Its called the "multifunction switch"
Its the turn signal handle you use to turn on turn signals, control wiper speed ect...
Yeah that.lol.I changed it.
dreamstang is offline   Reply With Quote
Old 09-09-2011, 06:00 AM   #5
Registered Member
Regular
 
Rocco4.6's Avatar
 
Join Date: Jul 2011
Region: Illinois
Posts: 114
What year is your car?
Rocco4.6 is offline   Reply With Quote
Old 09-09-2011, 11:15 AM   #6
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Quote:
Originally Posted by Rocco4.6
What year is your car?
88
dreamstang is offline   Reply With Quote
Old 09-09-2011, 03:36 PM   #7
Registered Member
Regular
 
94 Mustang GT's Avatar
 
Join Date: Jan 2011
Region: Minnesota
Posts: 165
It's gotta be wiring. If your wipers work and the multi function switch is new and not used.
__________________
1994 Mustang GT
Bought for $2200,Had 97K miles,New fuel tank,New driver front hub,New pass ball joint,New alt, New battery,New fog lights,New plastic bezel shifter,Fixed check engine light,New tires,Coolant flush,Magnaflow exhaust. Its starting to come together towards stock THEN I will make it go FAST!
94 Mustang GT is offline   Reply With Quote
Old 09-09-2011, 03:41 PM   #8
Registered Member
Regular
 
00STANG00's Avatar
 
Join Date: Oct 2009
Location: Gonzales
Region: Louisiana
Posts: 801
Send a message via AIM to 00STANG00 Send a message via Yahoo to 00STANG00
under the driver side dashboard there switchs a round one try changing that its back up lights but never know what else its used for or look in the trunk for another one some where by the fuel button
__________________
SUCK MY DUST
00STANG00 is offline   Reply With Quote
Old 09-09-2011, 06:40 PM   #9
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Everything else on the multifunction switch works fine.ill start checking into the wiring

---------- Post added at 06:40 PM ---------- Previous post was at 06:37 PM ----------

Is it possible that that hazard switch is bad since the signals and hazards are linked together.I think I read something about the hazard switch has an override over the turn signals.
dreamstang is offline   Reply With Quote
Old 09-09-2011, 06:49 PM   #10
Road Trip!
 
Join Date: Mar 2011
Region: California
Posts: 569
It could be a busted bulb I had the same problem and the bulb was just extremely fuc+ed up there was water in it so just check all the bulbs
16218 is offline   Reply With Quote
Old 09-09-2011, 08:07 PM   #11
Registered Member
Regular
 
FordRacer_51's Avatar
 
Join Date: Aug 2011
Region: Ohio
Posts: 146
I have turn signal issues to some times they work sometimes they don't. But my car has a python alarm on it and I thought maybe it was screwed up??
FordRacer_51 is offline   Reply With Quote
Old 09-11-2011, 10:42 AM   #12
Registered User
Newbie
 
GoodfellaBugsy's Avatar
 
Join Date: Aug 2011
Location: Las Vegas
Region: Nevada
Posts: 11
It's the relay switch for the turn signals, 99% positive, that is what the problem was on my 88 mustang. I had same symptoms.
GoodfellaBugsy is offline   Reply With Quote
Old 09-11-2011, 11:00 AM   #13
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: turn signals

It may be your turn signal flasher.
There are two flashers, 1 for the hazzard lights and 1 for the turn signals.
Trojan Horse is offline   Reply With Quote
Old 09-11-2011, 11:50 AM   #14
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Quote:
Originally Posted by Trojan Horse
It may be your turn signal flasher.
There are two flashers, 1 for the hazzard lights and 1 for the turn signals.
that makes sense.do the left and right have seperate or do they use the same flasher.i just figured if the hazards work then the signals should.thanx

---------- Post added at 11:50 AM ---------- Previous post was at 11:38 AM ----------

Hey Trojan,I didn't see your thread until it was closed.I just wanted to say good luck on a great recovery!
dreamstang is offline   Reply With Quote
Old 09-11-2011, 02:08 PM   #15
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: turn signals

Quote:
Originally Posted by dreamstang View Post
that makes sense.do the left and right have seperate or do they use the same flasher.i just figured if the hazards work then the signals should.thanx

---------- Post added at 11:50 AM ---------- Previous post was at 11:38 AM ----------

Hey Trojan,I didn't see your thread until it was closed.I just wanted to say good luck on a great recovery!
No separate flashers for the left and right sides. The same flasher serves both the left and right turn signals.

Thanks for the well wishes.
Trojan Horse is offline   Reply With Quote
Old 09-12-2011, 11:45 AM   #16
Road Trip!
 
Join Date: Mar 2011
Region: California
Posts: 569
Check the bulbs make sure there a all in great condition
16218 is offline   Reply With Quote
Old 09-12-2011, 12:27 PM   #17
A.K.A. Baby-D!
 
Join Date: Jan 2010
Region: Louisiana
Posts: 1,871
Re: turn signals

check all bulbs. had same problem in my 04 and i had a bad bulb in one of my tailights.
__________________
Current:
2011 V6 MCA Premium--the daily
1989 GT--the project
Previous:
2004 V6--my first pony
1988 GT--July 2010 MOTM
04TRV6 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Left low beam headlight wont work but i will when i turn on high beams p1blake04 1996-2004 Mustang GT 4 09-05-2011 11:30 PM
brake noise only when i turn. mhobbs 1996-2004 Mustang GT 2 08-27-2011 05:07 PM
Sequential turn signals mustangchassy Mustang Paint, Appearance & Detailing 16 08-07-2011 07:35 PM
Car is trembling like it wants to turn off. bobsurvives 1996-2004 Mustang GT 20 07-26-2011 02:46 PM

» Like Us On Facebook



12:57 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.