Need help my 5.0 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-12-2011, 06:43 PM   #1
Registered Member
Regular
 
Join Date: Jan 2011
Region: Ohio
Posts: 34
Need help my 5.0

What's up fellas,
Hey I have been playing with my mustang for a while and have added roller rockers, o yeah, it's a 91 5.0, I have a e-cam, msd 19lb injectors, after adding all that it was running very well it ran great for about three weeks then it started running like it's to rich and then like it's to lean, so I installed a new fuel pump and that isn't help.. So if I'm in to the throttle for a few min then let off the throttle to let it coast or engine brake for a min the hit the throttle again it falls on it's face, now I was just messing around with it running at a idle and pulled the IAC plug and it didn't change a bit??? I haven't yet check the TPS voltage but I wouldn't think that would cause this.. Any ideas????
Thanks for any input
C4king is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-13-2011, 05:05 AM   #2
Registered Member
Regular
 
BigRed1781's Avatar
 
Join Date: Sep 2011
Region: Pennsylvania
Posts: 168
Just a thought, check your fuel pressure & your O2 sensor. O2 could be sending a bad signal causing the ecm to adjust fuel up & down. A A/F ratio gauge would tell you if your rich or lean.
BigRed1781 is offline   Reply With Quote
Old 09-13-2011, 10:10 PM   #3
Registered Member
Regular
 
Join Date: Jan 2011
Region: Ohio
Posts: 34
Quote:
Originally Posted by BigRed1781
Just a thought, check your fuel pressure & your O2 sensor. O2 could be sending a bad signal causing the ecm to adjust fuel up & down. A A/F ratio gauge would tell you if your rich or lean.
I put a new pump in it, what should a engine do when you unhook the IAC? Should it run bad? ???
C4king is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-14-2011, 01:24 AM   #4
Registered Member
Regular
 
96 stang's Avatar
 
Join Date: Mar 2011
Region: California
Posts: 112
From what i understand When you unhook the IAC it will idle bad but as soon as you give it gas the MAF takes over. & it should run better while your giving gas.
96 stang is offline   Reply With Quote
Old 09-14-2011, 02:24 AM   #5
Registered Member
Regular
 
BigRed1781's Avatar
 
Join Date: Sep 2011
Region: Pennsylvania
Posts: 168
Check your fuel pressure regulator.
BigRed1781 is offline   Reply With Quote
Old 09-14-2011, 07:36 PM   #6
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: Need help my 5.0

Have you checked the TPS yet?
Trojan Horse is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 V6 versus 2012 GT 5.0 avengnd General Mustang Discussion 6 09-01-2011 05:49 AM
What is the H O mean in a 5.0 crkmonzo 1979-1995 Mustang GT 16 08-30-2011 09:34 PM
Boss 302 vs GT 5.0 poloka 2011-2014 Mustang GT 188 06-20-2011 05:08 PM

» Like Us On Facebook



09:39 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.