Please help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-23-2011, 10:46 PM   #1
Registered Member
Regular
 
Snappybadman's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 24
Please help

K I have a 91 lx 5.0 and my head lights are all that works on it I have no cluster lights and it's not telling me how fast I'm going I have no power to the radio wires at all and have no clue why I don't the fuses are all good but still nothing please help if u can
Snappybadman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-23-2011, 11:01 PM   #2
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: Please help

Quote:
Originally Posted by Snappybadman View Post
K I have a 91 lx 5.0 and my head lights are all that works on it I have no cluster lights and it's not telling me how fast I'm going I have no power to the radio wires at all and have no clue why I don't the fuses are all good but still nothing please help if u can
Are you sure you have checked all of the fuses, in the interior and under the hood?
Maybe someone has hacked up some wiring under the dash?
Buy a Chilton or Haynes manual with the wiring diagrams and start tracing wires.
Trojan Horse is offline   Reply With Quote
Old 09-23-2011, 11:23 PM   #3
Registered Member
Regular
 
Snappybadman's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 24
Iv checked all fuses this car dose not have a fuse panel under the hood
Snappybadman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-23-2011, 11:41 PM   #4
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: Please help

Quote:
Originally Posted by Snappybadman View Post
Iv checked all fuses this car dose not have a fuse panel under the hood
You're right. I was thinking of the newer models.
Trojan Horse is offline   Reply With Quote
Old 09-23-2011, 11:51 PM   #5
Registered Member
Regular
 
Snappybadman's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 24
The funny thing is my head lights work and up and til tonight my back light worked too but now they are not working and the motor that goes to my top is not working either but my trunk light works
Snappybadman is offline   Reply With Quote
Old 09-24-2011, 11:41 AM   #6
Registered Member
Regular
 
Join Date: Aug 2011
Region: Florida
Posts: 55
Check the fuse links at the starter solenoid. They look like wires that are attached to the battery side of the solenoid.
Mustangsandiron is offline   Reply With Quote
Old 09-24-2011, 12:54 PM   #7
Registered Member
Regular
 
Snappybadman's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 24
Ok
Snappybadman is offline   Reply With Quote
Old 09-26-2011, 08:54 PM   #8
Registered Member
Regular
 
Join Date: Aug 2011
Region: Florida
Posts: 55
Did you find what was causing the problem?
Mustangsandiron is offline   Reply With Quote
Old 09-26-2011, 09:05 PM   #9
Registered Member
Regular
 
Snappybadman's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 24
No not yet still doing some digging I have the whole dash out right now
Snappybadman is offline   Reply With Quote
Old 09-26-2011, 09:31 PM   #10
Registered Member
Regular
 
96civic87's Avatar
 
Join Date: Sep 2011
Region: Louisiana
Posts: 65
Could it be a short or bad ground maybe not sure?
96civic87 is offline   Reply With Quote
Old 09-26-2011, 09:41 PM   #11
Registered Member
Regular
 
Snappybadman's Avatar
 
Join Date: Apr 2011
Region: Alabama
Posts: 24
It could I'm chasing the wires now
Snappybadman is offline   Reply With Quote
Old 09-26-2011, 10:05 PM   #12
Registered Member
Regular
 
00STANG00's Avatar
 
Join Date: Oct 2009
Location: Gonzales
Region: Louisiana
Posts: 801
Send a message via AIM to 00STANG00 Send a message via Yahoo to 00STANG00
i didnt read above but check fuses relay switch( by your feet a circle one) bulbs
__________________
SUCK MY DUST
00STANG00 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:17 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.