Temp gauge - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-01-2012, 11:00 PM   #1
Registered Member
Regular
 
captain78's Avatar
 
Join Date: Dec 2011
Region: Louisiana
Posts: 851
Temp gauge

Gauge not working. Is it as simple as changing sending unit on intake
captain78 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-01-2012, 11:33 PM   #2
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: Temp gauge

Quote:
Originally Posted by captain78 View Post
Gauge not working. Is it as simple as changing sending unit on intake
Yes, it's possible that's the problem.
It's also possible that some mice got in the car while it was sitting and chewed up some wiring.
Trojan Horse is offline   Reply With Quote
Old 01-02-2012, 06:44 AM   #3
Registered Member
Regular
 
captain78's Avatar
 
Join Date: Dec 2011
Region: Louisiana
Posts: 851
Oh god I hope not

---------- Post added at 06:44 AM ---------- Previous post was at 06:42 AM ----------

Oh. When key if off temp gauge reads normal when key turned on it drops and never comes back up until I turn car off kinda like my gas gauge
captain78 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-02-2012, 06:59 AM   #4
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: Temp gauge

Quote:
Originally Posted by captain78 View Post
Oh god I hope not

---------- Post added at 06:44 AM ---------- Previous post was at 06:42 AM ----------

Oh. When key if off temp gauge reads normal when key turned on it drops and never comes back up until I turn car off kinda like my gas gauge
Yeah me too. That can be a mess and a real PITA to sort out.
Maybe you should remove the instrument panel and check it out before doing anything else.
Don't forget the speedo cable disconnect.
It's kind of difficult, but not impossible to remove.
The best thing to do is to go to American Muscle or LRS maybe and look up a speedo cable.
Their enlarged views will give you an idea of where and what to squeeze to disconnect the cable, because you probably won't be able to see what you are doing.
Trojan Horse is offline   Reply With Quote
Old 01-02-2012, 08:57 PM   #5
Registered Member
Regular
 
captain78's Avatar
 
Join Date: Dec 2011
Region: Louisiana
Posts: 851
Well put some sea foam in my tank and about an hour later gauge started working.

---------- Post added at 08:57 PM ---------- Previous post was at 08:56 PM ----------

Wrong thread lol. But went bought new coolent temp sender working good now
captain78 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 gt cluster gauge repair... jmpark527 2005-2010 Mustang GT 29 11-25-2015 10:05 AM
Fuel gauge not working after CAI install. Hellraisen 1996-2004 Mustang GT 0 09-14-2011 07:58 AM
gauge issue mrc 1996-2004 Mustang GT 3 09-13-2011 09:14 AM
20 gauge to 18 gauge XXSTEVEO66 General Mustang Discussion 0 08-16-2011 07:58 PM
fuel pressure gauge XXSTEVEO66 1979-1995 Mustang GT 9 08-12-2011 04:02 PM

» Like Us On Facebook



10:42 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.