i need help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-28-2012, 10:06 AM   #1
Registered Member
Regular
 
Join Date: Nov 2011
Region: Kentucky
Posts: 172
i need help

Hey guys I've still been trying to get my car running at it's best. But it ain't lookin good. But. I was wandering something. All my smog stuff isn't hooked up anymore. And I have the line removed from the egr valve and capped off. But I don't get no codes for nothning. I've only got one code the whole time I've had the car. And it was for the fan. But the car is missing alittle when I get up in the revs. But it almost sounds like it is barley popping or backfiring out of the exhaust instead of missing. But it is just barly making a sound when it does it. I've never heard a motor do this b4. But I was just wandering shouldn't I be getting more codes. Like lean or rich codes. And shouldn't the egr valve set off a code. When I do research on the Internet about mustangs. People usualyy say they have like 5 or 6 codes when there car isn't running good. Any help would be greatly appreciated.!!
Robbie94gt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-28-2012, 10:50 AM   #2
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Did u check ur timing?
dreamstang is offline   Reply With Quote
Old 01-28-2012, 10:57 AM   #3
Registered Member
Regular
 
Join Date: Nov 2011
Region: Kentucky
Posts: 172
Not yet but I set it about 3 months ago at 10. I tried avancing at that time to just 11 amd it started pingin so I put it back to 10. With a running light. But also after I druve my car for say 30. Mins and then shut it off amd try to start it right back up it has to crank a few times just like I was starting it cold. I've always heard that a motor thst is timed right should start with back up when warm. Is that true. Also I put a new coil on it. But what about the codes. Shouldn't that smog stuff be turnin on a code. I've had the car for bout 8 months and it's runnig stronger now then it ever has but it's missing now. It used to never miss. I've never heard one pop out the exhaust like that just barly. I've heard themback fire loud out the exhaust but mine is not doing that. But thanks for your help. It means a lot

---------- Post added at 01:57 PM ---------- Previous post was at 01:56 PM ----------

* timming light
Robbie94gt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-28-2012, 11:01 AM   #4
Registered Member
Regular
 
Meansaleen's Avatar
 
Join Date: Apr 2011
Region: New York
Posts: 181
When you tried advancing timing what type of fuel did you have in your tank? And what type of fuel do you currently use?
Meansaleen is offline   Reply With Quote
Old 01-28-2012, 11:01 AM   #5
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
U may need to check your fuel pressure.u may be running lean which could be why u couldn't get more the 11*.
dreamstang is offline   Reply With Quote
Old 01-28-2012, 11:19 AM   #6
Registered Member
Regular
 
Join Date: Nov 2011
Region: Kentucky
Posts: 172
I use 89 all the time. Amd I checked the pressure 2 weeks ago. It was 32 at idle. 40 with the vacuum off the regualtor amd plugged. The only thing concerned me was that when I reved it up to 2500 rpm the pressure dropped about 4 psi. Shouldn't it rose instead of dropping.

---------- Post added at 02:19 PM ---------- Previous post was at 02:18 PM ----------

Quote:
Originally Posted by Meansaleen
When you tried advancing timing what type of fuel did you have in your tank? And what type of fuel do you currently use?
And I was using 87 at the time amd haven't tried to advance it since I've been using alittle higher octane
Robbie94gt is offline   Reply With Quote
Old 01-28-2012, 11:23 AM   #7
Registered Member
Regular
 
Meansaleen's Avatar
 
Join Date: Apr 2011
Region: New York
Posts: 181
When advancing timing u have to use premium 93 or better. My timing before supercharger was 14 degrees. And I never had pinging with premium fuel. Try using premium fuel. I suspect it might be crappy gas in your tank. Have you used fuel stabilizer?
Meansaleen is offline   Reply With Quote
Old 01-28-2012, 11:41 AM   #8
Registered Member
Regular
 
Join Date: Nov 2011
Region: Kentucky
Posts: 172
No I haven't but it runs good don't backfire or miss or nothin untill I push the pedal over halfway then it starts cutting out but it still picks up speed. My vacuum is 17 amd steady. But what would cause the small backfire out the exhaust if the timming is at 10. Could clogged injectors do this. ? Apparentaly the car set for a while b4 I got it cuz there was like 2 or 3 dirt dopper nest between the upper and lower intake. Signs of it sitting a while. But I know no history on the car. But I have drove the piss out of this car. It's it just strange. When I first got it. It ran good but didn't fell like it ran at it's full potental. It never missed or backfired Now I've done a few things like full exhaust amd gears amd it's stronger than it ever has been but missing/backfiring. I'm just runnig out of options. I have a set of gt40 heads amd intake waiting to go but I want to get this straighted out b4 I put those on there and have more problems with ya
Robbie94gt is offline   Reply With Quote
Old 01-28-2012, 10:37 PM   #9
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: i need help

Quote:
Originally Posted by Robbie94gt View Post
I use 89 all the time. Amd I checked the pressure 2 weeks ago. It was 32 at idle. 40 with the vacuum off the regualtor amd plugged. The only thing concerned me was that when I reved it up to 2500 rpm the pressure dropped about 4 psi. Shouldn't it rose instead of dropping.


Quote:
Originally Posted by Robbie94gt View Post
No I haven't but it runs good don't backfire or miss or nothin untill I push the pedal over halfway then it starts cutting out but it still picks up speed. My vacuum is 17 amd steady. But what would cause the small backfire out the exhaust if the timming is at 10. Could clogged injectors do this. ? Apparentaly the car set for a while b4 I got it cuz there was like 2 or 3 dirt dopper nest between the upper and lower intake. Signs of it sitting a while. But I know no history on the car. But I have drove the piss out of this car. It's it just strange. When I first got it. It ran good but didn't fell like it ran at it's full potental. It never missed or backfired Now I've done a few things like full exhaust amd gears amd it's stronger than it ever has been but missing/backfiring. I'm just runnig out of options. I have a set of gt40 heads amd intake waiting to go but I want to get this straighted out b4 I put those on there and have more problems with ya
The 40 psi at idle with the vacuum hose off is good, but it should not drop all the way down to 4 psi. Some drop is normal, but that is too far. I would suspect the pressure regulator is not working properly.


The injectors could very well be dirty and in need of cleaning. The nozzle is very small and it does not take much to clog them up. Old, varnished fuel can do that every time.


The popping out the exhaust can also be caused by a burned or leaking valve. Usually it is the exhaust valve, which can get a piece of carbon wedged between the valve and seat and not seal up properly.
Trojan Horse is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:47 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.