Blinker and wiper issues - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-21-2012, 09:33 PM   #1
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Blinker and wiper issues

Hi guys. I picked up a 1991 lx coupe last week. The car needs a little love to pass inspection. The passenger blinker stays on when the switch inside is in the off position and vice-versa. The wipers will not turn all the way off either. Does anybody have a clue? At first I thought it was a wiring issue with the blinkers, but then started having the wiper issue. I've heard that the actual switch is a common problem. Any help is greatly appreciated in getting this foxbody notchback where it belongs: on the road.
91notchback is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2012, 11:39 PM   #2
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: Blinker and wiper issues

Sounds like you have switch problems. Replacements are probably needed.


Check your wiring too, just to make sure it hasn't been hacked up.
Trojan Horse is offline   Reply With Quote
Old 02-21-2012, 11:51 PM   #3
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Thanks man. I really appreciate it! I've been real busy with work and school, but I plan on getting on this issue SOON. It's killing me having to watch it sit and only cranking it everyday. I will update what I find out.
91notchback is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2012, 11:54 PM   #4
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: Blinker and wiper issues

Quote:
Originally Posted by 91notchback View Post
Thanks man. I really appreciate it! I've been real busy with work and school, but I plan on getting on this issue SOON. It's killing me having to watch it sit and only cranking it everyday. I will update what I find out.
You're welcome.
Do post what you find, it will help someone else in the future.
Trojan Horse is offline   Reply With Quote
Old 02-22-2012, 04:38 AM   #5
Registered Member
Regular
 
90fox's Avatar
 
Join Date: Feb 2012
Region: Illinois
Posts: 302
My wipers don't work either...rain x lol.
90fox is offline   Reply With Quote
Old 02-22-2012, 06:57 AM   #6
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Haha! It wouldn't be a big deal to me either. I'm just having hell gettin it inspected. Nobody will just slide me on through man...lol
91notchback is offline   Reply With Quote
Old 02-22-2012, 07:36 AM   #7
Registered Member
Regular
 
90fox's Avatar
 
Join Date: Feb 2012
Region: Illinois
Posts: 302
Right need to fix mine too. Just being lazy about it because hasn't been issue.
90fox is offline   Reply With Quote
Old 02-22-2012, 11:34 AM   #8
Registered Member
Regular
 
SleepingStang's Avatar
 
Join Date: Jan 2011
Region: Wisconsin
Posts: 169
Sounds like the multi-function switch is junk. A used one may get you through inspection but may as well fix it right.

http://www.latemodelrestoration.com/...Lever-Assembly

Good luck to you.
SleepingStang is offline   Reply With Quote
Old 02-22-2012, 12:07 PM   #9
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Thanks for the link man. I will for sure get a new one while I'm replacing anyways. I appreciate yalls help!
91notchback is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MT82 Transmission Issue...Please Read and Please HELP DannyDoright 2011-2014 V6 Mustang 5 03-02-2012 09:46 AM
94 gt issues? dmcgoy3 1979-1995 Mustang GT 2 02-21-2012 01:04 PM
Trunk issues Mystic General Mustang Discussion 4 02-20-2012 06:31 PM
Break light and side marker tint Musskao Mustang Paint, Appearance & Detailing 16 02-20-2012 06:14 PM
cam difference between 3.8 and 4.2 mustangg2000 Pre-2005 V6 Mustang 1 02-20-2012 03:23 PM

» Like Us On Facebook



11:41 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.