2 more weeks - Page 2 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-14-2012, 08:40 AM   #36
Titus Wadicus
Regular
 
svtlx's Avatar
 
Join Date: Jan 2007
Region: Ohio
Posts: 2,103
Send a message via Yahoo to svtlx
Re: 2 more weeks

Quote:
Originally Posted by WhiteCobra94 View Post
New valve covers came, and intake spacer , just left the shop, motor goes in Thursday!!! Hope these valve covers work!!!
i dont think u will have any issues. i dont like the way the chromes covers seal up after they been on and off a few times... so i ended up getn ford motorsports..
__________________

bbk ssi, 70ml t.b., bbk adj.reg., bd11-a 11psi, e-cam,
racing aod, 2700 stall, 3.42 gears, ported e7, 308ci, 1.7rr, comp .560valve springs, gear drive, high dwell module, msd 6a & coil, bbk off road xpipe, mac cat back, 30lbs inj, pro-m 90mm, welded subframe connectors, boxed upper & lower trailing arms, spherical axle bushings, 255/50/16 tires, 255lph pump, 456hp
svtlx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-14-2012, 10:02 AM   #37
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Yea, ..... I've had it with these valve covers, finally sold the cobra ones so it was a even swap for me !!

The only other prob I had with the motor and the ONLY mod I bought used (never buying used parts again) we're the crane cam 1.6 rocker arms , torque them down and they would not adjust , they were shot so I ending up buying new ones!!!
WhiteCobra94 is offline   Reply With Quote
Old 03-14-2012, 10:09 AM   #38
Titus Wadicus
Regular
 
svtlx's Avatar
 
Join Date: Jan 2007
Region: Ohio
Posts: 2,103
Send a message via Yahoo to svtlx
Re: 2 more weeks

thats wut happens when u buy the good stuff lol. i just got the pedestal. if they dont adjust right i know its pushrods... makes my life less complicated.
__________________

bbk ssi, 70ml t.b., bbk adj.reg., bd11-a 11psi, e-cam,
racing aod, 2700 stall, 3.42 gears, ported e7, 308ci, 1.7rr, comp .560valve springs, gear drive, high dwell module, msd 6a & coil, bbk off road xpipe, mac cat back, 30lbs inj, pro-m 90mm, welded subframe connectors, boxed upper & lower trailing arms, spherical axle bushings, 255/50/16 tires, 255lph pump, 456hp
svtlx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-14-2012, 10:20 AM   #39
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Quote:
Originally Posted by svtlx
thats wut happens when u buy the good stuff lol. i just got the pedestal. if they dont adjust right i know its pushrods... makes my life less complicated.
Well I bought the pedestal to stud mount conversion kit from crane cams do I can use the rockers , soooooooo I sent the kit back and buy the pedestal mount ones !
WhiteCobra94 is offline   Reply With Quote
Old 03-14-2012, 04:27 PM   #40
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 2 more weeks

Quote:
Originally Posted by WhiteCobra94 View Post
Well I bought the pedestal to stud mount conversion kit from crane cams do I can use the rockers , soooooooo I sent the kit back and buy the pedestal mount ones !
For a street car the pedestal mounts are the best solution in most cases.
For race cars the adjustables have their advantages too.
On the old solid lift cams we used to use rocker arm adjustments to move the engine's power band up and down the RPM scale a bit to help compensate for air temp/humidity, altitude or track variations.
Trojan Horse is offline   Reply With Quote
Old 03-14-2012, 05:14 PM   #41
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
I'm actually happy I ended up buying brand new pedestal rockers , makes me feel better knowing that I didn't use any used parts lol!!
WhiteCobra94 is offline   Reply With Quote
Old 03-20-2012, 07:16 AM   #42
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Motor is in !!! Getting excited now! Lol
Attached Thumbnails
Click image for larger version

Name:	image-2797289935.jpg
Views:	61
Size:	335.4 KB
ID:	44351  
WhiteCobra94 is offline   Reply With Quote
Old 03-20-2012, 08:23 AM   #43
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 2 more weeks

All right, progress!
Trojan Horse is offline   Reply With Quote
Old 03-21-2012, 09:13 AM   #44
Registered Member
Regular
 
Taxman's Avatar
 
Join Date: Dec 2011
Region: Louisiana
Posts: 164
Every time I look at your car I want to make mine look like it... ( the front end an hood) what kinda front bumper is that? An did you lower your car?
Taxman is offline   Reply With Quote
Old 03-21-2012, 09:17 AM   #45
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Quote:
Originally Posted by Taxman
Every time I look at your car I want to make mine look like it... ( the front end an hood) what kinda front bumper is that? An did you lower your car?
The bumper is 94-98 cobra, 3.5 SVO cowl hood, lowered 1 1/2 inches all around
WhiteCobra94 is offline   Reply With Quote
Old 03-27-2012, 02:53 PM   #46
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Well she started on the first try..... still idles rough but SCT-chip isn't hooked up , new fuel pump isn't in and the timing isn't set!

Here's a quick video , isn't the greatest but I'll have a better one coming!!!

WhiteCobra94 is offline   Reply With Quote
Old 03-27-2012, 03:14 PM   #47
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 2 more weeks

Quote:
Originally Posted by WhiteCobra94 View Post
Well she started on the first try..... still idles rough but SCT-chip isn't hooked up , new fuel pump isn't in and the timing isn't set!

Here's a quick video , isn't the greatest but I'll have a better one coming!!!

Allright!
Trojan Horse is offline   Reply With Quote
Old 03-30-2012, 03:17 PM   #48
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Ok everything is installed BUT!!! The car stalls randomly and it's just flat when you try to hit on the gas, the idle hangs up to, I have the SCT-4bank chip in and still doesn't seem right, I know when I ordered it they didn't ask me some mods that I thought have to be tuned I don't know, what do you guys think?

(P.S. the gas that's in the car right now has been in there for over a year)
WhiteCobra94 is offline   Reply With Quote
Old 03-30-2012, 03:26 PM   #49
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 2 more weeks

Quote:
Originally Posted by WhiteCobra94 View Post
Ok everything is installed BUT!!! The car stalls randomly and it's just flat when you try to hit on the gas, the idle hangs up to, I have the SCT-4bank chip in and still doesn't seem right, I know when I ordered it they didn't ask me some mods that I thought have to be tuned I don't know, what do you guys think?

(P.S. the gas that's in the car right now has been in there for over a year)
Call them back and question them about it.
Why do you have the chip? (Memory Refresh)


Stale gasoline shouldn't cause those issues unless it is contaminated or completely flat, which shouldn't happen in that amount of time. I've had old cars that have sat for up to 3 years and they'd start and run ok on the old gas.
Trojan Horse is offline   Reply With Quote
Old 03-30-2012, 03:33 PM   #50
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
I did my swap which is

- 302 bored .40 over to 308
- Edelbrock Performer Heads
- Edelbrock Performer 5.0 intake
- Trick Flow 1 inch intake spacer
- Trick Flow Stage 1 Cam
- 1.6 rockers
- 75mm throttle body
- 75mm mass air sensor
- 24lb injectors
- CAi
- full off-road exhaust
- pro billet distributor

All pumps and sensors are new

Rebuilt trans with a B&M Hole-shot torque converter With 4.10 rear

And SCT 4bank chip from AM

---------- Post added at 02:33 PM ---------- Previous post was at 02:33 PM ----------

Quote:
Originally Posted by WhiteCobra94
I did my swap which is

- 302 bored .40 over to 308
- Edelbrock Performer Heads
- Edelbrock Performer 5.0 intake
- Trick Flow 1 inch intake spacer
- Trick Flow Stage 1 Cam
- 1.6 rockers
- 75mm throttle body
- 75mm mass air sensor
- 24lb injectors
- CAi
- full off-road exhaust
- pro billet distributor

All pumps and sensors are new

Rebuilt trans with a B&M Hole-shot torque converter With 4.10 rear

And SCT 4bank chip from AM
Everything was installed at once
WhiteCobra94 is offline   Reply With Quote
Old 03-30-2012, 03:39 PM   #51
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 2 more weeks

Thank you, sorry to have you type it up, but I had forgotten exactly what you were doing.

Try it without the chip.
I don't see anything that specifically requires one for it to run.
Your MAF is calibrated for the injectors right?
Trojan Horse is offline   Reply With Quote
Old 03-30-2012, 03:45 PM   #52
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Quote:
Originally Posted by Trojan Horse
Thank you, sorry to have you type it up, but I had forgotten exactly what you were doing.

Try it without the chip.
I don't see anything that specifically requires one for it to run.
You MAF is calibrated for the injectors right?
Yes it's calibrated

---------- Post added at 02:45 PM ---------- Previous post was at 02:44 PM ----------

Sounds like I'm gonna have to custom tune it!!
WhiteCobra94 is offline   Reply With Quote
Old 03-30-2012, 03:55 PM   #53
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 2 more weeks

Quote:
Originally Posted by WhiteCobra94 View Post
Yes it's calibrated

---------- Post added at 02:45 PM ---------- Previous post was at 02:44 PM ----------

Sounds like I'm gonna have to custom tune it!!
You shouldn't have to custom tune it.
My car has equivalent or maybe even a few more mods and it runs just fine off the stock ECU.
You have an issue or issues somewhere in the system.
Trojan Horse is offline   Reply With Quote
Old 03-30-2012, 04:23 PM   #54
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
But I was always told for sn95 mustangs when you add heads, cam, intake that it needs to be tuned
WhiteCobra94 is offline   Reply With Quote
Old 03-30-2012, 04:30 PM   #55
Registered Member
Regular
 
McNassty's Avatar
 
Join Date: Jul 2011
Posts: 600
Quote:
Originally Posted by WhiteCobra94
But I was always told for sn95 mustangs when you add heads, cam, intake that it needs to be tuned
I didn't have to, I just got a tune for a more aggressive fuel and timing curve
McNassty is offline   Reply With Quote
Old 03-30-2012, 04:41 PM   #56
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Well it's installed now, but i don't know what other issues there would be, everything is new from motor, ignition, trans, rear. I don't know im just getting frustrated now!!!!
WhiteCobra94 is offline   Reply With Quote
Old 03-30-2012, 04:46 PM   #57
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Quote:
Originally Posted by WhiteCobra94
Well it's installed now, but i don't know what other issues there would be, everything is new from motor, ignition, trans, rear. I don't know im just getting frustrated now!!!!
did you try removing the tune like trojan suggested?the tune may just not be working right for ya

---------- Post added at 04:46 PM ---------- Previous post was at 04:42 PM ----------

also once u remove the tune you may have to drive it a little bit so the ecu can relearn its parameters
dreamstang is offline   Reply With Quote
Old 03-30-2012, 04:51 PM   #58
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
I'm gonna drive it tonight I'm heading to shop now ..... I have a guy that works at a performance shop he said to bring it over and he'll hook it up to the computer and see what or if he has to adjust something's !
WhiteCobra94 is offline   Reply With Quote
Old 03-30-2012, 05:55 PM   #59
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Quote:
Originally Posted by WhiteCobra94
I'm gonna drive it tonight I'm heading to shop now ..... I have a guy that works at a performance shop he said to bring it over and he'll hook it up to the computer and see what or if he has to adjust something's !
Also my buddy that did all the work and test drove it , his daily driver is a 780rwhp Shelby GT500 so I'll see how my car rides in a few!
WhiteCobra94 is offline   Reply With Quote
Old 03-30-2012, 06:01 PM   #60
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 2 more weeks

Quote:
Originally Posted by WhiteCobra94 View Post
Also my buddy that did all the work and test drove it , his daily driver is a 780rwhp Shelby GT500 so I'll see how my car rides in a few!
Good luck & happy tire smoke!
Trojan Horse is offline   Reply With Quote
Old 03-30-2012, 07:42 PM   #61
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Ok I just left shop and I might have panicked early the car idles awesome,!!!! Right around 950-1000rpms,



When you rev the car sounds amazing , as so as you put it in drive and give it gas , you can feel it wanting to go but something's holding it back , kinda like clogged cats but my exhaust is off road,

Does this sound like something is wrong with my mass air sensor?
WhiteCobra94 is offline   Reply With Quote
Old 03-30-2012, 08:16 PM   #62
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 2 more weeks

Quote:
Originally Posted by WhiteCobra94 View Post
Ok I just left shop and I might have panicked early the car idles awesome,!!!! Right around 950-1000rpms,



When you rev the car sounds amazing , as so as you put it in drive and give it gas , you can feel it wanting to go but something's holding it back , kinda like clogged cats but my exhaust is off road,

Does this sound like something is wrong with my mass air sensor?
Maybe, but it sounds more like a timing or fuel supply issue.
Here's how to test the MAF.
Attached Thumbnails
Click image for larger version

Name:	MAF Tests .jpg
Views:	52
Size:	97.4 KB
ID:	45495  
Trojan Horse is offline   Reply With Quote
Old 03-30-2012, 08:38 PM   #63
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Right now the timing is at 10 degrees and fuel pressure is 38 psi
WhiteCobra94 is offline   Reply With Quote
Old 03-30-2012, 08:55 PM   #64
Registered Member
Regular
 
Lapida's Avatar
 
Join Date: Jun 2011
Region: Other
Posts: 142
Quote:
Originally Posted by WhiteCobra94
Right now the timing is at 10 degrees and fuel pressure is 38 psi
Amazing sound!
Lapida is offline   Reply With Quote
Old 03-30-2012, 08:58 PM   #65
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 2 more weeks

Quote:
Originally Posted by WhiteCobra94 View Post
Right now the timing is at 10 degrees and fuel pressure is 38 psi
That fuel pressure is at idle correct?
What does it do when you rev it?
Trojan Horse is offline   Reply With Quote
Old 03-30-2012, 09:09 PM   #66
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Quote:
Originally Posted by Trojan Horse

That fuel pressure is at idle correct?
What does it do when you rev it?
I don't what it's at , at rev , but I have a brand new fuel pressure reg, and new 190 pump
WhiteCobra94 is offline   Reply With Quote
Old 03-30-2012, 09:16 PM   #67
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 2 more weeks

Quote:
Originally Posted by WhiteCobra94 View Post
I don't what it's at , at rev , but I have a brand new fuel pressure reg, and new 190 pump


Did you set the pressure at idle with the vacuum hose disconnected and plugged?


How is your TPS?
Maybe it is not sensing the throttle position correctly.
Trojan Horse is offline   Reply With Quote
Old 03-30-2012, 09:22 PM   #68
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
I personally didn't set the pressure but I'll find out tomorrow how he did it!

---------- Post added at 08:22 PM ---------- Previous post was at 08:19 PM ----------

Quote:
Originally Posted by WhiteCobra94
I personally didn't set the pressure but I'll find out tomorrow how he did it!
I'm gonna pick up a new TPS and idle control valve this week! The hard part is over now it's little stuff lol
WhiteCobra94 is offline   Reply With Quote
Old 03-30-2012, 09:30 PM   #69
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 2 more weeks

Quote:
Originally Posted by WhiteCobra94 View Post
I personally didn't set the pressure but I'll find out tomorrow how he did it!

---------- Post added at 08:22 PM ---------- Previous post was at 08:19 PM ----------

I'm gonna pick up a new TPS and idle control valve this week! The hard part is over now it's little stuff lol
Yup, get out the Raid spray, it's time to "get the bugs out".
Trojan Horse is offline   Reply With Quote
Old 04-20-2012, 05:37 PM   #70
Registered Member
Regular
 
WhiteCobra94's Avatar
 
Join Date: Dec 2010
Region: Pennsylvania
Posts: 1,435
Finally this nightmare is over!!!! There was nothing wrong your damaged with the car, turned out the chip from AM was not the way to go for me. I dropped the car off Wednesday and this morning had the car custom dynoed tune by (2nd street speed in Pa) with a 302 bored to 308 , HCI, full off-road exhaust the car dynoed at 304rwhp / 314ft/tq,

I'm picking the car up tomorrow I'll have pics and videos to follow!!!!

Thank you everyone for the help and info over the past year !!!!
WhiteCobra94 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broke it some more, pic of busted oil pan inside... Project Pony Pre-2005 V6 Mustang 11 03-22-2012 07:31 PM
I'm in love: FRHP, MGW, Calipers, and More avengnd 2011-2014 Mustang GT 26 03-15-2012 12:38 PM
a couple more swap pics... svtlx 1979-1995 Mustang GT 30 03-07-2012 09:12 PM
what do i do next for more power? angelofrat42 2005-2010 V6 Mustang 7 03-07-2012 06:26 PM
More goodies for me! SCT tuner ?'s Project Pony Pre-2005 V6 Mustang 2 02-23-2012 02:04 PM

» Like Us On Facebook



07:23 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.