gt40 upper amd lower and maf upgrade! - Page 3 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-27-2012, 10:47 PM   #71
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
Quote:
Originally Posted by dreamstang
do you have pics of what needs capped? we may be able to give you an even better solution.
ill take a look and see what i have picture wise

---------- Post added at 10:47 PM ---------- Previous post was at 10:46 PM ----------

Quote:
Originally Posted by Trojan Horse
You can use a brass compression fitting and a cap to plug that off. I just cut the bulge off of the little tube and slid the compression fitting over it and tightened it up. Looks better and it's more secure.

Are the inlet and outlet tubes on the TB itself or the adapter?
If on an adapter, just remove it completely. It is no longer needed and just taking up room.
yes they are on the adapter not the tb
87blackonblack is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-27-2012, 10:57 PM   #72
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
Quote:
Originally Posted by dreamstang
do you have pics of what needs capped? we may be able to give you an even better solution.
this is about as close as i can getv ya until i get back to the garage in the morning. buy you can see that the throttle body is separate from the adapter plate with the coolant tubes on it.

Click image for larger version

Name:	ForumRunner_20120427_235408.png
Views:	239
Size:	504.6 KB
ID:	48496
87blackonblack is offline   Reply With Quote
Old 04-27-2012, 11:06 PM   #73
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: gt40 upper amd lower and maf upgrade!

Quote:
Originally Posted by 87blackonblack View Post
this is about as close as i can getv ya until i get back to the garage in the morning. buy you can see that the throttle body is separate from the adapter plate with the coolant tubes on it.
Yeah, you should be able to just get rid of the adapter plate completely.
My Cobra intake does not use it and yours looks identical.
Trojan Horse is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-28-2012, 07:39 AM   #74
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
awesome well that's my stock intake i took that picture before i started taking it apart so i new where everything went
87blackonblack is offline   Reply With Quote
Old 04-28-2012, 07:40 AM   #75
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
this is where i am at now with the gt40

Click image for larger version

Name:	ForumRunner_20120428_083930.png
Views:	1081
Size:	416.4 KB
ID:	48520



Click image for larger version

Name:	ForumRunner_20120428_083955.png
Views:	405
Size:	440.9 KB
ID:	48521



Click image for larger version

Name:	ForumRunner_20120428_083955.png
Views:	405
Size:	440.9 KB
ID:	48521
87blackonblack is offline   Reply With Quote
Old 04-28-2012, 09:26 AM   #76
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
do i need a spacer to go between th tb?
87blackonblack is offline   Reply With Quote
Old 04-28-2012, 04:54 PM   #77
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
You will to mount your throttle cable, they do make tb spacers that eliminate the egr if your deleting it.
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 04-28-2012, 08:55 PM   #78
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
i bought an egr spacer delete 1" also subframe connectors and my ac delete pulley today in about one week my car should be finished for now anyways.

---------- Post added at 08:55 PM ---------- Previous post was at 08:54 PM ----------

iI hope to hit mid 13. what do u guys think
87blackonblack is offline   Reply With Quote
Old 05-03-2012, 08:47 PM   #79
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
ok need some help please!?!?!

i finished my maf and mi upper and lower buttoned it all up and timed it to 14 degrees.

idled great revved up great but when i took it for a ride it just feel on its face horribly. when i get on the gas it boggs down and just doors not want to go anywhere under a load.

any ideas?

i also Changed the injectors they are all 19# but they are an upgraded version with 4 holes instead of two.

---------- Post added at 08:47 PM ---------- Previous post was at 08:45 PM ----------

Quote:
Originally Posted by 87blackonblack
ok need some help please!?!?!

i finished my maf and mi upper and lower buttoned it all up and timed it to 14 degrees.

idled great revved up great but when i took it for a ride it just feel on its face horribly. when i get on the gas it boggs down and just doors not want to go anywhere under a load.

any ideas?

i also Changed the injectors they are all 19# but they are an upgraded version with 4 holes instead of two.
sorry for the typos my phone has a cracked screen and its hard to type on.
87blackonblack is offline   Reply With Quote
Old 05-03-2012, 08:49 PM   #80
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
it isnt detonating is it? i would start with the base timing for now till you get it running better.

the only difference with the 4 holes in the injector is it will have a more even spray pattern.
dreamstang is offline   Reply With Quote
Old 05-03-2012, 09:03 PM   #81
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
im not sure what u mean be detonating? and tomorrow i am planning on going through all of my spark plug wires and check the timing again. im so close to having it finished its frustrating the h#ll out of me!!!
87blackonblack is offline   Reply With Quote
Old 05-03-2012, 09:10 PM   #82
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
i mean pinging. if you advance your timing to far without running premium fuel it can be very bad for your motor. it sounds like marbles bouncing around. if you load the engine heavy you can tell more. for example: drive around 20-25 mph then put it in 4th or 5th gear and you listen to the motor if you hear the pinging then your timing is to far advanced. some guys can run 14* without needing premium, but other guys cant.
dreamstang is offline   Reply With Quote
Old 05-03-2012, 09:15 PM   #83
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
i use premium fuel ill double check tomorrow what you just said.

another thing i read about is possible maf is dirty and they said soething about cleanig the wire in it but mine does not have any in it is this normal?
87blackonblack is offline   Reply With Quote
Old 05-03-2012, 09:24 PM   #84
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
its really hard to get at it. i dont have a maf cause im carbed. but on other models i have cleaned sometimes you cant really see them in the housing. you have to phyisically take it out of the housing.

---------- Post added at 09:24 PM ---------- Previous post was at 09:17 PM ----------

you should be alright. but i would still set it to 10* till you get it running right. especially when a possible timing issue is involved.
dreamstang is offline   Reply With Quote
Old 05-03-2012, 09:36 PM   #85
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
okay sounds good i googled my maf sensor and yea its normal on mine.

my act sensor was located in my lower intake but with gt40 there is no spot and reading farther into it they say i should move it to the intake tube could this
be the issue right now its pluged in but just hanging by the intake?

---------- Post added at 09:36 PM ---------- Previous post was at 09:30 PM ----------

Quote:
Originally Posted by 87blackonblack
okay sounds good i googled my maf sensor and yea its normal on mine.

my act sensor was located in my lower intake but with gt40 there is no spot and reading farther into it they say i should move it to the intake tube could this
be the issue right now its pluged in but just hanging by the intake?
also i did an egr delete could this be an issue as well right now the plug is.just hanging empty?
87blackonblack is offline   Reply With Quote
Old 05-03-2012, 09:42 PM   #86
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
Quote:
Originally Posted by 87blackonblack
okay sounds good i googled my maf sensor and yea its normal on mine.

my act sensor was located in my lower intake but with gt40 there is no spot and reading farther into it they say i should move it to the intake tube could this
be the issue right now its pluged in but just hanging by the intake?

---------- Post added at 09:36 PM ---------- Previous post was at 09:30 PM ----------



also i did an egr delete could this be an issue as well right now the plug is.just hanging empty?
I have my sensor hanging and egr deleted and not having those problems. Could be either timing or fuel related. Just start with cleaning the maf.
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 05-03-2012, 09:48 PM   #87
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
okay ill try the timing tomorrow and then if need be ill go back to the stock injectors here is pix of the before and after of the motor

Click image for larger version

Name:	ForumRunner_20120503_224800.png
Views:	146
Size:	439.5 KB
ID:	49118



Click image for larger version

Name:	ForumRunner_20120503_224815.png
Views:	175
Size:	504.6 KB
ID:	49119
87blackonblack is offline   Reply With Quote
Old 05-03-2012, 09:52 PM   #88
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
very nice.looks way better. nice job man.

i am not sure exactly but when you delete the egr you need to get a special thing to keep the ecu from throwing a code. this may or may not affect how it runs. but i think this can be made very easily i just dont remember how. and i would put that sensor in the tube also like stated. i would do all this and set your base timing and fo from there.
dreamstang is offline   Reply With Quote
Old 05-03-2012, 10:03 PM   #89
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
thanks and lookin at the b4 and after pix my wires look way different and i did see the egr thingy on ebay might by that and give it a shot if these ides dont work tomorrow.

---------- Post added at 10:03 PM ---------- Previous post was at 10:02 PM ----------

Quote:
Originally Posted by dreamstang
very nice.looks way better. nice job man.

i am not sure exactly but when you delete the egr you need to get a special thing to keep the ecu from throwing a code. this may or may not affect how it runs. but i think this can be made very easily i just dont remember how. and i would put that sensor in the tube also like stated. i would do all this and set your base timing and fo from there.
thanks for all the help man im exhausted im goin to.crash for.the evening woll keep u posted
87blackonblack is offline   Reply With Quote
Old 05-03-2012, 10:22 PM   #90
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Quote:
Originally Posted by 87blackonblack
thanks and lookin at the b4 and after pix my wires look way different and i did see the egr thingy on ebay might by that and give it a shot if these ides dont work tomorrow.

---------- Post added at 10:03 PM ---------- Previous post was at 10:02 PM ----------



thanks for all the help man im exhausted im goin to.crash for.the evening woll keep u posted
No problem. Maybe someone will chime in. I know there is a diagram around here somewhere that says how to make the ever thingy. And I think its really simple. I just don't remember how.
dreamstang is offline   Reply With Quote
Old 05-03-2012, 11:15 PM   #91
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: gt40 upper amd lower and maf upgrade!

Do a forum search for EGR Delete to find the drawing. All it does is turn off the CEL light.
Trojan Horse is offline   Reply With Quote
Old 05-04-2012, 04:29 AM   #92
Pete Jones
Regular
 
90mustangLX's Avatar
 
Join Date: Sep 2011
Region: Ohio
Posts: 781
Send a message via ICQ to 90mustangLX Send a message via AIM to 90mustangLX
Sorry of you said this before but I don't remember, but you did swap out computers right?
__________________
90 LX hatchback
(sold but not forgotten)

89 LX Notchback
No motor/trans (for now)
90mustangLX is offline   Reply With Quote
Old 05-04-2012, 11:22 AM   #93
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
yes i swaped them out and got a map sensor to match the 89 computer.
87blackonblack is offline   Reply With Quote
Old 05-04-2012, 05:35 PM   #94
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
ok checked timeing still the same so i am going back to the stock injectors in the morning. will keep u posted
87blackonblack is offline   Reply With Quote
Old 05-04-2012, 06:56 PM   #95
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
man i was hopeing to get this all squared away so i could take this monster to the track and see what it does. hopefully in the low therteens ....i know that's not fast but its a start
87blackonblack is offline   Reply With Quote
Old 05-04-2012, 06:59 PM   #96
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
low 13s isnt bad. i hope for high 12s in mine but i would be ok with low 13s though. did you take car of that egr also?
dreamstang is offline   Reply With Quote
Old 05-04-2012, 07:56 PM   #97
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
well my car has an egr delete that goes between the tb and the intake the egr plug thingy tat connects to the egr itself is just hanging there.

if i did away with the map sensor would this make a difference. in the useful info tab under maf conversion they say to plug it off and leave the map sensor own to the elements?

---------- Post added at 07:56 PM ---------- Previous post was at 07:55 PM ----------

Quote:
Originally Posted by dreamstang
low 13s isnt bad. i hope for high 12s in mine but i would be ok with low 13s though. did you take car of that egr also?
i probably would go about mid 13s
87blackonblack is offline   Reply With Quote
Old 05-04-2012, 08:04 PM   #98
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
some people look t my mod list and think i will go faster, but i just dont have a clue honestly.

im not sure about the map sensor. sorry.
dreamstang is offline   Reply With Quote
Old 05-04-2012, 08:05 PM   #99
Pete Jones
Regular
 
90mustangLX's Avatar
 
Join Date: Sep 2011
Region: Ohio
Posts: 781
Send a message via ICQ to 90mustangLX Send a message via AIM to 90mustangLX
I aim for a slower time so if I go faster than I thought I feel good about it heh.
__________________
90 LX hatchback
(sold but not forgotten)

89 LX Notchback
No motor/trans (for now)
90mustangLX is offline   Reply With Quote
Old 05-04-2012, 08:25 PM   #100
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
Quote:
Originally Posted by dreamstang
some people look t my mod list and think i will go faster, but i just dont have a clue honestly.

im not sure about the map sensor. sorry.
yah me either but hey they look good going down the track

---------- Post added at 08:25 PM ---------- Previous post was at 08:24 PM ----------

Quote:
Originally Posted by 90mustangLX
I aim for a slower time so if I go faster than I thought I feel good about it heh.
i better go faster then 14.0 lol
87blackonblack is offline   Reply With Quote
Old 05-04-2012, 08:29 PM   #101
Pete Jones
Regular
 
90mustangLX's Avatar
 
Join Date: Sep 2011
Region: Ohio
Posts: 781
Send a message via ICQ to 90mustangLX Send a message via AIM to 90mustangLX
Lol, I was expecting to run 16's since my car has stock gearing with huge tires in the back and a sick aod. I actually ran a 15.1 my best pass at 94 mph, my 60 ft is what really killed me, I've got plenty of top it it just takes me a bit to get there heh. After I do my 5 spd swap and 5 lug(with 3.73 gearing and smaller tires) I'm hoping to run a high 13 low 14 as I still have a stock bottom end and cam. Buddy of mine just basically restored his 87 hatch with a mildy built 302 and it actually only ran a best of 14.1, he was disappointed he thought it would go faster as his brother was driving it(he has a 12 second 351w hatchback).
__________________
90 LX hatchback
(sold but not forgotten)

89 LX Notchback
No motor/trans (for now)
90mustangLX is offline   Reply With Quote
Old 05-04-2012, 08:49 PM   #102
Registered Member
Regular
 
87blackonblack's Avatar
 
Join Date: Feb 2012
Region: Ohio
Posts: 308
i have 373s aluminum drive shaft bbk cold air intake and long tube headers off road x pipe 40 series flows but going to 10s gt40/cobra upper and lower intake. ac and smog deleted. egr delete. maf conversion 5 speed msd cap rotor and coil. ford racing wires. and upgraded injectors but taking them out tomorrow cause i have an issue i'm trying to figure out. hopefully this is enough to put me into the 13s i would be thrilled

---------- Post added at 08:49 PM ---------- Previous post was at 08:49 PM ----------

Quote:
Originally Posted by 87blackonblack
i have 373s aluminum drive shaft bbk cold air intake and long tube headers off road x pipe 40 series flows but going to 10s gt40/cobra upper and lower intake. ac and smog deleted. egr delete. maf conversion 5 speed msd cap rotor and coil. ford racing wires. and upgraded injectors but taking them out tomorrow cause i have an issue i'm trying to figure out. hopefully this is enough to put me into the 13s i would be thrilled
oh and sub frame connectors
87blackonblack is offline   Reply With Quote
Old 05-04-2012, 08:57 PM   #103
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Quote:
Originally Posted by 87blackonblack
i have 373s aluminum drive shaft bbk cold air intake and long tube headers off road x pipe 40 series flows but going to 10s gt40/cobra upper and lower intake. ac and smog deleted. egr delete. maf conversion 5 speed msd cap rotor and coil. ford racing wires. and upgraded injectors but taking them out tomorrow cause i have an issue i'm trying to figure out. hopefully this is enough to put me into the 13s i would be thrilled

---------- Post added at 08:49 PM ---------- Previous post was at 08:49 PM ----------



oh and sub frame connectors
sounds reasonable.
dreamstang is offline   Reply With Quote
Old 05-04-2012, 09:03 PM   #104
Pete Jones
Regular
 
90mustangLX's Avatar
 
Join Date: Sep 2011
Region: Ohio
Posts: 781
Send a message via ICQ to 90mustangLX Send a message via AIM to 90mustangLX
Bbk SSI-R upper and lower, Bbk shorties/h-pipe, Flowmaster 40s dumped before rear axle, Bbk cai, stock injectors(for now), gt40p heads, 8.5mm MSD 90 degree plugs, auto lite plugs(explorer style), 75mm tb, electric fan, a/c/smog delete,no egr, 265/50/15 on back 195/80/15 fronts(Jegs big n little wheels which are pretty light), sick aod heh. Basically all stock other than all that til I get some more cash.
__________________
90 LX hatchback
(sold but not forgotten)

89 LX Notchback
No motor/trans (for now)
90mustangLX is offline   Reply With Quote
Old 05-04-2012, 09:06 PM   #105
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
my list goes on forever. you can check my garage though if you have an extra 20 minutes. lol
dreamstang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:32 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.