Vibration before shifts - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-06-2012, 01:20 PM   #1
Registered Member
Regular
 
95GTvert's Avatar
 
Join Date: May 2012
Region: Missouri
Posts: 28
Vibration before shifts

Ok I have a 95 GT automatic, when I drive it normal, right before it shifts into each gear it vibrates really bad and then smooths back to normal afterwards. BUT if I am on the throttle hard or push down harder right before it shifts it doesn't do it. Feels like it vibrates the whole car, my thought is maybe drive shaft or u joint...if anyone has ever had this issue any help is greatly appreciated, thanks!
95GTvert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-06-2012, 01:23 PM   #2
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: Vibration before shifts

Quote:
Originally Posted by 95GTvert View Post
Ok I have a 95 GT automatic, when I drive it normal, right before it shifts into each gear it vibrates really bad and then smooths back to normal afterwards. BUT if I am on the throttle hard or push down harder right before it shifts it doesn't do it. Feels like it vibrates the whole car, my thought is maybe drive shaft or u joint...if anyone has ever had this issue any help is greatly appreciated, thanks!
Sounds like you might have some clutches that are worn out.
It may be time for a rebuild.
Trojan Horse is offline   Reply With Quote
Old 05-06-2012, 01:30 PM   #3
Registered Member
Regular
 
95GTvert's Avatar
 
Join Date: May 2012
Region: Missouri
Posts: 28
Ugh not what I'd wanna hear lol. Also I don't know if it has anything to do with it but when I bought the car there is a B&M ShiftPLUS installed in it, I never use it but its there. I read up a little on them and didn't hear much good about them.
95GTvert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-06-2012, 01:35 PM   #4
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
he is probably right. but it is still posible that your u joints are worn. put the car up on stands and check them out.

---------- Post added at 01:35 PM ---------- Previous post was at 01:33 PM ----------

does it happen at the same higher rpm through every gear?
dreamstang is offline   Reply With Quote
Old 05-06-2012, 01:39 PM   #5
Registered Member
Regular
 
95GTvert's Avatar
 
Join Date: May 2012
Region: Missouri
Posts: 28
Yes every shift it does it, about same rpm, it seems to be a little worse between 2nd and 3rd and 3rd to 4th.
95GTvert is offline   Reply With Quote
Old 05-06-2012, 01:55 PM   #6
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
if it does it every gear maybe it is rpm related?
dreamstang is offline   Reply With Quote
Old 05-06-2012, 04:54 PM   #7
Registered Member
Regular
 
95GTvert's Avatar
 
Join Date: May 2012
Region: Missouri
Posts: 28
Well after driving some more today I noticed that it does it also at lower speeds, still at 35 mph or so it vibrates when shifting. On the highway it vibrates around 2300 rpm. So no matter the speed or rpm, if it shifts it vibrates right before
95GTvert is offline   Reply With Quote
Old 05-07-2012, 03:11 AM   #8
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: Vibration before shifts

Quote:
Originally Posted by 95GTvert View Post
Ugh not what I'd wanna hear lol. Also I don't know if it has anything to do with it but when I bought the car there is a B&M ShiftPLUS installed in it, I never use it but its there. I read up a little on them and didn't hear much good about them.
The B&M Shift Plus is simply an Electronic Shift Improver.
Try using it and see if it has any effect on your issue.
You probably didn't read much good about them because people buy them and expect them to cure all the ills of a failing transmission. For what it is they work ok.


Here is a page with info and instructions - B&M Shift Plus
Trojan Horse is offline   Reply With Quote
Old 04-04-2017, 07:09 AM   #9
Registered Member
Regular
 
Join Date: Jan 2017
Location: Columbia
Region: Maryland
Posts: 29
Mine does the same thing but it has something to do with the exhaust. It only recently started once I installed a catless mid pipe. I was thinking it mayb occurs because of my muffler which is a muffler delete type system and is straight through. I might need a chambered muffler to control the sound better?
Superman06 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:18 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.