won't start - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-17-2012, 06:25 AM   #1
Registered User
Newbie
 
sick5point0's Avatar
 
Join Date: Mar 2012
Region: New Jersey
Posts: 6
won't start

I have a 93 LX hatch that won't start need help I have gas fuel pump n filter is good I have spark fuel my injectors are clicking it cranks over but don't start it only starts with starting fluid n stays on for literally 2 seconds
sick5point0 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-17-2012, 06:38 AM   #2
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
The pump may be just priming and not giving any fuel pressure while you're cranking it.
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 05-17-2012, 06:41 AM   #3
Registered User
Newbie
 
sick5point0's Avatar
 
Join Date: Mar 2012
Region: New Jersey
Posts: 6
Yeah but there's this little nipple thing that looks like a tire valve stem when i push the nipple in a lot of fuel is coming out though
sick5point0 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-17-2012, 06:47 AM   #4
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Then your injectors may noy be pulsing. Check injectors with a noid light. It could also be the pip/hall sensor.
dreamstang is offline   Reply With Quote
Old 05-17-2012, 06:49 AM   #5
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
^what he said.
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 05-17-2012, 06:50 AM   #6
Registered User
Newbie
 
sick5point0's Avatar
 
Join Date: Mar 2012
Region: New Jersey
Posts: 6
By pulsing u mean clicking cause when i turn my key to where on my lights turn on in my dash my injectors click n yeah maybe ur right bout the pip/hall sensor have to check it
sick5point0 is offline   Reply With Quote
Old 05-17-2012, 07:00 AM   #7
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
They should get a signal to fire at certain intervals every revolution or what. I'm not exactly sure of how it does it does it. But the pip sends the ecu the signal for the injectors to pulse( open and close).
dreamstang is offline   Reply With Quote
Old 05-17-2012, 05:03 PM   #8
Registered Member
Regular
 
Join Date: Mar 2012
Region: Indiana
Posts: 27
Re: won't start

Check your fuel pressure my 95 mustang was doing the exact same thing changed regulator prob fixed
95 black vert is offline   Reply With Quote
Old 05-17-2012, 10:43 PM   #9
Registered Member
Regular
 
Jkgravy's Avatar
 
Join Date: Nov 2011
Region: Georgia
Posts: 61
Just because fuel is coming out doesn't mean it has pressure behind it, it doesn't hurt to go buy a fuel pressure gauge. You will always have it and you can know what kind of pressure you are getting.
Jkgravy is offline   Reply With Quote
Old 05-17-2012, 10:45 PM   #10
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
it is a good idea to check pressure. but if he is getting some fuel, which he is it would at least fire. at least i would think. but yes check pressure.
dreamstang is offline   Reply With Quote
Old 05-18-2012, 10:14 AM   #11
Registered Member
Regular
 
Jkgravy's Avatar
 
Join Date: Nov 2011
Region: Georgia
Posts: 61
Quote:
Originally Posted by dreamstang
it is a good idea to check pressure. but if he is getting some fuel, which he is it would at least fire. at least i would think. but yes check pressure.
I had the same issue on a 89 and I was getting fuel, and it would start the die right away, I wasn't getting enough pressure to keep it running. Found out it was the filter.
Jkgravy is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



08:02 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.