95 mustang gt 5.0 failing 1 test in emission high nitro oxide plz help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-13-2012, 06:27 PM   #1
Registered Member
Regular
 
Join Date: Feb 2010
Posts: 72
95 mustang gt 5.0 failing 1 test in emission high nitro oxide plz help

please help my timing is correct, i not sure if coolant is full but im going to check it now. I failing emissions because the combustion chamber is hotter than normal. its not hot to me i mean temp guage is fine, but apparently its beyond the limit for passing emission please help.
durtyred69 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-13-2012, 06:36 PM   #2
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
If the cylinders are hot, you may try retarding the timing and or running premium fuel. This is most likely a lean issue. Check your fuel pressure.
dreamstang is offline   Reply With Quote
Old 06-13-2012, 06:54 PM   #3
Registered Member
Regular
 
Join Date: Feb 2010
Posts: 72
Re: 95 mustang gt 5.0 failing 1 test in emission high nitro oxide plz help

i run 93 i just started running 93 0ctane about 3 weeks now i will check the fuel pressure i hope that fixes it i'll let you know
durtyred69 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-13-2012, 06:55 PM   #4
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
the fuel actually cools the top of the piston each stroke before it fires. when you are lean there is not enough fuel to keep the piston cooled properly. just my guesses. i would start there.
dreamstang is offline   Reply With Quote
Old 06-14-2012, 12:38 AM   #5
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 95 mustang gt 5.0 failing 1 test in emission high nitro oxide plz help

Quote:
Originally Posted by durtyred69 View Post
please help my timing is correct, i not sure if coolant is full but im going to check it now. I failing emissions because the combustion chamber is hotter than normal. its not hot to me i mean temp guage is fine, but apparently its beyond the limit for passing emission please help.
Clogged converters or smog pump defective?
Run some gasoline/ethanol mix. The alcohol burns cleaner than the higher octane fuels.
Do not ****** the timing much (2° max), that will also cause it to heat up.
Trojan Horse is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:21 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.