O2 sensor issue - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-30-2012, 12:35 AM   #1
Registered Member
Regular
 
captain78's Avatar
 
Join Date: Dec 2011
Region: Louisiana
Posts: 851
O2 sensor issue

K I bought a set of long tubes put them on went to put the O2 sensors on and guess what the bungs are there but no holes drilled for sensors so pulled out the almighty dewalt drill and drill the holes. Driver side is perfect 90 degree angle no problems pass side is kicked up a bit and drill wasn't straight but did I stop nope drilled through and when done. Looked at it and ate the threads on bung so now o2 sensor won't go in lol I'm guessing only option I have is to weld up the hole and drill a new one and weld on a new bung for o2 sensor to fit. What y'all think is that my only option or is there something else I can do.

---------- Post added at 12:35 AM ---------- Previous post was at 12:35 AM ----------

Without removing the header
captain78 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-30-2012, 12:48 AM   #2
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: O2 sensor issue

Quote:
Originally Posted by captain78 View Post
K I bought a set of long tubes put them on went to put the O2 sensors on and guess what the bungs are there but no holes drilled for sensors so pulled out the almighty dewalt drill and drill the holes. Driver side is perfect 90 degree angle no problems pass side is kicked up a bit and drill wasn't straight but did I stop nope drilled through and when done. Looked at it and ate the threads on bung so now o2 sensor won't go in lol I'm guessing only option I have is to weld up the hole and drill a new one and weld on a new bung for o2 sensor to fit. What y'all think is that my only option or is there something else I can do.

---------- Post added at 12:35 AM ---------- Previous post was at 12:35 AM ----------

Without removing the header
There just really isn't a good option for repairing that.
If you can get a hold of a right angle close quarters drill then you may be able to drill it out and use a thread insert. Check McMaster Carr for thread inserts and see if they have the correct size and see what size you would have to drill it out to, to ensure you have enough "meat" to do it.
Trojan Horse is offline   Reply With Quote
Old 06-30-2012, 09:09 AM   #3
Registered Member
Regular
 
captain78's Avatar
 
Join Date: Dec 2011
Region: Louisiana
Posts: 851
Ok alls good in o2 sensor i talked to my guy who builds complete exhaust and he said when he puts up my muffs and X pipe he can take care of my issue.
captain78 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:00 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.