No power. - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Closed Thread
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-18-2012, 04:58 PM   #1
Registered Member
Regular
 
Thrasher13's Avatar
 
Join Date: May 2012
Region: South Carolina
Posts: 21
No power.

Recently rebuild the motor in my 89 hatch. All I did was freshen it up and put some gt40p heads on. Now I have no power at all. And it revs so slow. It's also sounds a little like a tractor when you first start revving. It's almost skipping but it's not. It's like a cylinder isn't firing but yet at idle the sound is good. It also is randomly after firing. It can be idling fine and all of a sudden pop then back to normal.
Thrasher13 is offline  
Sponsored Links
Advertisement
 
Old 07-18-2012, 05:11 PM   #2
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
I would check fuel pressure and timing.

Then you may want to check spark at each cylinder to I sure they are all firing.
dreamstang is offline  
Old 07-18-2012, 05:48 PM   #3
Registered Member
Regular
 
Thrasher13's Avatar
 
Join Date: May 2012
Region: South Carolina
Posts: 21
I've played with my timing. I set it at 36 base timing at 2k. And it after fired bad. So I've been slowly retarding it. And it's still doing it at 16
Thrasher13 is offline  
Sponsored Links
Advertisement
 
Old 07-18-2012, 05:51 PM   #4
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Unplug the spout connector and set it to 10* at idle.
dreamstang is offline  
Old 07-18-2012, 05:57 PM   #5
Registered Member
Regular
 
Thrasher13's Avatar
 
Join Date: May 2012
Region: South Carolina
Posts: 21
Il try that. And get back to you. Thanks
Thrasher13 is offline  
Old 07-18-2012, 05:59 PM   #6
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
No problem

---------- Post added at 05:59 PM ---------- Previous post was at 05:57 PM ----------

Also unplug the spout with car off. Then plug it back in after you set timing with car off
dreamstang is offline  
Old 07-19-2012, 12:39 AM   #7
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: No power.

Make sure you have the firing order correct.
Trojan Horse is offline  
Closed Thread

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:15 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.