87 5.0 with 89 dash harness: no spark! Help? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Join Mustang Evolution Today

Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-19-2012, 08:20 PM   #1
Registered User
Join Date: Jan 2012
Region: California
Posts: 12
87 5.0 with 89 dash harness: no spark! Help?

Problem: I bought an 87 Mustang that some [dip**** tweaker] tried to convert from stock speed density to a MAF system. They did it wrong, way wrong, it ran like ****. After ******* around with it for way too long, I want to convert the car back to its factory (non-MAF setting) so I can actually drive the ******* thing.

The tweaker installed a new ECU (A9L) and hacked into the wiring harness in several very ****ty ways, thus rendering the car almost undriveable.

I obtained new wiring harnesses: engine harness and underdash harness. I BELIEVE the new harnesses I got were from an 89. I installed them both.

The engine harness appears to be same as the stock (1987) one. The underdash harness has several additional plugs, at least some of which I believe are for an airbag (that my 87 does not have). There's obviously nothing to plug them in to.

After installing both harnesses, I have power to the fuel pump (and there is good fuel pump pressure), and I have power to the distributor and power to the coil. BUT, NO SPARK!

Question: why would the 89 harness allow power to the distributor and coil, but not to the actual sparkplug? Is there some aspect of the 89 harness (or the A9L ECU computer) that would not allow the spark to get all the way to the plug? Since the car ran before with the A9L computer, I don't see why it would not allow a spark now. It must be something with the 89 harness, right?

My only idea at this point is to get a correct 87 harness and install it. Then (assuming the car will run), I will also need to get a non-MAF ECU computer, in other words a stock 87 ECU computer.

As always, all input and advice is greatly appreciated.

Buckallred is offline   Reply With Quote
Old 08-19-2012, 08:32 PM   #2
Road Trip!
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Re: 87 5.0 with 89 dash harness: no spark! Help?

The harness is probably not compatible with the 87 ECU pinout.
I would go ahead and "properly" convert it to MAF since you have hte ECU and harness you need.

The speed density system does not work well with any mods that change the airflow of the engine, so if you don't plan to mod, then it will work ok for you, but if you do then changing to MAF is the smart thing to do.
Trojan Horse is offline   Reply With Quote

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

» Like Us On Facebook

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

10:49 AM

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.