Problems with dash gauges - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-25-2012, 06:46 PM   #1
Registered Member
Regular
 
jacob.a.gasparp's Avatar
 
Join Date: Dec 2011
Region: Nebraska
Posts: 125
Problems with dash gauges

Ok my speedometer, odometer, and tripometer, stopped working on the way to work. Apparently when that's happened before the previous owner would just hit the dash and they would all start working again but that isnt working the only thing that happens when you do the is the speedo needle jumps a little. What should I check out first do yall think and has anyone had this problem beside me?

89 gt hatchback 5.0
jacob.a.gasparp is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-25-2012, 06:51 PM   #2
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
im betting someone pulled the cluster before and didnt get everything plugged back in tight. i would pull it out(just a little bit) and check everything.
dreamstang is offline   Reply With Quote
Old 09-25-2012, 06:59 PM   #3
Registered Member
Regular
 
sally2002's Avatar
 
Join Date: May 2011
Region: Indiana
Posts: 438
Agreed sounds like a loose connection or wire problem
sally2002 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-25-2012, 08:45 PM   #4
Registered Member
Regular
 
jacob.a.gasparp's Avatar
 
Join Date: Dec 2011
Region: Nebraska
Posts: 125
Alright I will try that
jacob.a.gasparp is offline   Reply With Quote
Old 09-26-2012, 02:42 PM   #5
Registered Member
Regular
 
jacob.a.gasparp's Avatar
 
Join Date: Dec 2011
Region: Nebraska
Posts: 125
Well I pulled the instrument cluster forward and didn't really find any loose wiring or anything. Do yall think it is possible that it just finally went bad?
jacob.a.gasparp is offline   Reply With Quote
Old 09-26-2012, 03:11 PM   #6
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
Quote:
Originally Posted by jacob.a.gasparp
Well I pulled the instrument cluster forward and didn't really find any loose wiring or anything. Do yall think it is possible that it just finally went bad?
Yes that's a possibility.
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 09-26-2012, 03:29 PM   #7
Registered Member
Regular
 
jacob.a.gasparp's Avatar
 
Join Date: Dec 2011
Region: Nebraska
Posts: 125
Crud
jacob.a.gasparp is offline   Reply With Quote
Old 09-26-2012, 06:28 PM   #8
Registered Member
Regular
 
jacob.a.gasparp's Avatar
 
Join Date: Dec 2011
Region: Nebraska
Posts: 125
Is there anyway to just repair the speedometer
jacob.a.gasparp is offline   Reply With Quote
Old 09-26-2012, 06:31 PM   #9
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
first chase the speedo cable from the cluster to the trans. sometimes they get damaged. if you dont see anything obvious you may just want to replace it anyways. they are about 20-25$. but before you buy one pull the cable out of the trans and pull out the speedo gear and make sure its not stripped.
dreamstang is offline   Reply With Quote
Old 09-26-2012, 07:39 PM   #10
Registered Member
Regular
 
jacob.a.gasparp's Avatar
 
Join Date: Dec 2011
Region: Nebraska
Posts: 125
Ok I'll check all that out
jacob.a.gasparp is offline   Reply With Quote
Old 09-26-2012, 07:52 PM   #11
Registered Member
Regular
 
jacob.a.gasparp's Avatar
 
Join Date: Dec 2011
Region: Nebraska
Posts: 125
Does the speedo cable also run the odometer and tripometer?
jacob.a.gasparp is offline   Reply With Quote
Old 09-26-2012, 07:52 PM   #12
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Quote:
Originally Posted by jacob.a.gasparp
Does the speedo cable also run the odometer and tripometer?
yes
dreamstang is offline   Reply With Quote
Old 09-26-2012, 08:03 PM   #13
Registered Member
Regular
 
jacob.a.gasparp's Avatar
 
Join Date: Dec 2011
Region: Nebraska
Posts: 125
Ok I'll definitely check that out
jacob.a.gasparp is offline   Reply With Quote
Old 09-27-2012, 01:27 PM   #14
Registered Member
Regular
 
Bily Pepp's Avatar
 
Join Date: Jan 2012
Region: Alabama
Posts: 72
I've got the same problem with my fuel gauge, it works only when I've been driving for 10-15 mins. Or so. Also my speedometer jumps until it gets to 20 then evens out, when I hit 60 it drops and hangs.
Bily Pepp is offline   Reply With Quote
Old 09-27-2012, 07:29 PM   #15
Registered User
Newbie
 
Join Date: Sep 2012
Region: North Carolina
Posts: 15
My speedo used to stick or jump till 20 and I just had to replace and grease the speedo some to smooth it out.
86.5ptOh is offline   Reply With Quote
Old 09-27-2012, 08:24 PM   #16
Registered Member
Regular
 
Robbiemustang96's Avatar
 
Join Date: Nov 2011
Region: Illinois
Posts: 622
my tach stays at 2500 all the time and i dont know whats wrong with it
Robbiemustang96 is offline   Reply With Quote
Old 09-29-2012, 11:40 PM   #17
Registered Member
Regular
 
Odub421's Avatar
 
Join Date: Jan 2012
Region: California
Posts: 34
I had the same problem with the tach in my 92 LX. I bought a replacement OEM tach and installed it myself. It works great now.
Odub421 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Very Nice Upgraded Vortech V1 S-Trim Kit (FULL KIT!! EVERYITHING)+ GAUGES AND PODS CodyNelson Mustang Parts for Sale and Wanted 16 09-30-2012 09:06 AM
LED Dash upgrade jroth823 Classic Mustangs 17 02-29-2012 07:38 AM
Triple pillar gauges RVAStang05 Mustang Paint, Appearance & Detailing 6 02-19-2012 07:08 AM
bugging out dashboard/battery light help! electrical problems ponyobsessed Pre-2005 V6 Mustang 0 01-20-2012 01:09 AM
speedo and gauges problems kirpy 2005-2010 V6 Mustang 0 10-20-2011 07:36 PM

» Like Us On Facebook



05:32 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.