91 mustang running really really rich. Need help.:) - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-29-2012, 02:28 PM   #1
Registered User
Newbie
 
Join Date: Sep 2012
Region: Florida
Posts: 1
91 mustang running really really rich. Need help.:)

Okay so I just bought a 91 5.0 mustang. And I had to drill and tap the intake manifold for the ait sensor or whatever it's called because the previous owner just had it laying on top of the engine not mounted.

The car runs really rich and I though that would fix it but it didn't. Any suggestions.

Also the car runs even richer when it rains or moist out. The car has an msd ignition box, I haven't had much time to work on the car but so far I have replace the coil and that's it.

All help is appreciated.
Attackthesystem is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-29-2012, 02:50 PM   #2
Road Trip!
Supporter
 
Join Date: Jun 2006
Region: Missouri
Posts: 8,779
Quote:
Originally Posted by Attackthesystem View Post
Okay so I just bought a 91 5.0 mustang. And I had to drill and tap the intake manifold for the ait sensor or whatever it's called because the previous owner just had it laying on top of the engine not mounted.

The car runs really rich and I though that would fix it but it didn't. Any suggestions.

Also the car runs even richer when it rains or moist out. The car has an msd ignition box, I haven't had much time to work on the car but so far I have replace the coil and that's it.

All help is appreciated.
1. Are you sure the AIT sensor is good?
2. Have you checked and tested the O2 sensors? (There is a link in the Useful Info sticky thread in this forum for test procedures.)
3. Have you checked and cleaned the MAF sensor?
4. Are you sure the injectors are good and not sticking open?
5. Have you checked the intake, injector ports, vacuum lines & fittings for leaks?
6. Are the plugs, plug wires, cap & rotor in good shape?
Trojan Horse is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



04:42 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.