92 LX 5.0 AOD Conv - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-20-2012, 01:16 AM   #1
Registered User
Newbie
 
Join Date: Oct 2012
Region: North Carolina
Posts: 2
92 LX 5.0 AOD Conv

92 lx 5.0 AOD, low torqe and power, some times pops and misses at wot when accelerating usally above 3000 rpm, changed rotor, plugs, tps, wires, cap, no engine light coming on, any suggestions? At cruse, then wot trans doesnt seem to drop to low-as far as the trans is that typical for these AOD's (not sure of current rear ratio-new project)? Thanks Brian
hvnfunyett is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-20-2012, 01:25 AM   #2
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
Check base timing and fuel pressure
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 10-20-2012, 06:19 PM   #3
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Also check for vac leaks. That happened to me a while back.
91notchback is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-20-2012, 06:27 PM   #4
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
ok im just a bit confused. aod converion? what exactly do you mean by that? because if you swapped from a t5 to a aod then i think you need to swap the ecu. slowstang kniws more than me on this one though.
dreamstang is offline   Reply With Quote
Old 10-21-2012, 09:36 AM   #5
Registered User
Newbie
 
Join Date: Oct 2012
Region: North Carolina
Posts: 2
Base was at 10btc, havent checked fuel pressure yet!

---------- Post added at 10:31 AM ---------- Previous post was at 10:29 AM ----------

Base timing was at 10 btc but seems to run better at 12, mas is clean looks fairly new, checked back pressure from from vacum on upper intake thinking maybe a bad cat, but vacum increased well at 2500rpm verses idle. Cleaning trottle body seemed to make it rev smoother but even after all Ive tried it performs like a wore out 6cyl. I just got this car and Im lost on this one. Ive had one of these 5.0 stangs before, and know how it should perform. Can anybody help me bring this 5.0 back to life. Thanks guys!

---------- Post added at 10:35 AM ---------- Previous post was at 10:31 AM ----------

Its an original aod, no swap

---------- Post added at 10:36 AM ---------- Previous post was at 10:35 AM ----------

No vacum leaks found.
hvnfunyett is offline   Reply With Quote
Old 10-21-2012, 11:52 AM   #6
Registered Member
Regular
 
Jar72's Avatar
 
Join Date: Oct 2012
Location: Albany
Region: Georgia
Posts: 127
Check cyl pressure if the rings are weak you'll have blow by under hard acceleration. Also check the harmonic balancer front and back In detail mine was beginning to wear out and I Found that the timing was way off when I installed the new one. I thought it was set at 14 and it was actually at 9.
__________________
JMF
Jar72 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:31 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.