need help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-28-2012, 10:41 AM   #1
Registered User
Newbie
 
Join Date: Nov 2012
Region: Florida
Posts: 3
need help

my 94 gt is running very rich, it is bone stock with 150,000 miles. i have checked the codes and i get an egr low flow and an o-2 lean left bank. maf is clean, idle air control is bad it think due to irratic rough idle, i also have a constant check engine light and air bag and anti lock light even after all codes are cleared. any thought?
fcapel4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-28-2012, 10:56 AM   #2
Registered Member
Regular
 
McNassty's Avatar
 
Join Date: Jul 2011
Posts: 600
How are you checking codes?
McNassty is offline   Reply With Quote
Old 11-28-2012, 03:13 PM   #3
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
Check timing, check spark plug (are they fouled). Whats the engine temp at (is it the stock gauge?) give us more info please

Wait, your getting a left bank O2 lean or the left bank is running lean? Do you have a vacuum leak? Does it sound like it?
Billymich is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-28-2012, 04:47 PM   #4
Registered User
Newbie
 
Join Date: Nov 2012
Region: Florida
Posts: 3
need help

i have replaced all vacuum lines , checked for intake gskt leaks, cleaned maf and iacv new plugs wires and dist cap. cleaned and oiled k&n fliter recently, but after problem started. i dont want to start throwing parts at this car unless i have direction. im old school shadetree mechanic and this is my first personal car that is injected. yes i have just graduated to this milennium. the car will fly at wot but blows black smelly smoke when i step on it. any ideas? also i used the inexpensive actron code extractor

---------- Post added at 05:42 PM ---------- Previous post was at 05:40 PM ----------

also engine temp is normal on stock gauge. everything on this car is stock i believe

---------- Post added at 05:47 PM ---------- Previous post was at 05:42 PM ----------

Quote:
Originally Posted by fcapel4 View Post
i have replaced all vacuum lines , checked for intake gskt leaks, cleaned maf and iacv new plugs wires and dist cap. cleaned and oiled k&n fliter recently, but after problem started. i dont want to start throwing parts at this car unless i have direction. im old school shadetree mechanic and this is my first personal car that is injected. yes i have just graduated to this milennium. the car will fly at wot but blows black smelly smoke when i step on it. any ideas? also i used the inexpensive actron code extractor

---------- Post added at 05:42 PM ---------- Previous post was at 05:40 PM ----------

also engine temp is normal on stock gauge. everything on this car is stock i believe
and i replace fuel pump, and filter, checked pressure regulator and have 32psi at idle
fcapel4 is offline   Reply With Quote
Old 11-28-2012, 06:12 PM   #5
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
Exhaust leak?
Billymich is offline   Reply With Quote
Old 11-28-2012, 11:40 PM   #6
Registered Member
Regular
 
McNassty's Avatar
 
Join Date: Jul 2011
Posts: 600
Supposed to be 38.5 at idle, and what are you hooking up to to get codes? '96 and up are when they started using ports for the code readers
McNassty is offline   Reply With Quote
Old 11-29-2012, 07:52 PM   #7
Registered User
Newbie
 
Join Date: Nov 2012
Region: Florida
Posts: 3
yes it has exhaust leak on pass bank, extracting codes with actron hand held. have put 3 airtex fuel pumps for low pressure issues, below 20 barely runs, but now i have major fuel system issue.way too rich. im gonna throw a pressure regulator on and see what happens
fcapel4 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



03:41 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.