mustang turns on but cant drive - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-30-2012, 01:27 PM   #1
Registered User
Newbie
 
nsguido415's Avatar
 
Join Date: Nov 2012
Region: California
Posts: 17
mustang turns on but cant drive

1992 mustang 5.0

So pretty much my car ran perfectly fine. i bought the car a cam, fuel injectors, fuel reg, mass airflow, new intake manifold, throttle body, cold air intake. Car drove perfectly fine no problems. Then the car started struggling when you gave it gas almost like it didnt want to run while it back fired and had no power. While in neutral no problem idle was great. Gave it gas no problem. Put the car in first gear started driving car would start back firing and shaking. Got to the stop sign car rpms would go up and down then after 10 seconds car would turn off. I would go to turn the car on the car wouldn't turn on. If i hit the gas then turned the key the car would turn on. No idle problems. Drive little bit and the problem would start all over. Unless i was at the light in neutral giving the car a little gas. Was too scared to drive the car so i would just take it home. I changed the throttle position sensor, indle control and the baf sensor. Now that i changed the spark plugs and cables. The car is not drivable. Put it in first gear i could slam on the gas and the car just turns off
nsguido415 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-30-2012, 01:37 PM   #2
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
Check timing.
Billymich is offline   Reply With Quote
Old 11-30-2012, 03:08 PM   #3
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Check fuel pressure also.
91notchback is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-30-2012, 03:17 PM   #4
Registered User
Newbie
 
nsguido415's Avatar
 
Join Date: Nov 2012
Region: California
Posts: 17
Quote:
Originally Posted by 91notchback View Post
Check fuel pressure also.
How do you check that
nsguido415 is offline   Reply With Quote
Old 11-30-2012, 04:31 PM   #5
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
Quote:
Originally Posted by nsguido415 View Post
How do you check that
+1
i'd also like to know, I think mines off. Though so is my timing... a bit retarded (no pun intended)
Billymich is offline   Reply With Quote
Old 11-30-2012, 05:08 PM   #6
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
You can rent a tool from autozone, or LMS sells a gauge that screws into the schrader valve for like $40. That's what I have, and it beats renting a tool everytime!
91notchback is offline   Reply With Quote
Old 11-30-2012, 05:17 PM   #7
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Quote:
Originally Posted by 91notchback
You can rent a tool from autozone, or LMS sells a gauge that screws into the schrader valve for like $40. That's what I have, and it beats renting a tool everytime!
LRS that is...lmao!
91notchback is offline   Reply With Quote
Old 11-30-2012, 05:50 PM   #8
Registered User
Newbie
 
nsguido415's Avatar
 
Join Date: Nov 2012
Region: California
Posts: 17
Quote:
Originally Posted by 91notchback View Post

LRS that is...lmao!
What should it be set as? I think my mass air flow is up to 75mm and my injectors are 24lb
nsguido415 is offline   Reply With Quote
Old 11-30-2012, 06:01 PM   #9
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
38-40 psi with vac line on fuel pressure regulator removed and plugged with something. I'm curious as hell as to what's causin your issues man.
91notchback is offline   Reply With Quote
Old 11-30-2012, 07:29 PM   #10
Registered User
Newbie
 
nsguido415's Avatar
 
Join Date: Nov 2012
Region: California
Posts: 17
Quote:
Originally Posted by 91notchback View Post
38-40 psi with vac line on fuel pressure regulator removed and plugged with something. I'm curious as hell as to what's causin your issues man.
Was i suppose to dyno my car?
nsguido415 is offline   Reply With Quote
Old 11-30-2012, 07:34 PM   #11
Registered Member
Regular
 
McNassty's Avatar
 
Join Date: Jul 2011
Posts: 600
Depends on what size cam you went with and also if you got a MAF calibrated to 24lb injectors
McNassty is offline   Reply With Quote
Old 11-30-2012, 11:09 PM   #12
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Quote:
Originally Posted by McNassty
Depends on what size cam you went with and also if you got a MAF calibrated to 24lb injectors
What cam? Stock heads? Intake? If so... No need for fuel swap....
91notchback is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:43 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.