Gas guzzlin 5.0 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-19-2008, 06:58 PM   #1
Registered User
Newbie
 
Join Date: Mar 2008
Posts: 5
Angry Gas guzzlin 5.0

Well, here we go again. No power, and burnin lots of fuel. Does anyone know what makes a eec-iv speed density system go into closed loop control, is it temp or just after a certain period of time. My o2 sensors are reading super rich, but I don't think the computer is trying to compensate for it. All my electrical connections check out, and the computer isn't throwing any codes. 4 MILES PER GALLON, @ $5.00 a gallon, do the math, I NEED HELP!
79Bronco5L is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-20-2008, 12:57 AM   #2
Legacy Member
Legacy
 
MonteCitan's Avatar
 
Join Date: Aug 2004
Region: California
Posts: 2,506
Send a message via AIM to MonteCitan
Re: Gas guzzlin 5.0

Check the MAP sensor and test the TP sensor...

MAF could be dying, too - that is assuming you've done the EFI swap
__________________
2012 IS F Blue IS F Sport
2006 Mustang V6 wannabe
MonteCitan is offline   Reply With Quote
Old 06-20-2008, 07:36 AM   #3
Road Trip!
 
Cajun JungleBoy's Avatar
 
Join Date: Dec 2005
Region: Louisiana
Posts: 1,147
Send a message via AIM to Cajun JungleBoy Send a message via Yahoo to Cajun JungleBoy
Re: Gas guzzlin 5.0

lol my 5.0 burns **** loads of gas.... and is super hot... but that is prolly because of the blower...
Cajun JungleBoy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-20-2008, 08:48 PM   #4
Legacy Member
Legacy
 
Scut95's Avatar
 
Join Date: May 2005
Region: California
Posts: 501
Re: Gas guzzlin 5.0

Quote:
lol my 5.0 burns **** loads of gas.... and is super hot... but that is prolly because of the blower...
I thought my car was running really hot, i threw a mechnical gauge in and found it was running between 190-210...the fan kicks on at 210, the stock gauge is up in the upper end towards the H FYI....the gas is probably the blower, boost is a great thing except for gas milage haha
Scut95 is offline   Reply With Quote
Old 06-20-2008, 09:29 PM   #5
Registered User
Newbie
 
Join Date: Mar 2008
Posts: 5
Re: Gas guzzlin 5.0

Quote:
Originally Posted by MonteCitan View Post
Check the MAP sensor and test the TP sensor...

MAF could be dying, too - that is assuming you've done the EFI swap
Been there, tried that. Thanks for the input, though. Think its almost time for a carb!
79Bronco5L is offline   Reply With Quote
Old 01-14-2011, 01:39 AM   #6
Registered Member
Regular
 
94 Mustang GT's Avatar
 
Join Date: Jan 2011
Region: Minnesota
Posts: 165
Re: Gas guzzlin 5.0

Quote:
Originally Posted by 79Bronco5L View Post
Well, here we go again. No power, and burnin lots of fuel. Does anyone know what makes a eec-iv speed density system go into closed loop control, is it temp or just after a certain period of time. My o2 sensors are reading super rich, but I don't think the computer is trying to compensate for it. All my electrical connections check out, and the computer isn't throwing any codes. 4 MILES PER GALLON, @ $5.00 a gallon, do the math, I NEED HELP!
Time has nothing to do with when it will go into closed loop. Its temp with other factors! but your o2 cant be reading super rich if its not setting any codes! what i can think of is that its throwing extra gas in to cool the engine but i dont think it would do that if its only at 210! And hopefully by now you fixed the issue!! lol if so what was the issue???
94 Mustang GT is offline   Reply With Quote
Old 01-14-2011, 11:18 PM   #7
Titus Wadicus
Regular
 
svtlx's Avatar
 
Join Date: Jan 2007
Region: Ohio
Posts: 2,103
Send a message via Yahoo to svtlx
Re: Gas guzzlin 5.0

where da fuk r all these old threads cumn from????
__________________

bbk ssi, 70ml t.b., bbk adj.reg., bd11-a 11psi, e-cam,
racing aod, 2700 stall, 3.42 gears, ported e7, 308ci, 1.7rr, comp .560valve springs, gear drive, high dwell module, msd 6a & coil, bbk off road xpipe, mac cat back, 30lbs inj, pro-m 90mm, welded subframe connectors, boxed upper & lower trailing arms, spherical axle bushings, 255/50/16 tires, 255lph pump, 456hp
svtlx is offline   Reply With Quote
Old 01-14-2011, 11:31 PM   #8
Registered Member
Regular
 
94 Mustang GT's Avatar
 
Join Date: Jan 2011
Region: Minnesota
Posts: 165
Re: Gas guzzlin 5.0

Quote:
Originally Posted by svtlx View Post
where da fuk r all these old threads cumn from????
hahahaha. I like to read the old threads and see what people did to solve their question! lol
94 Mustang GT is offline   Reply With Quote
Old 01-16-2011, 11:49 AM   #9
Registered Member
Regular
 
ibleedblue65's Avatar
 
Join Date: Dec 2010
Region: Georgia
Posts: 182
Quote:
Originally Posted by 94 Mustang GT

hahahaha. I like to read the old threads and see what people did to solve their question! lol
Lol. Its possible the computer its trying to compensate for the rich condition but can't. Leaking injector or fuel pressure too high.
ibleedblue65 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



03:02 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.