Head lights - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-14-2013, 07:42 PM   #1
Registered Member
Regular
 
93fox's Avatar
 
Join Date: Mar 2012
Region: Missouri
Posts: 36
Head lights

What's up everyone. So a few weeks ago my head lights started actin up. My brights would just shut off randomly out of no where, but my dims would work fine. Then other times my brights wouldn't even turn on, and sometimes they work perfectly. I was kinda pushing aside the problem until today my lights just stopped working completely. Nothing at all. Any input would be greatly appreciated. Thanks
93fox is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-14-2013, 08:39 PM   #2
Evolution's Finest
Supporter
 
SCCofSV's Avatar
 
Join Date: Mar 2012
Location: Burbank,Well, Close enough!
Region: California
Posts: 366
Okay, we need a little more info, such as, are they Halogen or HID? Did you check either of the bulbs or connection. I know stupid question but one that needs to be asked. If they were HID, my guess is that it is a Bad ballast (you just discribed what happen to my lights and that was my problem) or. 2. Bulbs and 3. a short somewhere in the harness. I know very little about halogen bulbs. l'm sure the guys here can help you better than l.
SCCofSV is offline   Reply With Quote
Old 02-14-2013, 08:41 PM   #3
Registered Member
Regular
 
1slosix's Avatar
 
Join Date: Jul 2012
Region: Tennessee
Posts: 7,311
no you're right on the money...those questions have to be answered first
__________________

carving corners like a boss
1slosix is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-14-2013, 08:54 PM   #4
Registered Member
Regular
 
93fox's Avatar
 
Join Date: Mar 2012
Region: Missouri
Posts: 36
They are halogens. I don't think it's the bulbs because when I pull back on the dimmer switch, to flash the brights they work fine. But when I let go, of course they turn off.
93fox is offline   Reply With Quote
Old 02-14-2013, 09:25 PM   #5
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
Are your dash lights going out too? It's likely a bad switch.
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 02-14-2013, 09:35 PM   #6
Registered Member
Regular
 
93fox's Avatar
 
Join Date: Mar 2012
Region: Missouri
Posts: 36
No, they all work fine.
93fox is offline   Reply With Quote
Old 02-15-2013, 10:01 AM   #7
Registered User
Newbie
 
87mustangGT's Avatar
 
Join Date: Oct 2012
Region: Massachusetts
Posts: 19
My bet would be multi function switch had this problem in my 90 convert
87mustangGT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:32 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.