Help!!! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-11-2013, 09:07 PM   #1
Registered User
Newbie
 
87mustangGT's Avatar
 
Join Date: Oct 2012
Region: Massachusetts
Posts: 19
Help!!!

Dont know whats wrong with my car took it out today and it stalled. Cranks and cranks has spark but the fuel pump doesn't kick on when i hit the key changed the fuel pump and checked the relays the inertia switch is good and didnt trip i even tried bypassing that please any suggestions will help
87mustangGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-11-2013, 09:43 PM   #2
Registered Member
Regular
 
maldog's Avatar
 
Join Date: Jun 2012
Region: Nevada
Posts: 1,563
I'm not sure if that year stang has a fuel safety CB ( circuit breaker) Check your service manual or go online. it may have popped out and you will have to reset it.

---------- Post added at 07:43 PM ---------- Previous post was at 07:39 PM ----------

Found this for you.....

You might also want to check the conditon of your fuel cut off inertia (sp?) switch located in the hatchback under the interior panel towards the rear of the hatch.Its a shock sensitive button switch...if you are in an accident it pops out like a circuit breaker to cut off power to your fuel pump...if it was triggered all you have to do is push the button to reset it...You might want to check to see if there are any problems with this switch that may be causing it to intermittantly fail?
__________________
2006 Mustang GT Premium RedFire. CAI, SLP Loudmouth, SCT Progammer, 5 speed manual trans. My other car is a CORVETTE!
maldog is offline   Reply With Quote
Old 03-12-2013, 05:45 AM   #3
Registered User
Newbie
 
87mustangGT's Avatar
 
Join Date: Oct 2012
Region: Massachusetts
Posts: 19
Ive checked tgat switch an even jumped it out still nothing
87mustangGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-12-2013, 06:11 AM   #4
Registered Member
Regular
 
Finchms's Avatar
 
Join Date: Jan 2012
Region: Georgia
Posts: 208
Quote:
Originally Posted by 87mustangGT View Post
Ive checked tgat switch an even jumped it out still nothing
Have u checked the relay under the drivers seat?
Finchms is offline   Reply With Quote
Old 03-12-2013, 08:23 AM   #5
Registered User
Newbie
 
87mustangGT's Avatar
 
Join Date: Oct 2012
Region: Massachusetts
Posts: 19
Yes and bought a new one and the ecu in the passenger kick panel
87mustangGT is offline   Reply With Quote
Old 03-13-2013, 05:39 AM   #6
Registered Member
Regular
 
Finchms's Avatar
 
Join Date: Jan 2012
Region: Georgia
Posts: 208
U make sure u getting power thru the wire coming from the ecu? U may need to start chasing wires to see if any are broken or frayed.
Finchms is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



03:22 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.