94 5.0 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-23-2013, 12:34 PM   #1
Registered Member
Regular
 
Rcansawroy's Avatar
 
Join Date: Sep 2012
Region: Arkansas
Posts: 22
94 5.0

Fuel pump or ccrm,,, I'm stuck should I replace both and if so should I upgrade my fuel pump? Where do I fin the right ccrm I read a thread b4 that said advance but no advance close to me
Rcansawroy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-23-2013, 05:28 PM   #2
Road Trip!
 
Join Date: Jul 2012
Region: Ohio
Posts: 422
Whats the problem?
keaton5.0 is offline   Reply With Quote
Old 03-24-2013, 01:37 PM   #3
Registered Member
Regular
 
Rcansawroy's Avatar
 
Join Date: Sep 2012
Region: Arkansas
Posts: 22
Fuel pump not working well I can't here it anyways!!!
Rcansawroy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-26-2013, 12:45 PM   #4
Registered User
Newbie
 
Join Date: May 2012
Location: Norfolk
Region: Virginia
Posts: 6
Mine was doing the same thing, and when we tested it with a mulimeter, i only had like 8 or 9 volts going to it, and none past the conectors on it. so what we did, is just hot wired it to a toggle switch. didnt feel like trying to figure out where the low volts where comming from.
94gt_Michael is offline   Reply With Quote
Old 03-26-2013, 02:07 PM   #5
Registered Member
Regular
 
Rcansawroy's Avatar
 
Join Date: Sep 2012
Region: Arkansas
Posts: 22
Ok now I don't have any fire at all to the coil
Rcansawroy is offline   Reply With Quote
Old 03-26-2013, 06:46 PM   #6
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Ok we need some more info. What exactly isn't working? What do we know at this point?
From what I can tell your fuel pump and coil are both not working?
Also have you done any tests?
dreamstang is offline   Reply With Quote
Old 03-26-2013, 07:05 PM   #7
Registered Member
Regular
 
Rcansawroy's Avatar
 
Join Date: Sep 2012
Region: Arkansas
Posts: 22
Man I'm lost I just replace the distr. and the igniton module and still no fire as for the fuel pump it works when running a hot wire to it and it came on but car want start and there isn't any fire in the coil wire I'm not giving up just lost and as far as test I dot know any to run but koke test and I can't get anything outta the ecc nexus my battery is dead my friend is at work so can't get a jump or borrow his charger
Rcansawroy is offline   Reply With Quote
Old 03-26-2013, 07:19 PM   #8
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Quote:
Originally Posted by Rcansawroy View Post
Man I'm lost I just replace the distr. and the igniton module and still no fire as for the fuel pump it works when running a hot wire to it and it came on but car want start and there isn't any fire in the coil wire I'm not giving up just lost and as far as test I dot know any to run but koke test and I can't get anything outta the ecc nexus my battery is dead my friend is at work so can't get a jump or borrow his charger
Hmmm. Does sound like a possible erc relay. I believe it's under the passenger seat. I also think there is another really like it somewhere on the car that you cam swap just to test. But I dont remember which one.

I would get a wiring schematic and test the relay before buying one. Make sure the relay is functioning if you can't find one to swap.

Read through this when u get a chance.
http://sbftech.com/index.php/topic,588.0.html
dreamstang is offline   Reply With Quote
Old 03-26-2013, 07:56 PM   #9
Registered Member
Regular
 
94GT302's Avatar
 
Join Date: Jul 2012
Region: Missouri
Posts: 98
Quote:
Originally Posted by dreamstang View Post

Hmmm. Does sound like a possible erc relay. I believe it's under the passenger seat. I also think there is another really like it somewhere on the car that you cam swap just to test. But I dont remember which one.

I would get a wiring schematic and test the relay before buying one. Make sure the relay is functioning if you can't find one to swap.

Read through this when u get a chance.
http://sbftech.com/index.php/topic,588.0.html
ERC Relay?
94GT302 is offline   Reply With Quote
Old 03-26-2013, 07:57 PM   #10
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Quote:
Originally Posted by 94GT302 View Post

ERC Relay?
Eec
dreamstang is offline   Reply With Quote
Old 03-26-2013, 11:24 PM   #11
Road Trip!
 
Join Date: Jul 2012
Region: Ohio
Posts: 422
On most fox bodies the eec relay is located in the passenger side kick panel and the fuel pump relay is under the driver seat. I think in like 92 or 93 they both were moved to the engine compartment next to the maf sensor, im not sure if that applies to sn95s tho
keaton5.0 is offline   Reply With Quote
Old 03-27-2013, 07:34 PM   #12
Registered Member
Regular
 
Rcansawroy's Avatar
 
Join Date: Sep 2012
Region: Arkansas
Posts: 22
I run a wire to the red coil wire car starts take it off and it dies plz help me out
Rcansawroy is offline   Reply With Quote
Old 03-27-2013, 07:39 PM   #13
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
You need to use a schematic and trace that wire back with a meter.
dreamstang is offline   Reply With Quote
Old 03-27-2013, 07:45 PM   #14
Registered Member
Regular
 
Rcansawroy's Avatar
 
Join Date: Sep 2012
Region: Arkansas
Posts: 22
Everything work just runs sluggish with the wire from the coil to the battery
Rcansawroy is offline   Reply With Quote
Old 03-27-2013, 07:49 PM   #15
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
so you just need a new wire then eh?
dreamstang is offline   Reply With Quote
Old 03-27-2013, 08:05 PM   #16
Registered Member
Regular
 
Rcansawroy's Avatar
 
Join Date: Sep 2012
Region: Arkansas
Posts: 22
Dude I wanna thank u for everything u done and will do but seriously I'm lost here
Rcansawroy is offline   Reply With Quote
Old 03-27-2013, 08:10 PM   #17
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
No problem man.
Sorry if I'm being dense here, but if you have a bad wire and know which one it is what's the problem. Sorry I'm just not understanding what exactly you need. But I will do my best to help you.
dreamstang is offline   Reply With Quote
Old 03-27-2013, 08:15 PM   #18
Registered Member
Regular
 
Rcansawroy's Avatar
 
Join Date: Sep 2012
Region: Arkansas
Posts: 22
If and when I put a wire to the battery from the coil positive side car will fire I've replaced the dist an ignitin control module
Rcansawroy is offline   Reply With Quote
Old 03-27-2013, 08:22 PM   #19
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Ok so it works when u bypass the ignition wire on the coil? Let me look at a schematic and see I can help. But u probably are gonna have an ignition problem that needs to tracked down.
dreamstang is offline   Reply With Quote
Old 03-27-2013, 08:39 PM   #20
Registered Member
Regular
 
Rcansawroy's Avatar
 
Join Date: Sep 2012
Region: Arkansas
Posts: 22
Ok I'm trying to find the wire and a digram trust me I haven't driven my pony in three weeks and its killing me jack
Rcansawroy is offline   Reply With Quote
Old 03-27-2013, 08:46 PM   #21
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Ok. The wire comes from the igniton switch and through the neutral safety switch.

Here is a diagram. If you have a Haynes or Chilton they will also be located in the back. And of course some more diagrams are located in the useful sticky thread.

But your gonna have to check that wire coming out of the igniton switch. Then check that it gets through the neutral safety switch. Then of course from there to the coil. Also forgot to mention there is a fusable link in that wire to. Just start from the beginning and verify voltage one step at a time until you find the bad spot.
Attached Thumbnails
Click image for larger version

Name:	ForumRunner_20130327_204626.png
Views:	62
Size:	62.9 KB
ID:	98856  
dreamstang is offline   Reply With Quote
Old 03-27-2013, 09:06 PM   #22
Registered Member
Regular
 
Rcansawroy's Avatar
 
Join Date: Sep 2012
Region: Arkansas
Posts: 22
U think control module is my problem dreamstang
Rcansawroy is offline   Reply With Quote
Old 03-27-2013, 09:09 PM   #23
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Not sure.
dreamstang is offline   Reply With Quote
Old 03-27-2013, 09:24 PM   #24
Road Trip!
 
Join Date: Apr 2011
Region: Indiana
Posts: 8,044
Hey you got an email address so I can send you a better diagram?
dreamstang is offline   Reply With Quote
Old 03-28-2013, 07:36 AM   #25
Registered Member
Regular
 
Rcansawroy's Avatar
 
Join Date: Sep 2012
Region: Arkansas
Posts: 22
Rcansawroy@gmail.com and thanks bro
Rcansawroy is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Members Mustangs

Mustang

lemons95

Kraken

Cise
Add your Mustang
» Like Us On Facebook



11:15 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.