89 mustang to slow help - Page 2 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-06-2013, 09:36 PM   #36
Registered Member
Regular
 
Dion11197's Avatar
 
Join Date: Mar 2011
Region: Texas
Posts: 829
Yeah, 13.9 is definitely better. Now to dial in his combo.
Dion11197 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-07-2013, 06:30 AM   #37
Registered Member
Regular
 
DustyStang306's Avatar
 
Join Date: Feb 2013
Location: Belleville On
Region: Canada
Posts: 342
Quote:
Originally Posted by Dion11197
Yeah, 13.9 is definitely better. Now to dial in his combo.
Ye that's what I was thinking I'm thinking it still should be a little faster I'm guessing he's using gt40 heads then
DustyStang306 is offline   Reply With Quote
Old 05-07-2013, 07:09 AM   #38
Registered Member
Regular
 
Dion11197's Avatar
 
Join Date: Mar 2011
Region: Texas
Posts: 829
Quote:
Originally Posted by DustyStang306 View Post

Ye that's what I was thinking I'm thinking it still should be a little faster I'm guessing he's using gt40 heads then
Even still with a cam and all I would think low 13's.
Dion11197 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-07-2013, 09:17 AM   #39
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
Quote:
Originally Posted by DustyStang306 View Post

Ye that's what I was thinking I'm thinking it still should be a little faster I'm guessing he's using gt40 heads then
Sounds more like stock heads. High 12s low 13s with gt40 heads.
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 05-07-2013, 11:38 AM   #40
Registered Member
Regular
 
DustyStang306's Avatar
 
Join Date: Feb 2013
Location: Belleville On
Region: Canada
Posts: 342
Quote:
Originally Posted by 93slowstang

Sounds more like stock heads. High 12s low 13s with gt40 heads.
Haha ye iv seen e7s with port work do high 12s haha I'm thinking your right on that one put a bottle in her in start put down some high 11 to mid 11
DustyStang306 is offline   Reply With Quote
Old 05-07-2013, 02:07 PM   #41
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Yeah I think he should be doing less but the track down here sucks

---------- Post added at 02:07 PM ---------- Previous post was at 02:05 PM ----------

His heads are aluminum just haven't took the time to check what they really are
Jcstang is offline   Reply With Quote
Old 05-07-2013, 05:24 PM   #42
Registered Member
Regular
 
DustyStang306's Avatar
 
Join Date: Feb 2013
Location: Belleville On
Region: Canada
Posts: 342
Quote:
Originally Posted by Jcstang
Yeah I think he should be doing less but the track down here sucks

---------- Post added at 02:07 PM ---------- Previous post was at 02:05 PM ----------

His heads are aluminum just haven't took the time to check what they really are
Where I am we got the one of the worst track in Ontario but theres no guys I know running h/c/I an only getting a 13.9 there hitting like low 13s an high 12s even a few in the high 11 what tires was he running an what size was there lots of wheel spin? An what gears he in when he's just passes the 1/4 mark? I'm just trying to see why it could be that slow I run faster the that with a stock 302 with a b303 cam an a typhoon upper an lower with port work an the e7s that were on it were ported a bit to my best time was 13.4 with slicks a I had 3:73 gears at that time
DustyStang306 is offline   Reply With Quote
Old 05-07-2013, 08:43 PM   #43
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Yeah he has 3.73 and he ran with drag radials some wheel spin

---------- Post added at 08:43 PM ---------- Previous post was at 08:41 PM ----------

No way the track out here if you loose expect to have a broken windshield half way the track it's unleveled oh and have to be careful with a pothole
Jcstang is offline   Reply With Quote
Old 05-12-2013, 01:33 PM   #44
Registered Member
Regular
 
Tkcobrasvt's Avatar
 
Join Date: May 2013
Location: Louisville
Region: Kentucky
Posts: 21
You need to pull your mass air sensor completely out of the mass air housing using the special torque bit with the hole in the middle and get a Q-tip with rubbing alcohol and clean very lightly the mass air filament. I did this on my 95 cobra the day I got it and instantly gained and extra 40% power. My cobra wouldn't even go 90mph in 3rd gear. Try this I bet it will help tremendously. It should take no more then 4 min to do. Nothing to loose!
Tkcobrasvt is offline   Reply With Quote
Old 07-08-2013, 03:02 PM   #45
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Now car feels ok but not fast enough but the reason I'm here again is the car is overheating and wanted to know if swapping pulleys affect the temp and if it does how much more
Jcstang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



01:19 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.