89 mustang to slow help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-21-2013, 11:29 PM   #1
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
89 mustang to slow help

Alright here I go a body of mine has an 89 mistang 5.0 and we can't get 1/4 mile times less than 15.3 what could be the problem does a Dyno tune work for that year model

---------- Post added at 11:29 PM ---------- Previous post was at 11:28 PM ----------

Sorry buddy
Jcstang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-21-2013, 11:38 PM   #2
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Quote:
Originally Posted by Jcstang View Post
Alright here I go a body of mine has an 89 mistang 5.0 and we can't get 1/4 mile times less than 15.3 what could be the problem does a Dyno tune work for that year model

---------- Post added at 11:29 PM ---------- Previous post was at 11:28 PM ----------

Sorry buddy
Start spending money and turnin wrenches!lol HCI would crank on your times...

---------- Post added at 11:38 PM ---------- Previous post was at 11:37 PM ----------

And rear end gears...
91notchback is offline   Reply With Quote
Old 04-21-2013, 11:39 PM   #3
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Car has everything I could imagine
Jcstang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-21-2013, 11:40 PM   #4
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
Quote:
Originally Posted by 91notchback View Post

Start spending money and turnin wrenches!lol HCI would crank on your times...

---------- Post added at 11:38 PM ---------- Previous post was at 11:37 PM ----------

And rear end gears...
+1.
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 04-21-2013, 11:40 PM   #5
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Gears heads intake tko tranny 4:10 gears
Jcstang is offline   Reply With Quote
Old 04-21-2013, 11:43 PM   #6
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Quote:
Originally Posted by Jcstang View Post
Car has everything I could imagine
WWHHHAAATT??? At a 15sec 1/4???

---------- Post added at 11:43 PM ---------- Previous post was at 11:42 PM ----------

Specs please.
91notchback is offline   Reply With Quote
Old 04-21-2013, 11:48 PM   #7
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
I know it has 4:10 hears at rear end heads I really don't know the brand it has a steeda 18 cam stage 2 clutch comp cams 1.6 lifters cobra intake manifold if I'm correct 75 mm throttle body MAF. Calibrated for bigger injectors
Jcstang is offline   Reply With Quote
Old 04-22-2013, 12:00 AM   #8
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Quote:
Originally Posted by Jcstang View Post
I know it has 4:10 hears at rear end heads I really don't know the brand it has a steeda 18 cam stage 2 clutch comp cams 1.6 lifters cobra intake manifold if I'm correct 75 mm throttle body MAF. Calibrated for bigger injectors
A stock fox runs about a low 14/high 13. I've never heard of a modded one runnin UNDER stock. You got me...
91notchback is offline   Reply With Quote
Old 04-22-2013, 12:03 AM   #9
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
Quote:
Originally Posted by 91notchback View Post

A stock fox runs about a low 14/high 13. I've never heard of a modded one runnin UNDER stock. You got me...
Driver mod...???
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 04-22-2013, 12:04 AM   #10
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Quote:
Originally Posted by 93slowstang View Post

Driver mod...???
my next answer...
91notchback is offline   Reply With Quote
Old 04-22-2013, 12:09 AM   #11
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
That's what I thought at first everyone drove the car 15.6 and up I hit a 15.3 and it's weird cause I have another buddy with a almost stock 5.0 and hit a 15.0 with regular tires what could it be
Jcstang is offline   Reply With Quote
Old 04-22-2013, 12:14 AM   #12
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Quote:
Originally Posted by Jcstang View Post
That's what I thought at first everyone drove the car 15.6 and up I hit a 15.3 and it's weird cause I have another buddy with a almost stock 5.0 and hit a 15.0 with regular tires what could it be
Hell...ya got me! I've gotta friend that drove a STOCK civic hatch 1.5 at 15.3. Something's up...
91notchback is offline   Reply With Quote
Old 04-22-2013, 12:19 AM   #13
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Yeah I can't seem to find the problem
Jcstang is offline   Reply With Quote
Old 04-22-2013, 12:24 AM   #14
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Quote:
Originally Posted by Jcstang View Post
Yeah I can't seem to find the problem
I'm in the middle of a WORKED gt40 build with supporting mods, and I'm expecting high 12s. Does he have all supporting mods?

---------- Post added at 12:24 AM ---------- Previous post was at 12:23 AM ----------

High12s/LOW13s
91notchback is offline   Reply With Quote
Old 04-22-2013, 12:27 AM   #15
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Yeah
Jcstang is offline   Reply With Quote
Old 04-22-2013, 12:30 AM   #16
Registered Member
Regular
 
91notchback's Avatar
 
Join Date: Feb 2012
Region: Texas
Posts: 493
Quote:
Originally Posted by Jcstang View Post
Yeah
****.....

---------- Post added at 12:30 AM ---------- Previous post was at 12:29 AM ----------

I can't say ****!??
91notchback is offline   Reply With Quote
Old 04-22-2013, 03:49 AM   #17
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
Do a compression check, something is not right. Bad valve job is my guess.
tc x 4 is offline   Reply With Quote
Old 04-22-2013, 06:53 AM   #18
Registered Member
Regular
 
Dion11197's Avatar
 
Join Date: Mar 2011
Region: Texas
Posts: 829
Yeah, something is wrong! Lol

See if you can get a spec in the heads too! If he's got an over sized head that flows too much it can actually hurt performance. And I'm wondering if the head and intake ports are matched??

There could be engine problems..... Have y'all pulled the plugs to see how it's running?

I'm thinking either there's something really wrong with the engine combo or it's just REALLY tired.
Dion11197 is offline   Reply With Quote
Old 04-22-2013, 09:28 AM   #19
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
It's bored over .40 just rebuilt but before the button end got fixed that valves were hitting in the old pistons I don't know if the mechanic checked the heads

---------- Post added at 09:28 AM ---------- Previous post was at 09:27 AM ----------

BTW how could I know what kind of heads he's got they should have some kind of a serial # right
Jcstang is offline   Reply With Quote
Old 04-22-2013, 09:50 AM   #20
Registered Member
Regular
 
Dion11197's Avatar
 
Join Date: Mar 2011
Region: Texas
Posts: 829
They should, usually they are marked.

I'm wondering if the mechanic fixed everything. Sometimes if there's serious piston to valve contact, the valve gets bent. As mentioned earlier, I think a compression test is needed. I would also check all the plugs to see how it's running.

Does the engine sound on when running? I'm also wondering if its running on all cylinders.....

---------- Post added at 07:49 AM ---------- Previous post was at 07:49 AM ----------

Does it sound ok when running?

---------- Post added at 07:50 AM ---------- Previous post was at 07:49 AM ----------

Any misses or sputters? And does it seem to pull all the way through the RPM range or does it fall off?
Dion11197 is offline   Reply With Quote
Old 04-22-2013, 12:23 PM   #21
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Yeah engine sounds nice and strong but doesn't run strong it has a mean take off but that's it

---------- Post added at 12:23 PM ---------- Previous post was at 12:22 PM ----------

Only when cold on initial startup backfires through the intake when it warms up it sounds ok
Jcstang is offline   Reply With Quote
Old 04-22-2013, 12:27 PM   #22
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
Quote:
Originally Posted by Jcstang View Post
Yeah engine sounds nice and strong but doesn't run strong it has a mean take off but that's it

---------- Post added at 12:23 PM ---------- Previous post was at 12:22 PM ----------

Only when cold on initial startup backfires through the intake when it warms up it sounds ok
Timing sounds off if its backfiring through the intake. May possibly have an issue with the fuel system as well.
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 04-22-2013, 12:31 PM   #23
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
Quote:
Originally Posted by 93slowstang

Timing sounds off if its backfiring through the intake. May possibly have an issue with the fuel system as well.
Yep
tc x 4 is offline   Reply With Quote
Old 04-22-2013, 12:40 PM   #24
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Fuel problem it did have a bad injector and all of them were swapped afterwards
Jcstang is offline   Reply With Quote
Old 04-22-2013, 12:44 PM   #25
Registered Member
Regular
Supporter
 
93slowstang's Avatar
 
Join Date: Jan 2011
Location: Walker
Region: Louisiana
Posts: 3,436
Quote:
Originally Posted by Jcstang View Post
Fuel problem it did have a bad injector and all of them were swapped afterwards
You definitely need to check the base timing, if its good then you need to check the fuel pressure and make sure it's around 40# with the vacuum line pulled at idle.
__________________


93 GT with more junkyard mods than you can imagine.
90 GT bone stock down to the air filter, awaiting restoration.
Join Mustang Evolution today. Click here
93slowstang is offline   Reply With Quote
Old 04-22-2013, 12:46 PM   #26
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Ill check after work that plus compression
Jcstang is offline   Reply With Quote
Old 04-22-2013, 03:57 PM   #27
Registered Member
Regular
 
Dion11197's Avatar
 
Join Date: Mar 2011
Region: Texas
Posts: 829
Quote:
Originally Posted by 93slowstang View Post

You definitely need to check the base timing, if its good then you need to check the fuel pressure and make sure it's around 40# with the vacuum line pulled at idle.
+1
Dion11197 is offline   Reply With Quote
Old 04-28-2013, 09:29 AM   #28
Registered Member
Regular
 
Dion11197's Avatar
 
Join Date: Mar 2011
Region: Texas
Posts: 829
Did you find out anything?
Dion11197 is offline   Reply With Quote
Old 04-28-2013, 02:24 PM   #29
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Nope not yet my buddy ended up taking it to a performance shop but once he gets it back ill post on what they found
Jcstang is offline   Reply With Quote
Old 04-28-2013, 02:42 PM   #30
Registered Member
Regular
 
Dion11197's Avatar
 
Join Date: Mar 2011
Region: Texas
Posts: 829
Cool.
Dion11197 is offline   Reply With Quote
Old 04-30-2013, 01:31 PM   #31
Registered Member
Regular
 
Join Date: Apr 2013
Location: Coldwater
Region: Michigan
Posts: 20
Naut is offline   Reply With Quote
Old 05-05-2013, 09:59 PM   #32
Registered Member
Regular
 
Dion11197's Avatar
 
Join Date: Mar 2011
Region: Texas
Posts: 829
Anything new?
Dion11197 is offline   Reply With Quote
Old 05-06-2013, 02:15 PM   #33
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
Yes the mechanic said it was a main wire harness (salt and pepper connector) car ran a 13.9 yesterday
Jcstang is offline   Reply With Quote
Old 05-06-2013, 07:22 PM   #34
Registered Member
Regular
 
DustyStang306's Avatar
 
Join Date: Feb 2013
Location: Belleville On
Region: Canada
Posts: 342
Quote:
Originally Posted by Jcstang
Yes the mechanic said it was a main wire harness (salt and pepper connector) car ran a 13.9 yesterday
That's a little better haha what heads is he running?
DustyStang306 is offline   Reply With Quote
Old 05-06-2013, 08:13 PM   #35
Registered Member
Regular
 
Jcstang's Avatar
 
Join Date: Mar 2013
Location: Laredo
Region: Texas
Posts: 33
I really don't know
Jcstang is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



08:11 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.