New to site! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-16-2013, 08:46 PM   #1
Registered User
Newbie
 
Join Date: May 2013
Location: La county
Region: California
Posts: 4
New to site!

I just replaced my distributor on my 86 gt, including the tfi module. Not three weeks passed and it burned it again. What could be running too hot?
4eyesvt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-16-2013, 09:05 PM   #2
Registered Member
Regular
 
05 MUSTANG GT's Avatar
 
Join Date: Nov 2012
Region: Maryland
Posts: 138
Welcome I'm sure someone here can help solve your issue
05 MUSTANG GT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:02 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.