radio randomly stopped working it seems to be wireing any help - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-03-2013, 05:51 PM   #1
Registered Member
Regular
 
The420fox's Avatar
 
Join Date: Jan 2013
Location: 707
Region: California
Posts: 135
radio randomly stopped working it seems to be wireing any help

I checked all fuses and it all checks Out I have power from the 12+ ignition wire but the 12+ battery wire seems to be shorted. its the green and yellow that turns to the yellow that has no power up to the radio harness side I have an 88 mustang gt thanks if you can point me where I should check from here it would be appreciated.
The420fox is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-04-2013, 07:48 AM   #2
Registered Member
Regular
 
86 muscle's Avatar
 
Join Date: Oct 2011
Region: Texas
Posts: 264
Did you check your ground?
86 muscle is offline   Reply With Quote
Old 06-04-2013, 10:36 AM   #3
Registered Member
Regular
 
The420fox's Avatar
 
Join Date: Jan 2013
Location: 707
Region: California
Posts: 135
Thanks ill double check make sure the ground is secure I believe it was tho.
The420fox is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-04-2013, 10:46 AM   #4
Registered Member
Regular
 
86 muscle's Avatar
 
Join Date: Oct 2011
Region: Texas
Posts: 264
Is it the stock head unit?
86 muscle is offline   Reply With Quote
Old 06-04-2013, 11:49 AM   #5
Registered Member
Regular
 
The420fox's Avatar
 
Join Date: Jan 2013
Location: 707
Region: California
Posts: 135
No I installed sterio , speakers and subs. I'm thinking I figured it out its working again I thought I checked all the fuses but I apperently skipped the one that was blown smh lol rookie move well good I double checked my fuses after noticing my overhead lamp was not working or power mirror figured I had to Have overlooked a fuse thanks
The420fox is offline   Reply With Quote
Old 06-04-2013, 11:56 AM   #6
Registered Member
Regular
 
DustyStang306's Avatar
 
Join Date: Feb 2013
Location: Belleville On
Region: Canada
Posts: 342
Quote:
Originally Posted by The420fox
No I installed sterio , speakers and subs. I'm thinking I figured it out its working again I thought I checked all the fuses but I apperently skipped the one that was blown smh lol rookie move well good I double checked my fuses after noticing my overhead lamp was not working or power mirror figured I had to Have overlooked a fuse thanks
420fox your fox looks sick man love the Black on black with the red calipers looks nice and seen your motor looks really clean to man
DustyStang306 is offline   Reply With Quote
Old 06-04-2013, 12:09 PM   #7
Registered Member
Regular
 
The420fox's Avatar
 
Join Date: Jan 2013
Location: 707
Region: California
Posts: 135
Thanks dustystang306 yea I love this car I'm waiting for a new pair of summer tires in the mail and I'm going back to driving this everyday even tho it gets hella hot stopped in town no AC all black lol it cools once I'm moving fast
The420fox is offline   Reply With Quote
Old 06-04-2013, 01:11 PM   #8
Registered Member
Regular
 
86 muscle's Avatar
 
Join Date: Oct 2011
Region: Texas
Posts: 264
Glad you got her going!
86 muscle is offline   Reply With Quote
Old 06-04-2013, 01:27 PM   #9
Registered Member
Regular
 
The420fox's Avatar
 
Join Date: Jan 2013
Location: 707
Region: California
Posts: 135
Yea if UPS trains did not get derailed then it might have been here all ready well see how long its delayed
The420fox is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:56 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.