Blinkers stopped working?! - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-03-2013, 07:17 PM   #1
Moderator Emeritus
 
Adogg's Avatar
 
Join Date: Nov 2011
Region: Massachusetts
Posts: 1,499
Blinkers stopped working?!

So my blinkers stopped working today so when I turn them on left or right the little green arrow doesn't come up at all. What do you guys think is the problem?
__________________
Don't hate....... appreciate
Adogg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-03-2013, 10:04 PM   #2
Registered Member
Regular
 
mustangmania91's Avatar
 
Join Date: Dec 2012
Location: mayslick
Region: Kentucky
Posts: 143
I had the same issues. more than likely its your relay. However, if the relay has been changed it can also be your turn signal/multi switch. I actually changed both and mine works fine now
mustangmania91 is offline   Reply With Quote
Old 06-04-2013, 10:47 AM   #3
Moderator Emeritus
 
Adogg's Avatar
 
Join Date: Nov 2011
Region: Massachusetts
Posts: 1,499
Quote:
Originally Posted by mustangmania91 View Post
I had the same issues. more than likely its your relay. However, if the relay has been changed it can also be your turn signal/multi switch. I actually changed both and mine works fine now
Thanks man. Where are these two switches located and can I buy them at a regular parts store? How much where they?
__________________
Don't hate....... appreciate
Adogg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-04-2013, 07:28 PM   #4
Registered Member
Regular
 
mustangmania91's Avatar
 
Join Date: Dec 2012
Location: mayslick
Region: Kentucky
Posts: 143
The relay u can buy at most auto stores like autozone,advanced auto or o'reilleys. The multi switch u cant. Buy it feom cjponyparts.com or latemodelrestoration.com. the multi switch is fsirly expensive, however I purchased mine from ebay and it was new for roughly $40. Just be sure it has the wiper washer on it as well
mustangmania91 is offline   Reply With Quote
Old 06-05-2013, 08:37 AM   #5
Registered Member
Regular
 
mustangmania91's Avatar
 
Join Date: Dec 2012
Location: mayslick
Region: Kentucky
Posts: 143
Also, the multi switch sells between $40-$150. The higher is OEM and/or original replacement. Check ebay first, just be sure u order it new and again with the window washer included
mustangmania91 is offline   Reply With Quote
Old 06-05-2013, 01:43 PM   #6
Registered Member
Regular
 
alexak187's Avatar
 
Join Date: Dec 2010
Region: Arkansas
Posts: 67
I just fixed mine yesterday, after checkin every wire and nearly taking the dash out completely, it turned out to be a wire came loose behind the multi switch. I might check that.
alexak187 is offline   Reply With Quote
Old 06-05-2013, 02:48 PM   #7
Moderator Emeritus
 
Adogg's Avatar
 
Join Date: Nov 2011
Region: Massachusetts
Posts: 1,499
Unplugged the relay and the fuse put it back together and so far I have had now problems must have been a bad connection some where I feel like the problem may resurface
__________________
Don't hate....... appreciate
Adogg is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:44 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.