motor fire - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-02-2013, 10:37 PM   #1
Registered User
Newbie
 
lancer070187's Avatar
 
Join Date: Mar 2013
Location: Wichita
Region: Kansas
Posts: 17
motor fire

i thought i had just finished my 89 5.0 rebuild i took the car for a spin round the block it was running kind of rough. i parked it in drive way after running to the store i came back and tried to pull the car up on to a set of ramps it stalled on me. when i went to start it again it cough fire. now i need to know where to find the main wiring bundle for a 89 5.0 mustang and some other parts but i am not sure of the full extent of the damage yet i had to walk away before i got too upset. can any one help me find this wiring or even what it is called?



lancer070187 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-02-2013, 10:39 PM   #2
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
http://030e83b.netsolstores.com/1991...aspx]1991-1993 Engine Wiring Harness

If you have MAF
Billymich is offline   Reply With Quote
Old 08-02-2013, 10:46 PM   #3
Registered User
Newbie
 
lancer070187's Avatar
 
Join Date: Mar 2013
Location: Wichita
Region: Kansas
Posts: 17
I'm not sure if i have MAF or not
lancer070187 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-02-2013, 10:50 PM   #4
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
Do you have any engine mods done? If so, you are probably MAF

---------- Post added at 10:48 PM ---------- Previous post was at 10:48 PM ----------

Take some engine bay pics and I can tell you

---------- Post added at 10:50 PM ---------- Previous post was at 10:48 PM ----------

just search engine harness at that site for the wire harness. I think its like $150. Craigslist is another option. Sorry that happened. It sucks
Billymich is offline   Reply With Quote
Old 08-02-2013, 10:54 PM   #5
Registered User
Newbie
 
lancer070187's Avatar
 
Join Date: Mar 2013
Location: Wichita
Region: Kansas
Posts: 17
just got done rebuilding the engine but i have not done anything electrical yet. i put in a new cam bored the pistons .030 over up graded the rocker arms to 7:1 and put on a cobra upper and lower intake. that is all i have done to the motor. i will take some better picks and get back to you.
lancer070187 is offline   Reply With Quote
Old 08-02-2013, 10:56 PM   #6
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
1.72 rockers not 1:7 and yeah you most likely aren't speed density anymore
Billymich is offline   Reply With Quote
Old 08-02-2013, 11:07 PM   #7
Registered User
Newbie
 
lancer070187's Avatar
 
Join Date: Mar 2013
Location: Wichita
Region: Kansas
Posts: 17
speed density? I'm not sure what your referring to i am very new at this and the guy that was helping me through this bailed on me half way into the project.



lancer070187 is offline   Reply With Quote
Old 08-02-2013, 11:08 PM   #8
Road Trip!
 
Join Date: Aug 2013
Location: Over there
Region: Arizona
Posts: 32
Quote:
Originally Posted by lancer070187 View Post
speed density? I'm not sure what your referring to i am very new at this and the guy that was helping me through this bailed on me half way into the project.
If its an 89 it was never speed density. Speed density was 86-88.
87fiveoh is offline   Reply With Quote
Old 08-02-2013, 11:10 PM   #9
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
Lol I thought he said 88 sorry
Billymich is offline   Reply With Quote
Old 08-02-2013, 11:11 PM   #10
Registered User
Newbie
 
lancer070187's Avatar
 
Join Date: Mar 2013
Location: Wichita
Region: Kansas
Posts: 17
Ya thank you for your help i feel like a complete moron
lancer070187 is offline   Reply With Quote
Old 08-02-2013, 11:11 PM   #11
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
The link I posted, go there, the engine harness should work ok. **** don't worry, we all started somewhere. A year ago, I didn't even know what a transmission looked like, or a clutch or the inside of an engine. No worries that's why we're here
Billymich is offline   Reply With Quote
Old 08-02-2013, 11:18 PM   #12
Registered User
Newbie
 
lancer070187's Avatar
 
Join Date: Mar 2013
Location: Wichita
Region: Kansas
Posts: 17
ya it is a 89 but it has real sentimental value to me it was the car my dad taught me to drive stick in.

---------- Post added at 11:18 PM ---------- Previous post was at 11:14 PM ----------

ok i will give it a shot i have a lot more work ahead of me to make it a fast car i know but you must crawl before you can walk and walk before you can run right.
lancer070187 is offline   Reply With Quote
Old 08-02-2013, 11:20 PM   #13
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
Nah I like to run first and then give up because I scrapped my knee
Billymich is offline   Reply With Quote
Old 08-02-2013, 11:30 PM   #14
Registered User
Newbie
 
lancer070187's Avatar
 
Join Date: Mar 2013
Location: Wichita
Region: Kansas
Posts: 17
ya that seams to be the way i have been doing things this hole project. my first blunder was not the fire. it was letting a local engine shop have a crack at re assembling my motor. i got it back the first time and it was timed wrong. it was 140 deg. off they timed it as if it were a Chevy. then after they fixed that i put the motor back in the car and managed to blow a oil filter clean off the motor. the oil pump check valve was faulty. and now we have fire.
lancer070187 is offline   Reply With Quote
Old 08-02-2013, 11:32 PM   #15
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
Yeah, that's just not acceptable. I have broken many a part learning/fixing things on my car. Usually I go to fix one thing and break 2-3 others lol
Billymich is offline   Reply With Quote
Old 08-02-2013, 11:39 PM   #16
Road Trip!
 
Join Date: Aug 2013
Location: Over there
Region: Arizona
Posts: 32
Did you determine the cause of the fire? Electrical or fuel related?
87fiveoh is offline   Reply With Quote
Old 08-02-2013, 11:44 PM   #17
Registered User
Newbie
 
lancer070187's Avatar
 
Join Date: Mar 2013
Location: Wichita
Region: Kansas
Posts: 17
ya i am getting good at that but i did manage to do a ring and pinion swap with very little problems i am kinda proud of that. but then again i haven't had much of a chance to drive the car to make sure it dose not break. i will say it dose not whine at 40 mph like it did before.

---------- Post added at 11:44 PM ---------- Previous post was at 11:43 PM ----------

i am 90% sure it was fuel related it did not smell like a electrical fire.
lancer070187 is offline   Reply With Quote
Old 08-03-2013, 12:09 AM   #18
Registered Member
Regular
 
Billymich's Avatar
 
Join Date: Oct 2012
Location: Chicago
Region: Illinois
Posts: 861
Quote:
Originally Posted by lancer070187 View Post
ya i am getting good at that but i did manage to do a ring and pinion swap with very little problems i am kinda proud of that. but then again i haven't had much of a chance to drive the car to make sure it dose not break. i will say it dose not whine at 40 mph like it did before.

---------- Post added at 11:44 PM ---------- Previous post was at 11:43 PM ----------

i am 90% sure it was fuel related it did not smell like a electrical fire.
Could have been a leaky injector or O-ring possibly a backfire through the intake??
Billymich is offline   Reply With Quote
Old 08-03-2013, 12:39 AM   #19
Registered User
Newbie
 
lancer070187's Avatar
 
Join Date: Mar 2013
Location: Wichita
Region: Kansas
Posts: 17
ya i am hoping that is all it was and nothing more serious
lancer070187 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:54 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.