Help:Running Hot & Check Engine Light - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-11-2013, 07:32 AM   #1
Registered Member
Regular
 
Hellish Horse's Avatar
 
Join Date: Apr 2012
Region: Arizona
Posts: 796
Help:Running Hot & Check Engine Light

Hi All & Thank You in advance for any suggestions you might have.
I have a 94 GT w/ a 5.0. Car has almost 168K on it. I'm having trouble trying to figure out why my Temp Guage goes up a little past 3/4 of the way & my check engine light comes on intermittently. I thought I had a Cooling issue so I put in all Brand New Parts...All Aluminum 3 core radiator, Water Pump, T-Stat, Radiator & Heater Hoses. Did Not Help! My Oil & Coolant look normal...No milky residue. No bubbles in the Radiator. Plugs all look fine. No Sweet odor & No Leaks anywhere. I live in AZ. so it gets pretty hot in the afternoon (usually 100-110) & that's when my Temp & check engine problems happen. Car runs like a Champ in the mornings when it's cool outside. Once it gets up around 105 my Temp guage goes up to 3/4 or more, the car starts running rough & the check engine light will go on & off intermittently but wont stay lit. I'm not even sure the Check Engine light is caused by the same problem.
Any ideas Anyone??? I'm lost on this & have no idea what to try next. Is it possible the Stock Fan isn't doing the Trick? I put the same kind of radiator in my 04 V6 3.8 w/ the stock fan & had no issues at all. Could there be like a bad/faulty Temp Sensor somewhere? Thanks Again for any input.
Hellish Horse
Hellish Horse is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-11-2013, 11:22 AM   #2
Registered Member
Regular
 
nickcap's Avatar
 
Join Date: May 2011
Posts: 245
Any low coolant light? Maybe fan isn't turning on... Open your hood and turn your car on and stand by it you will see the fan turn on and feel the radiator hose to make sure there is coolant running through the hoses and I would definitely check your temp sensor for that can throw a code to your CPU and your car can be running sluggish start with the basics because you already put all new parts in.
__________________
1995 Mustang GT Convertible!! (My Baby Monique) Ha
nickcap is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Tags
check engine

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



02:10 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.