347 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-25-2013, 06:41 PM   #1
Registered User
Newbie
 
88droptop's Avatar
 
Join Date: Sep 2013
Location: St. Louis MO
Region: Missouri
Posts: 7
347

Just dropped a 347 in my 5.0 and i just hit 500 miles and it started smoking through the breather untop of my valve covers... Is that notmal... Ive heard it is and ive heard it aint...
88droptop is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-25-2013, 08:24 PM   #2
Registered Member
Regular
 
Kevo91's Avatar
 
Join Date: Apr 2013
Location: Magna
Region: Utah
Posts: 298
They always smoke a little on the first startup but that doesnt sound normal. Did you run it for 20 mins at 2k rpms on startup? And did you go out and seat the rings?
Kevo91 is offline   Reply With Quote
Old 09-25-2013, 09:24 PM   #3
Registered User
Newbie
 
88droptop's Avatar
 
Join Date: Sep 2013
Location: St. Louis MO
Region: Missouri
Posts: 7
I had Huber Performance put my engine in... He did the proper break in... He told me out 500 miles on the engine and i did... The smoke out if the breather just started Saturday....
88droptop is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-25-2013, 10:52 PM   #4
Registered Member
Regular
 
jduckz5.0's Avatar
 
Join Date: Apr 2013
Location: pittsburgh
Region: Pennsylvania
Posts: 310
Did you change oil after break in???
jduckz5.0 is offline   Reply With Quote
Old 09-25-2013, 11:16 PM   #5
Registered Member
Regular
 
Kevo91's Avatar
 
Join Date: Apr 2013
Location: Magna
Region: Utah
Posts: 298
Was it blue-ish smoke by chance?
Kevo91 is offline   Reply With Quote
Old 09-26-2013, 01:08 AM   #6
Registered User
Newbie
 
88droptop's Avatar
 
Join Date: Sep 2013
Location: St. Louis MO
Region: Missouri
Posts: 7
Just changed the oil ... Smoke is a clear white... Just coming out the breather... Oil pressure is perfect no over heating... Someone said its just the car breathing and cooling down...
88droptop is offline   Reply With Quote
Old 09-26-2013, 09:47 AM   #7
Registered Member
Regular
 
jduckz5.0's Avatar
 
Join Date: Apr 2013
Location: pittsburgh
Region: Pennsylvania
Posts: 310
I wouldn't be too worried but don't beat on it yet....keep an eye on it...
jduckz5.0 is offline   Reply With Quote
Old 09-26-2013, 10:55 AM   #8
Registered User
Newbie
 
88droptop's Avatar
 
Join Date: Sep 2013
Location: St. Louis MO
Region: Missouri
Posts: 7
I figured it wasnt to big of a deal... Everything has been done right to the engine... I thank its blow black... No pinging or ticking.... Mayb im just being parranoid....
88droptop is offline   Reply With Quote
Old 09-26-2013, 11:05 AM   #9
Registered Member
Regular
 
3stangs's Avatar
 
Join Date: Mar 2013
Location: Beloit
Region: Wisconsin
Posts: 69
Friend of mine has a 351 that's built and his does the same thing. No problems on his.
3stangs is offline   Reply With Quote
Old 09-26-2013, 11:07 AM   #10
Registered Member
Regular
 
jduckz5.0's Avatar
 
Join Date: Apr 2013
Location: pittsburgh
Region: Pennsylvania
Posts: 310
Yeah if its white smoke then its probably just steam...
jduckz5.0 is offline   Reply With Quote
Old 09-26-2013, 11:10 AM   #11
Registered User
Newbie
 
88droptop's Avatar
 
Join Date: Sep 2013
Location: St. Louis MO
Region: Missouri
Posts: 7
Thanks for the info... I just dont have another 4 grand for another engine... Just being cautious... I appreciate all your comments... Im new to the Mustang world and learning
88droptop is offline   Reply With Quote
Old 09-26-2013, 12:01 PM   #12
Staff
Regular
Staff
 
scottydsntknow's Avatar
 
Join Date: Apr 2013
Location: JB MDL
Region: New Jersey
Posts: 16,579
It might still be burnoff. Keep an eye on it and I'd change your oil 2 or 3 more times before you hit 2k miles. Dino oil for break in, dino oil till 1k, cheap synthetic till 1500 and then whatever you are going to use at 2k and then go to normal intervals. I'm kind of OCD about getting all the assembly lube, any little metal bits or any crap that got in there during assembly which should be minimal but still.
__________________
2000 Mustang GT Steeda #0048

Just because I give you advice, doesn't mean I know more than you. Its just means I've done more stupid ****.
scottydsntknow is online now   Reply With Quote
Old 09-26-2013, 12:10 PM   #13
Registered User
Newbie
 
88droptop's Avatar
 
Join Date: Sep 2013
Location: St. Louis MO
Region: Missouri
Posts: 7
I just changed it at 500 miles ... Thats what i was told by Huber Performance.... Used 10w 30 synthetic with a Bosch oil filter... Gonna run Royal Purple through at 2k.... The car is running great with no other problems.... Running nice and cool oil guage is right in the middle.... Hopefully just blow back through the breather...
88droptop is offline   Reply With Quote
Old 09-26-2013, 12:16 PM   #14
Staff
Regular
Staff
 
scottydsntknow's Avatar
 
Join Date: Apr 2013
Location: JB MDL
Region: New Jersey
Posts: 16,579
Yeah if you get rid of the PCV then the whole point of the breather is to... well... breathe...

And when you are saying the oil gauge is right in the middle and running cool... you are talking about on aftermarket gauges right? The stock oil gauge is simply an on/off switch that is set to 6 psi and the stock water gauge just gets you a ballpark reading. With an aftermarket 347 a good set of autometer/speedhut gauges are mandatory.

If you already have them then I apologize lol.
__________________
2000 Mustang GT Steeda #0048

Just because I give you advice, doesn't mean I know more than you. Its just means I've done more stupid ****.
scottydsntknow is online now   Reply With Quote
Old 09-26-2013, 12:26 PM   #15
Registered User
Newbie
 
88droptop's Avatar
 
Join Date: Sep 2013
Location: St. Louis MO
Region: Missouri
Posts: 7
Havnt upgraded the gauges yet that will be next on my list... Took it to Mustang Muscle they checked to make sure it wasnt getting hot .... Out a black magic fan on the radiator so i know its not getting hot.... I check the oil before i drive it every time stick always says full....
88droptop is offline   Reply With Quote
Old 09-26-2013, 12:27 PM   #16
Staff
Regular
Staff
 
scottydsntknow's Avatar
 
Join Date: Apr 2013
Location: JB MDL
Region: New Jersey
Posts: 16,579
Yeah but it can be full and the pump could go out or the shaft could shear off. Running at a low psi because of a shot pump for a long time could really damage stuff and the stock gauge will not tell you that at all. If you lose all pressure it'll go to 0 so its good for that at least.
__________________
2000 Mustang GT Steeda #0048

Just because I give you advice, doesn't mean I know more than you. Its just means I've done more stupid ****.
scottydsntknow is online now   Reply With Quote
Old 09-26-2013, 12:28 PM   #17
Registered User
Newbie
 
88droptop's Avatar
 
Join Date: Sep 2013
Location: St. Louis MO
Region: Missouri
Posts: 7
I havnt upgraded my gauges yet... I installed a black magic fan on the radiator and had Mustang Muscle check to make sure the car is nit getting hot... I check the oil before i drive it everytime and its always on full....
88droptop is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



01:25 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.