P/A 3g alternator upgrade - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-10-2013, 12:37 AM   #1
Registered User
Newbie
 
Join Date: Oct 2013
Location: San antonio
Region: Texas
Posts: 6
P/A 3g alternator upgrade

Just completed alternator upgrade in my 88gt, now I have an annoying chirp coming from either the alternator pulley or the tension pulley. Belt size is 90.8inches for A/C, power steering, and smog delete pulley. I've replaced the power steering pump as well. Any idea what would cause this , the tension pulley, alternator pulley, smog delete pulley are all new as is the serpentine belt. The " chirp" goes away once the engine warms up but that still takes about 10 minutes before the chirp stops. Any help or suggestions would be appreciated thanks!
Jriver34 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-10-2013, 02:26 AM   #2
Registered Member
Regular
 
Jzelm10's Avatar
 
Join Date: Feb 2012
Region: Alabama
Posts: 89
Mine does this also.. it's so annoying! If you spray the belt with lube it stops but its back like 2 days later
Jzelm10 is offline   Reply With Quote
Old 10-10-2013, 10:09 AM   #3
Registered Member
Regular
 
jduckz5.0's Avatar
 
Join Date: Apr 2013
Location: pittsburgh
Region: Pennsylvania
Posts: 310
Probably just got some grease or dirt on belt...exchange it and go from there...
jduckz5.0 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-11-2013, 12:56 AM   #4
Registered User
Newbie
 
Join Date: Oct 2013
Location: San antonio
Region: Texas
Posts: 6
Quote:
Originally Posted by jduckz5.0 View Post
Probably just got some grease or dirt on belt...exchange it and go from there...
Thanks I think cleaning the grooved surface of the pulleys really made a difference I noticed the felt from the belt was rubbing off and collecting in the grooved areas hopefully that will correct that chirp thanks.
Jriver34 is offline   Reply With Quote
Old 10-11-2013, 07:31 AM   #5
Registered Member
Regular
 
jduckz5.0's Avatar
 
Join Date: Apr 2013
Location: pittsburgh
Region: Pennsylvania
Posts: 310
Good luck..I used to use brake parts cleaner on the pulleys...and I used dawn to wash belt and let it dry before I put it back on...I spend a lot of money at AutoZone so they exchange or replace it for free..haha
jduckz5.0 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:45 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.