ground strap placement - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-13-2013, 05:31 PM   #1
Registered Member
Regular
 
3stangs's Avatar
 
Join Date: Mar 2013
Location: Beloit
Region: Wisconsin
Posts: 69
ground strap placement

Well after a week of intermittent not starting I've zeroed in on one problem. My ground strap from the motor mount to the chassis is broke. So I got some new strap from work to replace it. Problem is I can't the nut off the motor mount. Can I just move it from the mount to the one on the timing cover? Also I'll be moving the other end closer, any clean spot on the chassis will work correct?
3stangs is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-14-2013, 08:27 AM   #2
Staff
Regular
Staff
 
scottydsntknow's Avatar
 
Join Date: Apr 2013
Location: JB MDL
Region: New Jersey
Posts: 16,576
That nut should come off but yeah any point should work. I also would not use another replacement strap, I used 0 gauge battery cable when I re-did mine and I added one to the passenger side too.
__________________
2000 Mustang GT Steeda #0048

Just because I give you advice, doesn't mean I know more than you. Its just means I've done more stupid ****.
scottydsntknow is offline   Reply With Quote
Old 11-14-2013, 08:33 AM   #3
Registered Member
Regular
 
3stangs's Avatar
 
Join Date: Mar 2013
Location: Beloit
Region: Wisconsin
Posts: 69
Oh it'll come off with the right tools and effort. Which I don't have at home and it's cold and windy so I don't like being out on the ground. Lol. I decided on the strap just to get it done. After reading a bunch of threads from sites I'll be replacing and adding some better grounds
3stangs is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-14-2013, 01:47 PM   #4
Registered Member
Regular
 
3stangs's Avatar
 
Join Date: Mar 2013
Location: Beloit
Region: Wisconsin
Posts: 69
Got the new ground put on. Now the other culprit, which I suspected from the start also, is the ccrm. When I try to turn it over I can hear the ccrm just buzzing /clicking, and the fan immediately turns on. Is that indicative of it failing? I've thought that was going out also cause sometimes the fan wouldn't turn off after the car was off unless I tapped it.
3stangs is offline   Reply With Quote
Old 11-14-2013, 02:41 PM   #5
Registered Member
Regular
 
3stangs's Avatar
 
Join Date: Mar 2013
Location: Beloit
Region: Wisconsin
Posts: 69
Btw it's a 94 gt. Aode trans
3stangs is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:09 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.