Fuel Pump? - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-17-2013, 10:00 AM   #1
Registered User
Newbie
 
Join Date: Dec 2013
Posts: 1
Fuel Pump?

91 notch won't start, battery has more than enough amps to start and the alternator is new so the only other thing I can think of is the fuel pump. Any thoughts?
91NotchPhil is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-17-2013, 10:22 AM   #2
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Car needs 3 things to run. Air, spark, fuel. Have to checked for power at the plugs? Fuel at the rail?
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Old 12-17-2013, 02:42 PM   #3
Registered Member
Regular
 
Roguestang's Avatar
 
Join Date: Nov 2011
Location: Tampa
Region: Florida
Posts: 1,516
Quote:
Originally Posted by lowflyn View Post
Car needs 3 things to run. Air, spark, fuel. Have to checked for power at the plugs? Fuel at the rail?
+ infinity
__________________
2000 Mustang GT-Former giggle gas addict
1990 Mustang GT w/ Vortech V3

***resident gun idiot***
Roguestang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-18-2013, 11:26 AM   #4
Registered Member
Regular
 
Foxbody91's Avatar
 
Join Date: Dec 2013
Location: Warner Robins
Region: Georgia
Posts: 285
Does it start then cut off? Not turning over? Any particular sounds??
Foxbody91 is offline   Reply With Quote
Old 12-18-2013, 07:53 PM   #5
Registered Member
Regular
 
5.oh's Avatar
 
Join Date: May 2013
Location: Saint louis
Region: Missouri
Posts: 261
Do a couple shots in the throttle body with starting fluid. If it fires up and dyes it's your fuel pump. Take two plugs next to each other off the distributor and turn it over see if it's atleast getting spark.

---------- Post added at 08:53 PM ---------- Previous post was at 08:51 PM ----------

Btw for the spark thing it'll when you turn it over have someone else looking and see if there's any electric arking.
5.oh is offline   Reply With Quote
Old 12-27-2013, 06:48 AM   #6
Registered User
Newbie
 
Mike93coupe's Avatar
 
Join Date: Dec 2013
Posts: 10
Had same problem with my 93 coupe. I replaced the TFI module and the coil..
Mike93coupe is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:25 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.