Wipers/Turn signals not working. - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Join Mustang Evolution Today

Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-11-2014, 07:40 PM   #1
Registered User
Bford024's Avatar
Join Date: Aug 2012
Location: Colorado Springs, Co
Region: Colorado
Posts: 17
Wipers/Turn signals not working.

I have an 88 gt and my turn signals wont work along with my wiper blades. The headlights work, the brights work only when turned on, when i wanna "flash" the headlights the lights go off. Also when i use the turn signals the hazards flash. Ive replaced the hazard/defrost switch along with new connectors, ive replace the multifunction switch for the wipers, signals and get the same problem.

Bford024 is offline   Reply With Quote
Old 03-12-2014, 01:18 PM   #2
Registered Member
Foxbody91's Avatar
Join Date: Dec 2013
Location: Warner Robins
Region: Georgia
Posts: 258
Checked ur fuses?

Foxbody91 is offline   Reply With Quote
Old 03-12-2014, 04:19 PM   #3
Registered Member
slade95gt's Avatar
Join Date: Mar 2014
Posts: 169
U have a short somewhere or something is grounding out...... Check all your grounds
slade95gt is offline   Reply With Quote

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
92 GT Climate control not working Fymihwd 1979-1995 Mustang GT 0 02-14-2014 03:44 PM
Turn signals and breaklights not working Genocide 99gt 1996-2004 Mustang GT 10 01-30-2012 01:18 AM
dash lights and turn signals 88foxstang 1979-1995 Mustang GT 9 09-16-2011 07:18 PM
Head unit not working..... mcvicar04 1996-2004 Mustang GT 20 07-29-2011 09:08 AM
A\C working then not working Bohogin Pre-2005 V6 Mustang 3 07-14-2011 01:44 PM

» Like Us On Facebook

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

05:31 PM

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.