88 GT gas gauge and speedo/odometer not working. - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-24-2014, 12:08 AM   #1
Registered Member
Regular
 
UDLOOZ's Avatar
 
Join Date: Mar 2014
Location: Enfield
Region: Connecticut
Posts: 35
88 GT gas gauge and speedo/odometer not working.

I recently purchased this car and needs these issues resolved....

I recently dropped the gas tank and installed a new fuel sending unit but, that didn't fix it. Needle didn't even change location. Stuck on 3/4 of a tank. What should I do next?


Also the speedo/odometer aren't working where do I start? Easiest to hardest
UDLOOZ is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-24-2014, 08:48 PM   #2
Registered Member
Regular
 
slade95gt's Avatar
 
Join Date: Mar 2014
Posts: 169
Get u some aftermarket gauges and test them out before install if your wiring is right it could very well be bad gauges this is assuming u have checked fuses first
slade95gt is offline   Reply With Quote
Old 03-24-2014, 09:25 PM   #3
Registered Member
Regular
 
Join Date: Feb 2014
Location: 00
Region: Other
Posts: 1,198
Quote:
Originally Posted by UDLOOZ View Post
I recently purchased this car and needs these issues resolved....

I recently dropped the gas tank and installed a new fuel sending unit but, that didn't fix it. Needle didn't even change location. Stuck on 3/4 of a tank. What should I do next?


Also the speedo/odometer aren't working where do I start? Easiest to hardest
There is a chip on the circuit board behind the cluster that needs replacing. I can't remember exactly what its called. A guy I know had this same problem with his 88lx 5.0. It's a common issue with the 87-88s. They aren't the easiest to find, but a 89gt/5.0lx cluster would be a good upgrade. The later 89s have the 140speedo for the tilt wheel cluster. Sounds like your speedometer cable broke. It's an easy cheap fix.
Bigshow14 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-24-2014, 10:17 PM   #4
Registered Member
Regular
 
UDLOOZ's Avatar
 
Join Date: Mar 2014
Location: Enfield
Region: Connecticut
Posts: 35
I took apart the instrument panel with aftermarket (white gauges) and the whole circuit board was all torn especially where the wiring harness connects to the rear of the cluster on the gas gauge side...so I am in search of a new cluster I prefer black gauges. Anybody have a 140mph cluster they are looking to sell?

Yes the speedo cable literally had a 90 degree bend in it and was partially burnt/shredded. Easy enough to take out and ordered the whole new setup.
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	66
Size:	1.09 MB
ID:	151801  
UDLOOZ is offline   Reply With Quote
Old 03-24-2014, 10:27 PM   #5
Registered Member
Regular
 
Join Date: Feb 2014
Location: 00
Region: Other
Posts: 1,198
Do you have the mass air set up on your car
Bigshow14 is offline   Reply With Quote
Old 03-24-2014, 10:30 PM   #6
Registered Member
Regular
 
UDLOOZ's Avatar
 
Join Date: Mar 2014
Location: Enfield
Region: Connecticut
Posts: 35
Yes I do, BBK 75mm. Why you ask?
UDLOOZ is offline   Reply With Quote
Old 03-24-2014, 10:36 PM   #7
Registered Member
Regular
 
UDLOOZ's Avatar
 
Join Date: Mar 2014
Location: Enfield
Region: Connecticut
Posts: 35
If you check out my garage I have everything that is on the car listed there.
UDLOOZ is offline   Reply With Quote
Old 03-24-2014, 10:37 PM   #8
Registered Member
Regular
 
Join Date: Feb 2014
Location: 00
Region: Other
Posts: 1,198
Just curious, while you are looking for an 89 cluster, the 89 mass air set up is a nice cheap upgrade for your car.
Bigshow14 is offline   Reply With Quote
Old 03-24-2014, 10:41 PM   #9
Registered Member
Regular
 
Join Date: Feb 2014
Location: 00
Region: Other
Posts: 1,198
Quote:
Originally Posted by UDLOOZ View Post
If you check out my garage I have everything that is on the car listed there.
Just checked it out, you have a clean car nice set up. I had an 88gt vert white 5spd
Bigshow14 is offline   Reply With Quote
Old 03-24-2014, 10:44 PM   #10
Registered Member
Regular
 
UDLOOZ's Avatar
 
Join Date: Mar 2014
Location: Enfield
Region: Connecticut
Posts: 35
Quote:
Originally Posted by Bigshow14 View Post
Just curious, while you are looking for an 89 cluster, the 89 mass air set up is a nice cheap upgrade for your car.
The only thing I am thinking of doing is looking for new heads, upper and lower control arms and sub-frame connectors. Other than that the car is sitting pretty good as it is.
UDLOOZ is offline   Reply With Quote
Old 03-24-2014, 10:53 PM   #11
Registered Member
Regular
 
UDLOOZ's Avatar
 
Join Date: Mar 2014
Location: Enfield
Region: Connecticut
Posts: 35
Quote:
Originally Posted by Bigshow14 View Post
Just checked it out, you have a clean car nice set up. I had an 88gt vert white 5spd
Thanks. I literally stole this car for $4500. Right place right time. Just wish it was an LX but it is still a nice Florida car with zero rust anywhere.
UDLOOZ is offline   Reply With Quote
Old 03-25-2014, 07:57 AM   #12
Registered User
Newbie
 
UA10GT's Avatar
 
Join Date: Dec 2013
Location: Cincinnati
Region: Ohio
Posts: 8
I like the lx much better as well but sounds like you got a great deal on it
UA10GT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odometer and Trip not working! Please help! prittiecute 1996-2004 Mustang GT 11 02-21-2013 07:18 AM
speedometer and gas gauge not working?? rob913 1979-1995 Mustang GT 0 07-03-2010 09:00 AM
odometer and Trip not working Tim Knox 1996-2004 Mustang GT 2 07-19-2008 01:12 AM
odometer not working 98mustang2007 1996-2004 Mustang GT 4 03-20-2008 11:25 AM
Speedo works, Odometer does not.. floridamba Pre-2005 V6 Mustang 9 04-24-2007 04:02 AM

» Like Us On Facebook



12:29 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.