What could be wrong - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-18-2014, 10:56 PM   #1
Registered Member
Regular
 
busaboy's Avatar
 
Join Date: May 2013
Location: Victory Mills
Region: New York
Posts: 97
What could be wrong

Ok guys let's see who can solve this mystery...
Finally got my 91 mustang gt running and on the road, sounded great ran great until ran for over an hour or so, started skipping losing power and making a strange noise from valve cover and loading up with fuel, wouldn't run with fuel pump on.
Got it home took valve covers off and had a couple loose rockers but they were non adjustable talked to a buddy of mine and he said they were the wrong heads and that I needed roller rockers, and gave me a set of Windsor jr heads.
I got them all hooked up new gaskets and adjusted the valves. Only thing other than heads that are different is the upper intake put the one that came on it back on, got it all done fired it up and it runs like a bag of crap like the firing is messed up backfiring, and almost like it's not running on all cylinders????
I have changed the plug wires thinking they were bad and reset the the tdc and distributer definitely not 180 out and still using the same Windsor firing order my fuel pressure is 39psi.
I'm lost right now not sure what to do or what is wrong. Is there any way the intake could cause this? I ask because this is how it ran when I got it but have since rebuilt it and it ran great with the other intake I just don't see what could be wrong with it to cause it
Any info advice or knowledge would be greatly appreciated thanks
busaboy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-19-2014, 09:15 PM   #2
Registered Member
Regular
 
busaboy's Avatar
 
Join Date: May 2013
Location: Victory Mills
Region: New York
Posts: 97
No ideas??????
busaboy is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I was wrong - Really Wrong- Yep I was ronnie948 AmericanMuscle 4 03-09-2013 03:51 PM
Crazy Vid, wrong place wrong time Black95GT The Bar 19 06-26-2004 04:38 PM
wrong speedo! widowvirgin Pre-2005 V6 Mustang 13 04-02-2004 03:46 PM
Wrong on so many levels Monkey The Bar 5 08-05-2003 04:04 PM
DYNO GONE WRONG!!!! KrazyPony The Bar 6 07-23-2003 02:15 PM

» Like Us On Facebook



04:15 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.