electrical TROLLS - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-16-2014, 07:27 PM   #1
Registered User
Newbie
 
Join Date: Jul 2014
Location: west palm beach
Region: Florida
Posts: 1
electrical TROLLS

Hey guys im having a big electrical problem. Slowly my electronics started failing. First my tachometer doesnt light at night. As in when i switch in the lights, my tach doesnt light up, nor my idle brake lights. But highbeam indicator lights up. Then my directional lights and braking lights stopped working. So now no function in rear lights. But my headlights still work. Then i checked fuses the ones i managed to pull out by hand were ok, but then i started driving and it started smoking under my dash whenever i drive it smells like burnt plastic. Help me please?
El Peludo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-16-2014, 09:02 PM   #2
Registered Member
Regular
 
Hellish Horse's Avatar
 
Join Date: Apr 2012
Region: Arizona
Posts: 796
Sounds like you have a short under your dash that's grounding out to me. I feel for you as that can be a real PITA to find.
Hellish Horse is offline   Reply With Quote
Old 07-17-2014, 01:52 AM   #3
Registered Member
Regular
 
racks2relax's Avatar
 
Join Date: Jul 2014
Location: San Jose
Region: California
Posts: 78
Same problem, make sure you pull up a diagram telling you how many amps per fuse. You could be running a 15 amp fuse on a 10 amp and can easily cause a fire. Since you already had the smoke signal you might have burned the wires.

Sent from my SM-N900P using Mustang Evolution mobile app
racks2relax is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-17-2014, 02:02 AM   #4
Registered Member
Regular
 
racks2relax's Avatar
 
Join Date: Jul 2014
Location: San Jose
Region: California
Posts: 78
After the smoke happened to me, I checked the fuses and turned out to be #4. Which leads to running taillights, turn signals, dash lights, and Cat Lights (headlight in side and out side smaller lights). Your headlights (middle part) should still operate, and when you hit the breaks the break lights should too. You have a short. Easiest way to fix it is take the dash apart and find the burned wires. I had a couple burnt together, and they led to my Light/defroster switch. Good luck!

Sent from my SM-N900P using Mustang Evolution mobile app
racks2relax is offline   Reply With Quote
Old 07-17-2014, 02:05 AM   #5
Registered Member
Regular
 
racks2relax's Avatar
 
Join Date: Jul 2014
Location: San Jose
Region: California
Posts: 78
Look for these signs!

Sent from my SM-N900P using Mustang Evolution mobile app
Attached Thumbnails
Click image for larger version

Name:	1405580676083.jpg
Views:	70
Size:	51.0 KB
ID:	161638   Click image for larger version

Name:	1405580704143.jpg
Views:	60
Size:	45.4 KB
ID:	161639  

racks2relax is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mechanical or electrical gauges? tedness Pre-2005 V6 Mustang 1 03-26-2005 01:44 PM
Trolls car and car audio Troll The Bar 26 03-23-2004 02:18 AM

» Like Us On Facebook



07:05 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.