Only sluggish under load and imitates exhaust leak - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT

Join Mustang Evolution Today

Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-29-2014, 02:13 AM   #1
Registered User
93_blown_lx's Avatar
Join Date: Jul 2014
Location: Boaz
Region: Alabama
Posts: 1
Exclamation Only sluggish under load and imitates exhaust leak

Hey guys, newbie here so I hope I may be able to help some fellow stangbangers as well as receive some much needed help at the current moment. I have a 93 lx with an endless list of bolt on mods including a P1SC Procharger and intercooler. This issue does not pertain to the procharger because it is currently unhooked at drive belt and my paramters were changed back to natural aspiration....such as tps voltage and regapped plugs not so tight etc etc. The car will idle beautifully and seems to be no misfire or slugging until it is under load. It sounds like an exhaust leak but its not because i have double and triple checked near everything.

Please help a fellow out guys! Thanks for your time!

93_blown_lx is offline   Reply With Quote
Old 08-05-2014, 08:18 AM   #2
Registered User
Infantry09's Avatar
Join Date: Aug 2011
Region: Missouri
Posts: 15
Maybe a new tune... Since ur not running the super charger. Or different injectors.

Sent from my iPhone using Mustang Evolution

Infantry09 is offline   Reply With Quote
Old 08-05-2014, 09:36 PM   #3
Registered Member
havhammer's Avatar
Join Date: Oct 2011
Region: Michigan
Posts: 119
Check your mass air meter.

Sent from my SPH-L710 using Mustang Evolution mobile app
havhammer is online now   Reply With Quote

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 1979-1995 Mustang GT


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant shift under high load. Combatman 2005-2010 V6 Mustang 11 09-06-2013 06:36 AM
04 Mach 1 stalling and occasional studder under load kevinfm91 1996-2004 Mustang GT 5 05-15-2013 09:23 AM
Shutters under load Rockpanama 1996-2004 Mustang GT 6 11-11-2012 01:42 PM
Engine popping under load Travis B 1979-1995 Mustang GT 6 07-02-2012 06:30 AM
Ticking under load MustangGT02 1996-2004 Mustang GT 13 01-18-2012 03:40 PM

» Like Us On Facebook

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

01:12 AM

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 is in no way associated with or endorsed by Ford Motor Company.